locked
Windows 7 Speech Recognition Error RRS feed

  • Question

  • Hi, I've been looking online for a fix to this problem but none of it seems to work for me =\
    Whenever I start up Voice Recognition it gives me this error

    Speech Recognition could not start because the language configuration is not supported...
    Then it tell me to check that the user interface language is the same as voice recognition.

    I've done the following to try and get this fix :

    1) Check the settings
    2) Changed locale language to something else then change it back to US
    3) Made sure my Mic was setup correctly

    And I also did some other things but it just won't work.

    Could anyone please help me solve this error

    I could train and do the tutorial just fine, it worked perfectly.

    Thursday, January 21, 2010 6:20 AM

Answers

  • Hi,

     

    This issue can be caused by Speech Recognition settings.

     

    I suggest performing the following steps:

     

    1. Go to Control Panel ->Speech Recognition

    2. Click Advance Speech options on the left panel.

    3. Change the Language to another option.

    4. Uncheck the "Review documents and mail to improve accuracy.

     

    If it does not work, change the Language back.

     

    If the issue persists, please update the sound card driver and BIOS to latest version.


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Wednesday, January 27, 2010 9:26 AM
    Friday, January 22, 2010 6:23 AM

All replies

  • bump
    Friday, January 22, 2010 2:53 AM
  • Hi,

     

    This issue can be caused by Speech Recognition settings.

     

    I suggest performing the following steps:

     

    1. Go to Control Panel ->Speech Recognition

    2. Click Advance Speech options on the left panel.

    3. Change the Language to another option.

    4. Uncheck the "Review documents and mail to improve accuracy.

     

    If it does not work, change the Language back.

     

    If the issue persists, please update the sound card driver and BIOS to latest version.


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Wednesday, January 27, 2010 9:26 AM
    Friday, January 22, 2010 6:23 AM
  • I have done all of that, and I am still having issues...anything else I can do, or is there a way you can provide a download for it?

    Saturday, January 30, 2010 6:28 PM
  • Nothing solved the problem.
    Why is this marked as answered?
    Saturday, February 6, 2010 6:19 AM
  • I'm currently having the same problem and none of the workarounds work.

    I'm on a new laptop that has Windows 7 Home Premium (64 Bit) Factory Installed.

    The training worked fine, but now it won't start up with the same language error.


    Thursday, February 11, 2010 5:58 AM
  • Did all of the above and it doesn't work the Speech Recognition still thinks it's on a different language then the rest of Window.

    Just tried it on Vista with no problems.
    • Proposed as answer by Mr. Jane Friday, June 25, 2010 11:34 AM
    Friday, February 19, 2010 9:55 AM
  • Hi There a simpile answer is

    You need the orignal windows 7 CD/DVD insert the disk into the drive and press: upgrade NOT the other optiion and reinstall you have to have the Product key to hand.

    It should take 45 minutes to do.

    No settings of your computer will be changes

    Friday, June 25, 2010 11:38 AM
  • I've had a similar problem in the past, not only has speech recognition displaying this error but I tryed to use my copy of office and had pretty much the same language error. I think it may be something to do with that Office causing the problem with the language settings either getting corrupted or damaged.

    J Washington
    Sunday, July 18, 2010 11:17 PM
  • Hello,

    I had the same problem. Strangely i had some other symptoms. I am using Turkish Q keyboard as primary and english U.S. as secondary. As my speech recognition broke down, i saw that my office word and outlook mulfunctioned in terms of keyboard language. I was able to use Turkish Q keyboard on any application but when i open up outlook or word, language changes to english.

    It used to happen on xp to.. so i enabled language bar to set it back to TR when i am using these applications. But language bar never displayed itself on taskbar or desktop. So i look for this problem and saw that you can fix this issue via regedit.

    go to   computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    right click the right pane and a "new string value" value name can be default, value data should be set to "ctfmon"="CTFMON.EXE"

    After that i rebooted my machine and language bar came to the taskbar. I went under the applications and change language back to TR. And there was a suprise for me. Long gone speech recognition was back at the top center of the screen. (i tried everything else that people suggested nothing worked)

    I am not sure but maybe language difference between applications caused my problem. Or maybe ctfmon caused it. Try this one.

    i hope this is the case for you and you can fix it too..

     

    • Proposed as answer by thoughtwords Monday, August 23, 2010 5:16 AM
    Tuesday, July 27, 2010 8:41 AM
  • This fix ABSOLOUTELY works...at least it did for me on 64 bit windows 7...thank you so much!
    Sunday, August 22, 2010 6:41 AM
  • This fix ABSOLOUTELY works...at least it did for me on 64 bit windows 7...thank you so much!

    +1 Same situation and worked for me first try. Thanks!
    Monday, August 23, 2010 5:16 AM
  • Have same issue ... found no solution. Works fine in german Ui. When change back to Eng US have the problem. MS must issue hotfix.
    Thursday, November 11, 2010 10:15 AM
  • I see no one has found this solution for a year.  Worked like a charm! I am hardly expert, and this was the first time I have ever used regedit, I think!  Thank you so much.  And why on earth hasn't this been put in the "help" files?
    Monday, November 7, 2011 7:51 PM
  • Hello,

    I had the same problem. Strangely i had some other symptoms. I am using Turkish Q keyboard as primary and english U.S. as secondary. As my speech recognition broke down, i saw that my office word and outlook mulfunctioned in terms of keyboard language. I was able to use Turkish Q keyboard on any application but when i open up outlook or word, language changes to english.

    It used to happen on xp to.. so i enabled language bar to set it back to TR when i am using these applications. But language bar never displayed itself on taskbar or desktop. So i look for this problem and saw that you can fix this issue via regedit.

    go to   computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    right click the right pane and a "new string value" value name can be default, value data should be set to "ctfmon"="CTFMON.EXE"

    After that i rebooted my machine and language bar came to the taskbar. I went under the applications and change language back to TR. And there was a suprise for me. Long gone speech recognition was back at the top center of the screen. (i tried everything else that people suggested nothing worked)

    I am not sure but maybe language difference between applications caused my problem. Or maybe ctfmon caused it. Try this one.

    i hope this is the case for you and you can fix it too..

    this is absoultly the solution to fix my problem please give it a try if you find that nothing else works... defently if the language bar doesnt show up properly.
    Wednesday, July 4, 2012 2:34 AM
  • Thank you so much!  You don't know how much I appreciate your help.  My speech recognition hasn't worked for a year.  I always received that stupid error message.  I followed your instructions word for word, letter for letter, and bingo it worked!  Happy Thanksgiving!
    Saturday, November 23, 2013 1:28 AM