locked
User not found in SharePoint application RRS feed

  • Question

  • Dear Friends,

    We have a Sharepoint 2007 application hosted on port 443 for LDAP users.

    One of my team memeber has been  facing "user not found" error for the last 1 week while uploading images on one of the subsite.

    He has full control to the complete application. He is also added as sitecollection administrator.Attaching the error message. 

    Error message:

     
    User cannot be found.   at Microsoft.SharePoint.SPUserCollection.get_Item(String loginName)
       at Microsoft.SharePoint.SPFile.get_ModifiedBy()
       at Microsoft.SharePoint.ApplicationPages.UploadPage.UploadFile(String& leafName, SPVirusCheckStatus& checkStatus, String& virusMessage)
       at Microsoft.SharePoint.ApplicationPages.UploadPage.UploadFile()
       at Microsoft.SharePoint.ApplicationPages.UploadPage.OnSubmit(Object o, EventArgs e)
       at System.Web.UI.HtmlControls.HtmlInputButton.OnServerClick(EventArgs e)
       at System.Web.UI.HtmlControls.HtmlInputButton.RaisePostBackEvent(String eventArgument)
       at System.Web.UI.HtmlControls.HtmlInputButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
       at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
       at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    Troubleshoot issues with Windows SharePoint Services.
    Thursday, January 16, 2014 7:24 AM

All replies

  • When you say application, is it custom application? can you please elaborate on that?

    Typically this error occurs when one of the artifacts that you have been using was created/modified by someone who no longer exist in the environment. E.g. user removed from AD or this application was created in DEV environment in separate AD etc. 

    So my recommendation is to check the entire process of uploading and if this is all out of the box then try and see if during image upload any of the image is being overwritten which was previously created/modified by someone who does not exist?


    Amit

    Thursday, January 16, 2014 10:40 AM
  • Hello,

    "user not found" typically comes when you work with person or group column. Is there any such column in that list/library if yes then make sure that you are entering valid user name.

    If you have setup user profile service then make a full crawl and then test it.

    Here is some similar threads for your ref:

    http://msexchange.me/2012/03/26/sharepoint-2007-user-not-found-error-while-assigning-quota-to-site-collection-2/

    http://soerennielsen.wordpress.com/2011/01/06/fixing-event-error-7888-%E2%80%9Cuser-not-found%E2%80%9D/


    Hemendra:Yesterday is just a memory,Tomorrow we may never see
    Please remember to mark the replies as answers if they help and unmark them if they provide no help

    Thursday, January 16, 2014 11:01 AM
    Moderator
  • This is an extended application of our main sharepoint web application. And it is created on port 443 (https) with zone as "internet". The user is able to do the modification everywhere in the site except one subsite. He was using it fine till 6th Jan. The user is uploading some fresh images. I have deleted and added the user again. But he is still facing the same isssue.
    Thursday, January 16, 2014 11:01 AM
  • Did you verify Hemendra's suggestions?

    Amit

    Thursday, January 16, 2014 11:07 AM
  • Hi,

    We have already checked it with full crawl. Still no use.

    We have following columns enabled for this library.

    Thursday, January 16, 2014 11:15 AM
  • I can see only Modified By column as person or group datatype. How about parallel Approval column type?

    Also verify that if you are able to open that user profile or not? You may refer this link:

    http://stackoverflow.com/questions/2017570/bad-user-profile-links-in-moss-2007-site-usage-summary-site-users


    Hemendra:Yesterday is just a memory,Tomorrow we may never see
    Please remember to mark the replies as answers if they help and unmark them if they provide no help

    Thursday, January 16, 2014 11:21 AM
    Moderator
  • Parallel approval shows the status of the workflow.

    And yes I am able to open user profile.

    Thursday, January 16, 2014 12:10 PM
  • Can you run one more test? Create a new picture or document library on the same site and ask user to upload the document on that library. If that works then at least we know the issue is related to the that particular library. If it does not work then issue is related to artifacts at the site level.

    Please share your findings.


    Amit

    Thursday, January 16, 2014 12:34 PM
  • If the issue is with library then all the users should get this error. But only one user is getting this.


    As already mentioned, he was able to upload the images few days back
    • Edited by Himanshu5205 Thursday, January 16, 2014 12:41 PM additional info
    Thursday, January 16, 2014 12:40 PM
  • we have tried with creating new library. Still the same issue.
    Thursday, January 16, 2014 1:03 PM
  • I missed the part where you said its an issue for single user and not for everyone and thank you for running the test.

    If the issue is related to the user I assume you verified that nothing has changed for the User in AD?

    To be honest I am not too sure what could be cause for this when a single user facing the issue on just one site and the user is fine on all the other sites. Given all the other users are able to access the site and upload the file without any issue then this might just be related to either User or File(s) that user is uploading. 

    If you are completely out of options then run few more tests. Ask user to upload the same file on different site or ask user to create a new document on one of the document library on trouble site. Don't upload just create a new file using template and save back to library.

    Please dont get mad at my suggestions but I am lost and just trying to help in case you are out of options. :)


    Amit

    Thursday, January 16, 2014 1:31 PM
  • User is able to upload the same file on different location.
    Thursday, January 16, 2014 1:49 PM
  • LOL. That is weird. I am sorry but I am out of options on this one. 

    Amit

    Thursday, January 16, 2014 2:49 PM