locked
SBS 2011 RWW Shared Folders Issues RRS feed

  • General discussion

  • We have just completed a clean install of SBS 2011 and all is working well with the exception of the shared folders in RWW. When a user logs on to RWW they see all of the folder shares, even the ones they do not have permission to access.

    Granted when they navigate through them they cannot access the restricted folders but they are all shown! even the system user shares etc.

    Is there something we are missing that just displays the folder shares the user has access to, rather than all of the folder shares?

    • Changed type Sean Zhu - Tuesday, February 15, 2011 7:44 AM no response
    Tuesday, February 8, 2011 7:54 AM

All replies

  • afaik, Windows has never hidden any folders unless there is a $ at the end of the share name.  Like you, I wish that it did, but it doesn't.  If you have experience with other versions or installations of SBS where the behaviour is different I would be greatful if you could point out the differences.
    Larry Struckmeyer

    Please post the resolution to your issue so that everyone can benefit

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, February 8, 2011 12:13 PM
  • Can you give us a list of all shares visible?

    On my default clean install, a standard user logs in and i can see:

    Public

    RedirectedFolders

    UserShares

    Is your goal then to hide shares users do not have access to?


    Robert Pearman SBS MVP (2010)
    Tuesday, February 8, 2011 2:53 PM
  • I have the same problem.

     

    I would also like to hide the Public, RedirectedFolders and UserShares by default.

     

    Thursday, February 17, 2011 4:23 PM
  • I too would like to hide the Public, RedirectedFolders, and UserShares.  Any luck on this issue?

     

    Thanks

    Monday, April 11, 2011 8:58 PM
  • Same problem to me...

    With SBS 2011 and Windows Seven, users doesn't see folders that he doesn't have access to (I would say in Explorer off course)

    But, with RWW, all folders are visible to all users (for exemple, I have a Direcftion's folder where all users can see all content of folder and subfolder but cannot open documents fortunatly)

    Is there any solution to hide this folder without hiding it (also for my director) with $ .

    Thanks

    Tuesday, April 12, 2011 7:52 AM
  • I have the same issue here,

     

    permissions are locked down on the server, those who have access to appropriate folders have access and those who dont, dont have access

     

    but if you log into rww as a use who doesnt have access you can see all the shares, access all the files.

    this is of major concern, so i have disabled rww file share access until resolved.

     

    has anybody managed to resolve this issue.

     

    many thanks

    Wednesday, June 1, 2011 8:27 AM
  • @computer-pc : nobody seems to know how to resolve the issue... (if micrososft consider it was a issue) Can you tell me how do you disable RWW file sharing ?

    Thanks

    Friday, June 17, 2011 9:06 AM
  • go into sbs console

    shared folders and web sites

    double click remote web access and the choose homepage links, un-tick file sharing.

    ms must have a fix for this soon.

    Thursday, June 30, 2011 2:47 PM
  • Monday, August 29, 2011 6:35 PM
  • In SBS 2011 you can enable Acess-Based Enumeration. This prevents users from seeing folders they do not have access to.

    http://support.microsoft.com/kb/961658
    Tuesday, May 8, 2012 4:07 AM
  • The easiest way to prevent shares from displaying in RWA is to use the SBS Consol, and under Shared Folders & Web Access, (only shared folders are displayed) you will note that the share permissions include "everyone" which seems to be SBS default for sharing, so just delete "everyone" from the share permission list, and add "authenticated users" or any other security group, and the share will be displayed on RWA but not accessible (different browsers give different messages, but they all boil down to - "you've not got access". (Its even more secure, than allow "everyone" to access the share, then trying to clip their wings...

    This will let you control who has access to which share folders by the preferred MS method of using roles as apposed to individual folder access setting, it's also far quicker when adding new users, and down grading others!!


    • Edited by Sam Adcock Tuesday, February 5, 2013 11:41 PM
    Tuesday, February 5, 2013 11:37 PM
  • Sam that didn't work for me.

    I have a shared folder where only 1 security group has any access, through shared folder permissions as you suggest.

    I am not part of that security group - yet I can see it

    However an Issue I have is, is I can not see any Files in the RWW - I can see all folders of everyone but it never lists me any files, even my own files.

    Tris

    Sunday, April 7, 2013 2:25 PM