locked
Wallpaper issues RRS feed

  • Question

  • Hi, this is my first time installing this on one of our public computers.  I am having an issue with the wallpaper staying.  I set it to the wallpaper I want and when I come back into the user profile it is back to no wallpaper.  I even unlocked everything in SteadyState, set the account as an admin and tried resetting the wallpaper and once I leave the profile and come back in, it's back to no wallpaper.  Please tell me how to get a wallpaper to stay on the user account.
    Saturday, July 14, 2007 3:32 PM

Answers

  • Hey Joshua,

     

    I ran into the same problem with the old MSCT. Try using a BMP image instead of a JPG. Ever since I started using BMP's, no more problems with desktop wallparer.

    Sunday, July 15, 2007 4:12 PM
  • Yes, Eparico is right.

     

    Based on my experiences, sometimes JPG wallpaper will not appear.

     

    By default windows changes any wallpaper to bmp format and loads it.

     

    This happens because while JPG's can be used as the desktop background, they are not used in JPEG format. Instead, normally, you select the JPEG and windows converts that to a Windows Bitmap and stores the converted image at %userprofile%\Local Settings\Application Data\Microsoft\Wallpaper1.bmp.

    To resolve this, use a bitmap (either one that is already a BMP or open the JPEG in Microsoft Paint and save it as a bitmap file)

     

    If the problem persists, please check the following:

     

    1. Can you see %userprofile%\Local Settings\Application Data\Microsoft\Wallpaper1.bmp?

      2. Create a new user, will the same issue occur?
    Tuesday, July 17, 2007 10:26 AM

All replies

  • Hey Joshua,

     

    I ran into the same problem with the old MSCT. Try using a BMP image instead of a JPG. Ever since I started using BMP's, no more problems with desktop wallparer.

    Sunday, July 15, 2007 4:12 PM
  • Yes, Eparico is right.

     

    Based on my experiences, sometimes JPG wallpaper will not appear.

     

    By default windows changes any wallpaper to bmp format and loads it.

     

    This happens because while JPG's can be used as the desktop background, they are not used in JPEG format. Instead, normally, you select the JPEG and windows converts that to a Windows Bitmap and stores the converted image at %userprofile%\Local Settings\Application Data\Microsoft\Wallpaper1.bmp.

    To resolve this, use a bitmap (either one that is already a BMP or open the JPEG in Microsoft Paint and save it as a bitmap file)

     

    If the problem persists, please check the following:

     

    1. Can you see %userprofile%\Local Settings\Application Data\Microsoft\Wallpaper1.bmp?

      2. Create a new user, will the same issue occur?
    Tuesday, July 17, 2007 10:26 AM
  • Yes, this was the issue.  Thank you very much.    -Josh
    Tuesday, July 17, 2007 1:14 PM
  • I would like to expand on this issue:

     

    I have noticed that when using JPEGs as a desktop background, that there is a "Default Overlay" that covers the image.

     

    In Display Properties go to the "Desktop" tab, select "Customize Desktop" then in the "Desktop Items" window go to the "Web" tab, check the "My Current Home Page". Hit "OK", then "Apply".

     

    Your default webpage should pop up to your desktop. If you are reading this chances are good that it covers a majority of your desktop. When you resize this window you will be pleased to find that your image is sitting behind it. When you remove the window through the options mentioned above the "overlay" will cover the image again.

     

    The "overlay" is typically the color selected for your desktop.

     

    I havn't figured out a way around this "overlay" other than to resize the webpage window to the smallest possible and set it off to the side.

     

    I believe that this has to do with Microsoft using the same technique that IE uses to display JPEGs in turn limiting JPEG desktops to the "Custom Desktop" rules.

     

    I enjoy the higher quality of JPEGs and will continue to use them this way until a fix is made.

     

    Thursday, January 1, 2009 1:33 PM