locked
Skype for Business 2015 and Exchange Server 2010 RRS feed

  • Question

  • Hi all!

    I installed Skype for Business Server 2015 locally, I can open my client and it has been register automatically with the Skype for Business Server.

    I enabled two test users, my user and my colleague one, but I'm not able to send him any messages and I can't see his availability status.

    Is there something to do in order to fix the problem?

    Thanks a lot!


    Alessandro Microsoft Forum

    Friday, March 11, 2016 11:15 AM

Answers

  • hi

    Can we just check check that the connectivity with exchange store is all working,we can  check the   Lync Server Storage Service status on a Front End Server

    Test-CsExStorageConnectivity -SipUri testuser@test.com -Binding NetTCP -DeleteItem -HostNameStorageService pool.domain.com

    More info  is discussed in this article for Lync 2013, same applied for SFB as well 

    http://blogs.technet.com/b/saleesh_nv/archive/2013/03/14/lync-2013-unified-contact-store-ucs-troubleshooting-tips.aspx




    Linus

    Monday, March 14, 2016 12:59 AM
  • Hi,

    UCS is not available if the user’s mailbox is hosted on Exchange Server 2010.

    https://technet.microsoft.com/en-us/library/jj205317.aspx?f=255&MSPPError=-2147217396

     

    In addition, you mentioned that you can’t see the contacts’ presence in outlook, can you check the MAPI and EWS status in Lync client?

    https://blogs.technet.microsoft.com/rmilne/2013/09/11/exchange-autodiscover-lync/

    http://lyncuc.blogspot.jp/2013/01/lync-and-exchange-web-services-ews-and.html

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Monday, March 14, 2016 3:20 AM

All replies

  • Hi Alessandro, 

    Both users are signed in and you can see them available isnt it? Did you try searching  that  user with his sip URI as well.

    Could be some replication issue but if its a lab environment , then we can check the running services , reboot etc. 


    Linus

    • Proposed as answer by Eric_YangK Thursday, March 17, 2016 1:19 PM
    Sunday, March 13, 2016 3:46 AM
  • Hi Linus,

    thanks a lot for your quick reply. I try as you suggested to search the other user using the sip name: username@domain and it works.

    Well, now I need to solve another problem: how can I choose the main users directory?

    I see that normally the client is using the "Personal contacts", how can I set by default the Exchange or the corporate user addressbook? I would like that if I'm looking for someone the first addressbook is the exchange one.

    The installation is in the productive environment.

    Thanks a lot for the support!!


    Alessandro Microsoft Forum

    Sunday, March 13, 2016 12:25 PM
  • Hi Linus,

    I forgot one information, when I write a new mail in Outlook 2016 and I insert the contact of my colleague, the status availability information is unknown.

    It seems that there is some connection problem between Exchange and Skype for Busines server or some configurations are missing.

    I'm not an expert and I follow the Microsoft instructions to install a Skype for Business Server Standard on a single Frontend server. 


    Alessandro Microsoft Forum

    Sunday, March 13, 2016 12:33 PM
  • Hi, 

    In this case you should be utilizing the Exchange Contact Store, where it explains the requirement that you require

    https://technet.microsoft.com/en-us/library/jj688083.aspx?f=255&MSPPError=-2147217396


    Linus

    Sunday, March 13, 2016 2:49 PM
  • If you are looking for Exchange to integrate with SFB  you should also go through this document where it also let you know about Unified Contact Store 

    https://technet.microsoft.com/en-us/library/jj721919%28v=ocs.15%29.aspx?f=255&MSPPError=-2147217396


    Linus

    Sunday, March 13, 2016 2:52 PM
  • Hi,

    Autodiscover is enable and running on the Exchange server and also the certificates are created correctly on both Exchange and Skype for Business Server.

    I run the following command succesfully: Set-CsOAuthConfiguration -Identity global -ExchangeAutodiscoverUrl "https://autodiscover.mydomain/autodiscover/autodiscover.svc"

    After doing the above, I check the Unified Contact Store:

    with the following command "Get-CsUserServicesPolicy -Identity global" I see that is set to True:

    Identity                  : Global
    UcsAllowed                : True
    MigrationDelayInDays      : 0
    EnableAwaySinceIndication : True

    But when I try to test if the user contacts are sucesfully migrated to the Unified Contact Store I get the following:

    Target Fqdn   : sfbserver.mydomain
    Result        : Failure
    Latency       : 00:00:01.8015312
    Error Message : Contacts notification was not received within 120 seconds.

    Diagnosis     :

    Of course, when I try to look for the other user in my Skype for Business client searching by the surname I can find his contact but without the availability status and the possibility to send for example IM. If I try to look for the other user searching by the sip I can find him correctly and I can see the availability status. Same situation also in Outlook client, when I create a new message I can't see the availability status when I type the recepient.

    Any other idea?

    Thanks a lot!


    Alessandro Microsoft Forum

    Sunday, March 13, 2016 5:49 PM
  • hi

    Can we just check check that the connectivity with exchange store is all working,we can  check the   Lync Server Storage Service status on a Front End Server

    Test-CsExStorageConnectivity -SipUri testuser@test.com -Binding NetTCP -DeleteItem -HostNameStorageService pool.domain.com

    More info  is discussed in this article for Lync 2013, same applied for SFB as well 

    http://blogs.technet.com/b/saleesh_nv/archive/2013/03/14/lync-2013-unified-contact-store-ucs-troubleshooting-tips.aspx




    Linus

    Monday, March 14, 2016 12:59 AM
  • Hi,

    UCS is not available if the user’s mailbox is hosted on Exchange Server 2010.

    https://technet.microsoft.com/en-us/library/jj205317.aspx?f=255&MSPPError=-2147217396

     

    In addition, you mentioned that you can’t see the contacts’ presence in outlook, can you check the MAPI and EWS status in Lync client?

    https://blogs.technet.microsoft.com/rmilne/2013/09/11/exchange-autodiscover-lync/

    http://lyncuc.blogspot.jp/2013/01/lync-and-exchange-web-services-ews-and.html

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.



    Monday, March 14, 2016 3:20 AM
  • Hi Alessandro Zamboni MTBIT,

    I’m writing to follow up on this thread. Do you have any updates on this issue? Please post back at your convenience.

     

    Best regards,

    Eric


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, March 17, 2016 1:20 PM
  • Hi Eric,

    thanks a lot for your reply.

    I have tried to follow the last two answers and it seems that it is working, but the SfB client takes on day to recognize the additional skype user and provide status availability information. What probably solved the problem is the settinngs regarding the autodiscover.

    I would also test the possibility to test the meeting function, but I need to configure it.


    Alessandro Microsoft Forum

    Thursday, March 17, 2016 1:34 PM