none
Always on Availability Group RRS feed

  • Question

  • I have two SQL nodes where AG is configured and two SCOM machines when i provide listener name it goes ok!

    but when i check that i can connect with my DB the folder does not show up it shows local drives and no

    specific firewall Ports are opened.

    Saturday, July 20, 2019 7:27 PM

All replies

  • Hi,

    What folder doesnt show here?  Can you provide a screenshot so I can understand?

    Thanks,

    Matt

    Saturday, July 20, 2019 8:04 PM
  • I setup two folders one for Operation Manager database and one for Logs on both AG replicas in C drive for database where SCOM DB is going to be store these folders does not show during SCOM install it goes to local hard drive but should go to replicas database folder.
    Sunday, July 21, 2019 7:04 AM
  • Hi aqeel_xpp,

    >> SCOM DB is going to be store these folders does not show during SCOM install it goes to local hard drive but should go to replicas database folder.

    During setup, did you set the data file and log file location that you want or accept the default values?  Please refer to Deploying System Center Operations Manager.

    If I misunderstood, please let me know.

    Best regards,
    Cathy Ji

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, July 22, 2019 6:17 AM
  • It sounds like you may have configured an FCI (Failover Cluster Instance) and not configured SQL server service to be dependent on the shared storage you have presented to this cluster.

    This link shows you how to do that:

    https://www.sqlshack.com/how-to-add-a-new-disk-to-an-existing-sql-server-failover-clustered-instance/

    If you are using a SQL Server Always on Availbility Group, you should have identical storage on both nodes and your installation program should see both drives and folders. You are experiencing another issue and will need to reach out to the Operation Manager team.

    Monday, July 22, 2019 1:42 PM