locked
Pipeline Tracing not producing files RRS feed

  • Question

  • Trying to check Transport Agents on a test server (Exchange 2007 SP3 Update 5) using the following commands :-

    Set-TransportServer Exch1 -PipelineTracingSenderAddress "simon@somewhere.com"
    Set-TransportServer Exch1 -PipelineTracingEnabled $True
    Set-TransportServer Exch1 -ContentConversionTracingEnabled $True
    the PipelineTracingPath is left to the default value.

    An email sent from simon@somewhere.com works correctly and the files and folders are created correctly.

    When I change the PipelineTracingSenderAddress to "<>" using :-

    Set-TransportServer Exch1 -PipelineTracingSenderAddress "<>"

    and stop and start the MS Exchange Transport service no files and folders are created for the new messages. Changing back to a specified address works correctly again.

    Any help appreciated.

    • Edited by KiwiSimon1 Monday, February 27, 2012 3:21 AM
    Monday, February 27, 2012 3:20 AM

Answers

  • If you want to generate log files for messages generated by e-mail servers, such as automatic replies, delivery status notification (DSN) messages, journal reports, and other system-generated messages, you can specify the value "<>" with the PipelineTracingSenderAddress parameter.

    What are you trying to capture, a sender/recipient address of a user?


    Sukh

    • Proposed as answer by Sukh828 Wednesday, February 29, 2012 11:09 AM
    • Marked as answer by Evan LiuModerator Monday, March 5, 2012 10:05 AM
    Monday, February 27, 2012 11:02 PM
  • Hello Kiwisimon1,

    I use "<>" to test in my lab, I can see the file created for the NDR message.

    When you change the PipelineTracingSenderAddress to "<>" , it just go to generate log files for Journal reports, automatic replies, NDRs and so on.

    The command "Set-TransportServer Exch1 -PipelineTracingSenderAddress "<>" " is used to configure <> as the pipeline tracing sender address on the Server Exch1 computer, if no this message has been generated by Exch1 (after you change the setting), you will not see the log files.

    Here is a related document for you:

    Enable Pipeline Tracing
    http://technet.microsoft.com/en-us/library/bb125018.aspx

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    Wednesday, February 29, 2012 6:09 AM
    Moderator

All replies

  • If you want to generate log files for messages generated by e-mail servers, such as automatic replies, delivery status notification (DSN) messages, journal reports, and other system-generated messages, you can specify the value "<>" with the PipelineTracingSenderAddress parameter.

    What are you trying to capture, a sender/recipient address of a user?


    Sukh

    • Proposed as answer by Sukh828 Wednesday, February 29, 2012 11:09 AM
    • Marked as answer by Evan LiuModerator Monday, March 5, 2012 10:05 AM
    Monday, February 27, 2012 11:02 PM
  • Hello Kiwisimon1,

    I use "<>" to test in my lab, I can see the file created for the NDR message.

    When you change the PipelineTracingSenderAddress to "<>" , it just go to generate log files for Journal reports, automatic replies, NDRs and so on.

    The command "Set-TransportServer Exch1 -PipelineTracingSenderAddress "<>" " is used to configure <> as the pipeline tracing sender address on the Server Exch1 computer, if no this message has been generated by Exch1 (after you change the setting), you will not see the log files.

    Here is a related document for you:

    Enable Pipeline Tracing
    http://technet.microsoft.com/en-us/library/bb125018.aspx

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    Wednesday, February 29, 2012 6:09 AM
    Moderator