locked
.NET Framework 1.1 SP 1 compatibility with Windows 7 Ultimate RC/RTM RRS feed

  • Question


  • I know for a fact that Framework 1.1 SP 1 is compatible with Windows Vista , however is .NET 1.1 SP 1 fully compatible on Windows 7? . I have  a couple of clients that are complaning of issues with applications that had worked before but now have issues on Windows 7

    My second question is that Windows 7 comes pre-installed with Framework 3.5 right? then why are Framework 2.0 binaries also installed when 3.5 is backwards compatible with 2.0?


    C# Fan! ananda84(at)gmail(dot)com
    Friday, August 7, 2009 12:01 PM

Answers

  • Quick Test revels this:

    On Vista
    #1  Install .Net Framework 1.1. It shows .Net framework installed successfully.
    #2 Run .Net Framework Verification Utility & Choose Product To Verify ".Net framework 1.1" --- It shows "Product Verification Succeeded"

    On Windows 7 RC
    #1  Install .Net Framework 1.1. It shows .Net framework installed successfully.
    #2 Run .Net Framework Verification Utility & Choose Product To Verify ".Net framework 1.1" --- It shows "Product Verification Failed"
    Log file shows  several classes registry keys are missing.

    So, it looks like atleast some (or it could be most - not enough data) .Net 1.1 apps that would have worked on Vista are not going to work on Windows 7.





    http://www.NathCorp.Com
    • Marked as answer by Ananda Ganesh Saturday, August 8, 2009 4:53 AM
    Friday, August 7, 2009 6:16 PM