locked
Message Moderation in Exchange 2010 transport Rule RRS feed

  • Question

  • Exchange 2010

    Currently have a transport Rule that sends messages to a moderation account if the header value of Received-SPF:  is SoftFail or PermError.  This is working ok however I would like to increase the timeout for the moderation messages from 2 day to 4 or 7 days.   Have not found where to modify this.

    Thanks

    Rick

     

    Friday, October 4, 2013 5:43 PM

All replies

  • So the real answer may be that, currently, there's not a way to adjust it (answer from Andy D mentioned below)

    UPDATE #2: You probably already found this, but it does give some more detail, even showing some commands that may be of value:

     Technet posting on Moderation Expiration

    In the above link, "mark98765's" comments may be of use:

    "This seems to have done the trick:

    Set-RetentionPolicyTag moderatedrecipients -RetentionAction DeleteAndAllowRecovery
    Set-RetentionPolicyTag autogroup -RetentionAction DeleteAndAllowRecovery

    FYI this was never set/changed by me so i'm wondering if there is a problem with SP1 not changing this to an acceptable value."

    Looks like, from the above, IF it were possible, you would set the "AgeLimitForRetention" parameter.

    The "ModeratedRecipients" tag is set as folllows:

    Description : Managed Content Settings
    RetentionEnabled : True
    RetentionAction : MoveToDeletedItems
    AgeLimitForRetention : 5.00:00:00

    There may be at least one additional parameter you would set. I would suggest that you run "procmon"  in 'capture' mode and then set an arbitation policy as mentioned in the above posting, and then filter/search for "AgeLimitForRetention" and see if it has a clearly-related registry key. Alternatively, search the registry on your Exchange server for that Key. This may be unsupported and undocumented, but it may well work - USE WITH CAUTION, AT OWN RISK.

    Is this of any value - regarding setting the various Exchange Message features:

    Configure Message... [features]

    Can be done via EAC or via Powershell:

    powershell

    ps> Set-TransportService <ServerIdentity> -MessageExpirationTimeout <dd.hh:mm:ss>

    # Or, This example changes the message expiration timeout interval to 4 days on the Exchange server named Mailbox01
    ps> Set-TransportService Mailbox01 -MessageExpirationTimeout 4.00:00:00

    If so, please remember to "Mark as Answer." Thanks!


    UPDATE: Suposedly the default is 5 days: If the moderator doesn't respond to the message within five days, the Information Assistant will delete the message from the arbitration mailbox and notify the sender that their message has expired. Source: Microsoft message flow moderation http://technet.microsoft.com/en-us/library/dd297936(v=exchg.150).aspx#Flow

    tnjman

    FYI, your question wasn't completely clear, so I wasn't absolutely positive which feature you meant.

    Similar also to Andy-D's response here: http://social.technet.microsoft.com/Forums/exchange/en-US/b4ec573a-3886-4015-8128-efbfed212059/exchange-moderator-feature?forum=exchange2010

    Andy D said: "Hmmm, using Office 365 by chance? If not then the Office 365 logic has crept in. I'm not aware of any way to adjust it"

    http://technet.microsoft.com/en-us/exchangelabshelp/dd630704

    Expiration for messages waiting for moderation By default, a message waiting for moderation expires after two days. However, the processing of expired moderated messages runs every seven days. This means that a moderated message can expire at any time between two and nine days.


    Friday, October 4, 2013 5:52 PM
  • Not using Office 365 so looks like those commands don't fly on exchange 2010.

    However did find

    Get-TransportServer | Set-TransportServer -MessageExpirationTimeout 5.00:00:00

    Now have to wait 3 days to see if that works.

    Friday, October 18, 2013 9:37 PM
  • Glad you found that but my example/answer from Oct 4 did include a variant of that command:

    powershell
    
    ps> Set-TransportService <ServerIdentity> -MessageExpirationTimeout <dd.hh:mm:ss>
    
    # Or, This example changes the message expiration timeout interval to 4 days on the Exchange server named Mailbox01
    ps> Set-TransportService Mailbox01 -MessageExpirationTimeout 4.00:00:00


    It wasn't clear whether or not you wanted to set it "server-wide" or via an individual mailbox/account, since you mentioned "...messages to [A] moderation account" in your original posting.


    tnjman

    OK - "GetTransportServer" vs. "Service" - so, my source may have been incomplete/incorrect or maybe in reference to O365.

    Correct for standalone would have been, as you said, "Get-TransportServer" and, I am guessing: "Set-TransportServer" - thanks for finding/clarifying - I was close. ;-)

    • Edited by TNJMAN Monday, October 21, 2013 6:57 PM update
    Monday, October 21, 2013 6:53 PM
  • Messages still expire after 2 days. So that didn't fix it either.

    Monday, October 21, 2013 6:54 PM
  • Has everything been rebooted/restarted? Some parameters may not take effect immediately.

    Otherwise, my other answer was likely correct: This feature cannot yet be modified.


    tnjman

    Wednesday, October 23, 2013 5:18 PM
  • Sorry for the lag. Settings didn't work.

    Yes They were rebooted

    Friday, April 11, 2014 6:22 PM