none
Windows 8.1 not letting me change my default search provider RRS feed

  • Question

  • I recently upgraded my PC to Windows 8.1 and I am trying to set Google as my default search engine in Internet Explorer. I’ve worked through the process of changing this to Google but it’s not working. I click the ‘add to internet explorer’ button and nothing happens, I got someone to test on a Windows 7 PC and they get a pop-up saying ‘Do you want to add this search provider?’ However on my Windows 8.1 machine this pop-up doesn’t appear.

    Friday, August 1, 2014 9:19 AM

Answers

  • Hi,

    You need to use the Desktop version of IE on Windows 8 to add addons or your System Administrators have applied settings to your computer to stop you adding unauthorized addons or search providers.

    From Immersive IE you can use the Search Anywhere feature from the Charms bar. Right swipe to display the Charms bar.

    If you have the Google Toolbar installed.. then their Search Provider is already installed. Tools>Manage Addons (from Desktop IE) >Search Providers to view and manage the Search Providers that have already been installed.

    This forum is for

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com


    Rob^_^


    Friday, August 1, 2014 8:12 PM
  • Hi,

    After you get to the “Manage add-ons” item, you can add more search provider in the following way:

    1. Go to Search Provider, and then at the bottom part, click “Find more search providers…” just like the screenshot below:

    2. Find the Google provider and choose the one, you can set it as a default by clicking at the right corner of the pane as the screenshot below:

    Regards


    Wade Liu
    TechNet Community Support

    Tuesday, August 5, 2014 10:04 AM

All replies

  • Hi,

    You need to use the Desktop version of IE on Windows 8 to add addons or your System Administrators have applied settings to your computer to stop you adding unauthorized addons or search providers.

    From Immersive IE you can use the Search Anywhere feature from the Charms bar. Right swipe to display the Charms bar.

    If you have the Google Toolbar installed.. then their Search Provider is already installed. Tools>Manage Addons (from Desktop IE) >Search Providers to view and manage the Search Providers that have already been installed.

    This forum is for

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions. If you are a consumer looking for answers or to raise a question, it's highly recommended you head on over to http://answers.microsoft.com


    Rob^_^


    Friday, August 1, 2014 8:12 PM
  • Hi,

    After you get to the “Manage add-ons” item, you can add more search provider in the following way:

    1. Go to Search Provider, and then at the bottom part, click “Find more search providers…” just like the screenshot below:

    2. Find the Google provider and choose the one, you can set it as a default by clicking at the right corner of the pane as the screenshot below:

    Regards


    Wade Liu
    TechNet Community Support

    Tuesday, August 5, 2014 10:04 AM