none
Set a default associations configuration file - Windows 10 1607

    Question

  • Hi i am attempting to use the setting Set a default associations configuration file under Computer Configuration > Administrative Templayes > Windows Components > File Explorer to set Internet Explorer 11 as the default web browser in Windows 10 as per this article https://technet.microsoft.com/en-us/itpro/internet-explorer/ie11-deploy-guide/set-the-default-browser-using-group-policy

    I am doing this on Windows 10 1607 (Build 14393.447). On a clean reference system I launched default Programs and set Internet Explorer as the default web browser.

    I then used Dism to export the default applications definition to an XML file called apps.xml in C:\WINDOWS.

    I then reset the default web browser back to Edge. I then fired up local policy editor (gpedit.msc) and set the aforementioned setting to point to this file, ensuring everyone had permission to read the file.

    I created a new standard user account locally on the machine. I ran gpupdate /force and rebooted. I logged in as administrator expecting to see Internet Explorer as the default web browser but it was set to Edge. I logged out and then logged in for the first time as the new user and expected to see Internet Explorer as the default browser but instead it's edge.

    Running gpresult /h and reviewing the policy shows that the setting is applied (it's the only configured setting). I can only assume that the fault lies with the XML file. Here is a copy of the XML file.

    <?xml version="1.0" encoding="UTF-8"?>
    <DefaultAssociations>
      <Association Identifier=".htm" ProgId="IE.AssocFile.HTM" ApplicationName="Internet Explorer" />
      <Association Identifier=".html" ProgId="IE.AssocFile.HTM" ApplicationName="Internet Explorer" />
      <Association Identifier=".mht" ProgId="IE.AssocFile.MHT" ApplicationName="Internet Explorer" />
      <Association Identifier=".mhtml" ProgId="IE.AssocFile.MHT" ApplicationName="Internet Explorer" />
      <Association Identifier=".partial" ProgId="IE.AssocFile.PARTIAL" ApplicationName="Internet Explorer" />
      <Association Identifier=".svg" ProgId="IE.AssocFile.SVG" ApplicationName="Internet Explorer" />
      <Association Identifier=".url" ProgId="IE.AssocFile.URL" ApplicationName="Internet Browser" />
      <Association Identifier=".website" ProgId="IE.AssocFile.WEBSITE" ApplicationName="Internet Explorer" />
      <Association Identifier=".xht" ProgId="IE.AssocFile.XHT" ApplicationName="Internet Explorer" />
      <Association Identifier=".xhtml" ProgId="IE.AssocFile.XHT" ApplicationName="Internet Explorer" />
      <Association Identifier="FTP" ProgId="IE.FTP" ApplicationName="Internet Explorer" />
      <Association Identifier="http" ProgId="IE.HTTP" ApplicationName="Internet Explorer" />
      <Association Identifier="https" ProgId="IE.HTTPS" ApplicationName="Internet Explorer" />
      <Association Identifier="MK" ProgId="IE.HTTP" ApplicationName="Internet Explorer" />
      <Association Identifier="RES" ProgId="IE.HTTP" ApplicationName="Internet Explorer" />
    </DefaultAssociations>

    It is fairly straightforward XML so am not entirely sure what I could be doing wrong or if this setting is just no longer supported in Windows 10 1607?

    Can anyone help or offer some guidance? Web searches are flooded with info that is outdated or irrelevant so haven't been much help so far.

     


    • Edited by d4rkcell Thursday, November 17, 2016 9:50 AM
    Thursday, November 17, 2016 9:44 AM

All replies

  • Hi,

    Try to put the XML file to a shared folder and configure related permission on it, and configure the setting Set a default associations configuration with UNC path.

    Here is an article below for your reference.

    Set Internet Explorer as the default browser in Windows 10 with Group Policy

    https://4sysops.com/archives/set-internet-explorer-as-the-default-browser-in-windows-10-with-group-policy/

    Best Regards,

    Jay


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 18, 2016 9:03 AM
    Moderator
  • Hi Jay, thanks for that I will give it a try. I also discovered that modifying OEMDefaultAssociations.xml in the base image with the appropriate entries from the dism command does it without the need to use group policy. I am pretty sure it would be better using group policy but wanted to highlight there is another approach :)

    Thanks again

    Friday, November 18, 2016 10:45 AM
  • Did you ever fix this? I can see the GPO applied if i do a RSOP, but it isnt actually working :( !
    Thursday, March 02, 2017 5:28 PM
  • Did you ever fix this? I can see the GPO applied if i do a RSOP, but it isnt actually working :( !
    Hi, no like i said i ended up modifying the OEMDefaultassociations.xml file on the image. I guess you could also replace this file during OSD or something or maybe using a preference item? Give it a try.
    Friday, March 03, 2017 9:36 AM
  • Also just wanting to add that this is also not working for me either, so this GPO looks like it is not functioning correctly with 1607.

    The only workaround for now maybe to add this into the image, which isn't great since the client may change their minds at a later date.

    Monday, March 06, 2017 4:18 PM
  • I had the same problem where I'd set the GPO with my default associations file and it wasn't applying. What ended up working for me was changing the file extension from .xml to .txt. Hope this helps anyone else having this problem.

    Jeremy

    • Proposed as answer by Jack Pearce Tuesday, May 09, 2017 3:27 PM
    Friday, April 07, 2017 3:34 PM
  • Perfect, changing the extension from .xml to .txt worked for me
    Tuesday, May 09, 2017 3:28 PM
  • Unfortunately renaming xml to txt didn´t work for me. I renamed it on GPO, changed version, and ensured that new GPO is applied and the file is copied in C:\Windows\System32 as txt, fine.. but the file assosiotion didn´t change...

    Please remember to mark my post as an answer, if I really helped you out, or vote if usefull. Thank you!

    Monday, August 21, 2017 12:25 PM
  • We had the following problem with the DefaultAssociations

    We only want to set de default settings once, and let a user change it if they want to, but if you use the method as described as in https://docs.microsoft.com/en-us/internet-explorer/ie11-deploy-guide/set-the-default-browser-using-group-policy 
    it will be set every time a computer starts up.

    Therefor we made a small change
    We don’t load the DefaultAssociations.xml in a GPO from (Computer Configuration > Administrative Templayes > Windows Components > File Explorer ) 
    But with user preferences and item-level targeting


    Create 3 entry’s
    1 : 
    Order 1
    Action : Update
    Hive : HKEY_LOCAL_MACHINE
    Key SOFTWARE\Policies\Microsoft\Windows\System\DefaultAssociationsConfiguration
    Value name : DefaultAssociationsConfiguration
    Value data : \\....\DefaultAssociations.xml
    Item-Level targeting : the string registry value at HKCU\Software\Helicon\DefaultAssociationsConfiguration does not exist or does not have value data 1

    2:
    Order 2
    Action : Delete
    Hive : HKEY_LOCAL_MACHINE

    Key SOFTWARE\Policies\Microsoft\Windows\System\DefaultAssociationsConfiguration
    Value name : DefaultAssociationsConfiguration
    Value data : \\....\DefaultAssociations.xml
    Item-Level targeting : the string registry value at HKCU\Software\Helicon\DefaultAssociationsConfiguration does exist or does not have value data 1


    3 : 
    Order 3
    Action : Update
    Hive : HKEY_CURRENT_USER
    Key SOFTWARE\Policies\Microsoft\Windows\System\DefaultAssociationsConfiguration
    Value name : DefaultAssociationsConfiguration
    Value data : \\....\DefaultAssociations.xml
    Item-Level targeting : the string registry value at HKCU\Software\Helicon\DefaultAssociationsConfiguration does not exist or does not have value data 1


    If a new user log’s on : 
    Entry 1 places the DefaultAssociations.xml entry in the register
    Entry 2 does noting
    Entry 3 places a counter of a marker in the users register, which we will use for future logons

    If an existing user log’s on :
    Entry 1 does noting 
    Entry 2 removes the DefaultAssociations.xml entry in the register
    Entry 3 does noting 



    • Edited by Tom Backx Wednesday, August 30, 2017 10:08 AM typo
    Wednesday, August 30, 2017 10:07 AM
  • I stored the XML file under \\domain.com\netlogon but still couldn't get the GPO to apply.  Then I changed the file to a .txt file.  Still no luck.  Finally, what fixed it for me was removing the quotes around the path in the "Set a default associations configuration file" GPO.
    Thursday, October 12, 2017 9:46 PM
  • Hi Tom,

    Did you set this under the User policy or computer policy?

    Thanks

    Wednesday, February 07, 2018 1:32 PM
  • Just a nice idea, there is a location where policies are stored: SYSVOL, located in \\<domain name>\SYSVOL\<domainname>\Policies. In that folder (which is replicated on all DC's!) we simply created a 'Files' folder to hold all policy-related files, scripts, icons, and so on. This is lots better than using the GPO's internal Scripts folders, as in this way you can export and import GPO's without having to change script-paths each time.

    Also the replication is a nice additional feature here!

    Thursday, February 22, 2018 4:02 PM
  • > \\<domain name>\SYSVOL\<domainname>\Policies. In that folder (which is replicated on all DC's!) we simply created a 'Files'

    I would advise not to use "Policies"; but "Scripts" instead. The scripts folder is also shared as "NETLOGON" and its initial purpose is exactly "holding scripts and additional files".

    This folder also is the base folder for user scripts you assign to accounts in active directory without specifying a full path.

    Friday, February 23, 2018 9:09 AM
  • Hi,

    I was having a similar issue where the GPO for setting a default associations file wasn't working.  In my case I had <!-- comments --> as the first row of the XML file.  Removing the comments resolved it for me.

    20 hours 40 minutes ago