locked
How can multiple folders change to the same name? RRS feed

  • Question

  • Hello:

    About 2 weeks ago, two of our shared folders both became named "Documents". The top one should be named "User" and the bottom one named "File Room". The share names have remained in place allowing users to still access then via share name, but I am boggled by this.

    In addition, I can create a third folder in there named "Documents" and it lets me. Is there a way to undo this easily?

    Thanks

    Tuesday, August 28, 2012 5:42 PM

Answers

  • Hi,

    > The share names have remained in place allowing users to still access then via share name, but I am
    > boggled by this. In addition, I can create a third folder in there named "Documents" and it lets me

    Although these two folders are not redirect folders, I think it’s caused by the same reason in KB947222.

    Can you create fourth folder in that location named “Documents”?

    You can try workaround mentioned in that KB:

    Method 3:

    Do not grant the Read permission to the administrator for the Desktop.ini files on the server. To do this, follow these steps:

    Note: If more than one Desktop.ini file exists, follow these steps for all the Desktop.ini files.

    1. Right-click the Desktop.ini file, click Properties, and then click the Security tab.

    2. In the Group or user names pane, click Administrators.

    3. Click to select the Deny check box for the Read permission.

    4. Click OK.

    Please try that and give us feedback for further troubleshooting.

    For more information please refer to following MS articles:

    When you redirect the Documents folder on a Windows Vista-based or Windows 7-based computer to a network share, the folder name unexpectedly changes back to Documents
    http://support.microsoft.com/kb/947222


    Hope this helps!

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Lawrence

    TechNet Community Support

    • Marked as answer by Lawrence, Thursday, September 6, 2012 2:30 AM
    Thursday, August 30, 2012 9:15 AM
  • I followed your suggestion, rebooted the server and the folder names changed back to what they should have been. So in this case, just a reboot fixed it or the combination of the desktop.ini plus the reboot fixed it.

    Thanks for the help!

    • Marked as answer by Lawrence, Thursday, September 6, 2012 2:31 AM
    Wednesday, September 5, 2012 2:27 PM

All replies

  • Steinomite,

    This actually a documented issue with Group policy and folder redirection. You will also notice that Pictures, Videos, etc are duplicated as well.

    See: http://support.microsoft.com/kb/2533930

    The reasoning is that the Default User Profile creates the directories, while the redirected folders are still displaying. This means that you have 1 local and 1 redirected copy of the folder -- Its an "undocumented feature" so to speak.

    To change this, you have to update the group policy setting that is controlling Folder Redirection. [User Configuration\Policies\Windows Settings\Folder Redirection\]

    Right click folder > Select Properties > Check the following items.

    Enable "Grant the user exclusive rights to Documents."

    Enable "Move the contents of Documents to the new location"

    Here's the article that explains it: http://technet.microsoft.com/en-us/library/cc782799(v=ws.10).aspx

    Please feel free to ask further questions.

    -Brenton

    • Proposed as answer by Brent Blawat Tuesday, August 28, 2012 8:12 PM
    • Unproposed as answer by Brent Blawat Wednesday, August 29, 2012 2:59 PM
    Tuesday, August 28, 2012 7:03 PM
  • Unfortunately, I don't think this is the issue. These folders have existed for more years than I have worked here (5+) and they have always been named "User" and "File Room". We do not have any policy in place to redirect to/from this folder. The two folders are shared directory’s on a file server that many people have access to. These folders do not reside in the users profile.

    Something changed on our system that caused these folders to be renamed as the same thing, although they have different share names and completely different content.

    Thanks

    Tuesday, August 28, 2012 9:11 PM
  • Hello,

    please see http://support.microsoft.com/kb/947222


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.

    Wednesday, August 29, 2012 10:09 AM
  • Steinomite,

    Are these files on a SAN / NAS?

    How do you do your OS Deployment? Do you use USMT?

    -Brenton

    Wednesday, August 29, 2012 3:02 PM
  • Hi Meinolf - This doesn't apply to me. We are not using folder redirection to this location.

    Brenton - These folders are on a iSCSI attached drive to an HP LefHand SAN. In the old days (and in the case of this server) it was deployed using a VMWare template about 4 years ago. Now we deploy them using the standard Windows ISO file downloaded from out VL site. We don't use USMT.

    Thanks


    • Edited by Steinomite Wednesday, August 29, 2012 7:54 PM
    Wednesday, August 29, 2012 7:53 PM
  • Hi,

    > The share names have remained in place allowing users to still access then via share name, but I am
    > boggled by this. In addition, I can create a third folder in there named "Documents" and it lets me

    Although these two folders are not redirect folders, I think it’s caused by the same reason in KB947222.

    Can you create fourth folder in that location named “Documents”?

    You can try workaround mentioned in that KB:

    Method 3:

    Do not grant the Read permission to the administrator for the Desktop.ini files on the server. To do this, follow these steps:

    Note: If more than one Desktop.ini file exists, follow these steps for all the Desktop.ini files.

    1. Right-click the Desktop.ini file, click Properties, and then click the Security tab.

    2. In the Group or user names pane, click Administrators.

    3. Click to select the Deny check box for the Read permission.

    4. Click OK.

    Please try that and give us feedback for further troubleshooting.

    For more information please refer to following MS articles:

    When you redirect the Documents folder on a Windows Vista-based or Windows 7-based computer to a network share, the folder name unexpectedly changes back to Documents
    http://support.microsoft.com/kb/947222


    Hope this helps!

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Lawrence

    TechNet Community Support

    • Marked as answer by Lawrence, Thursday, September 6, 2012 2:30 AM
    Thursday, August 30, 2012 9:15 AM
  • Hi,

    I would like to confirm what is the current situation? Have you resolved the problem?

    If there is anything that we can do for you, please do not hesitate to let us know, and we will be happy to help.


    Lawrence

    TechNet Community Support

    Monday, September 3, 2012 2:50 AM
  • I followed your suggestion, rebooted the server and the folder names changed back to what they should have been. So in this case, just a reboot fixed it or the combination of the desktop.ini plus the reboot fixed it.

    Thanks for the help!

    • Marked as answer by Lawrence, Thursday, September 6, 2012 2:31 AM
    Wednesday, September 5, 2012 2:27 PM
  • Hi,

    Thanks for sharing your experience!

    You experience and solution can help other community members facing similar problems.

    Thanks for your contribution to Windows Server Forum!

    Have a nice day!

    Lawrence

    TechNet Community Support

    Thursday, September 6, 2012 2:31 AM