none
Windows 2012 RDS configuration issues - "your computer can't connect to the remote computer because the Remote Desktop Gateway is temporarily unavailable" RRS feed

  • Question

  • Here is the configuration;

    RDS-1.domain.com  - 10.10.10.1 = Connection Broker
    RDS-2.domain.com  - 10.10.10.2 = Gateway (3rd party SSl certificate installed)
    RDS-3.domain.com  - 10.10.10.3 = Session/Virtualization Host
    RDS-4.domain.com  - 10.10.10.4 = Web Access (3rd party SSl certificate installed)

    I can connect using RDS-2.domain.com internally with no issues configuring the RDS Gateway settings on the RDP client OR when I login to the Web interface. IIS is configured on RDS-2.domain.com and RDS-4.domain.com for binding on 443 using the correct 3rd party SSL certificate and has the FQDN set. The Router/Firewall has port 443 set to route incoming traffic to RDS-4 and 3389 to RDS-2. I can use a browser to connect to RDS-4.domain.com and I login with no issues, but when I click on a app I get;

     Your computer can't connect to the remote computer because the Remote Desktop Gateway
     is temporarily unavailable. Try reconnecting later or contact your network
     administrator for assistance.

    When I configure the RDP client for RDS-2.domain.com in the RDS Gateway configuration I get;

     Your computer can't connect to the remote computer because the Remote Desktop Gateway
     is temporarily unavailable. Try reconnecting later or contact your network
     administrator for assistance.

    I have configured RD CAP and RD RAP policies and have the SSL Certificate selected. SSL bridging is unchecked. Internal and External DNS is configured and working correctly. The RDS Gateway services are running, it sees and connects to the other servers as well as Active Directory. Do I need to open additional ports on my router/firewall? 


    Thursday, April 4, 2013 8:29 PM

Answers

All replies

  • Additionally, If I access RD Web access remotely and try to connect "Connect to a remote PC" I get;

    Remote Desktop can't connect to the remote computer for one of the following reasons:

    1) Remote access to the server is not enabled
    2) The remote computer is turned off
    3) The remote computer is not available on the network

    Make sure the computer is turned on and connected to the network, and that remote access is enabled.

    Again, if I do this internally I have no issues.  The "Computers" in question are virtualized in a collection(s) on the RD session/virtualization server. This is also the case when I try and access other computers that are not part of the virtualized collection. 

    Thursday, April 4, 2013 9:56 PM
  • Can I assume the internal FQDN and the Internet FQDN are different? If yes, we may have two fixes. 1. Add the Internet FQDN to teh Gateway. 2. Create internal DNS A record pointing to public IP address. This search result may help too.

    This computer can't connect to the remote computer because the RD ...

    ... can't connect to the remote computer because the RD Gateway server is unavailable ... because the Terminal Services Gateway server is temporarily unavailable. ... To fix it, please follow this link: Configure Remote Desktop Gateway Settings ... in your local DNS record so that the users can access RemoteApp using the ...
    www.chicagotech.net/remoteissues/remoteapp3.htm

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com

    Thursday, April 4, 2013 10:18 PM
  • OK... DERP moment, setting the router to forward to 3389 on the RD Gateway is the issue. Now I can (and did) change IIS and RD Gateway manager to listen on port 3389 (I did move basic RDP to another port beforehand) does allow RDP Clients to connect to the Virtualized collections. This isn't the preference ... I still have to figure out how to get the RD Web access session collections to work. I will adjust the port settings router settings and DNS settings as I unfook this mess. Any ideas how to get RD Web Access to look at a different port?

     
    Thursday, April 4, 2013 10:36 PM
  • 3389 port works for RDP, but for rdweb or renmoteapp, it should use port 443.

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com

    Friday, April 5, 2013 1:25 PM
  • Bob,

    If I change everything back to port 443 on the RD Gateway that should get things going again? 

    RDS-1.domain.com  - 10.10.10.1 = Connection Broker - No external IP Address
    RDS-2.domain.com  - 10.10.10.2 = Gateway (3rd party SSl certificate installed) - External IP of 40.20.30.1 Port 443
    RDS-3.domain.com  - 10.10.10.3 = Session/Virtualization Host - No external IP Address
    RDS-4.domain.com  - 10.10.10.4 = Web Access (3rd party SSl certificate installed) - External IP of 40.20.30.2 Port 443

    One thing I discovered is when I access RD Web and click on a application it appears to want to authenticate with RDS-1 (connection broker) .. Do I need to open a port up for that as well?

    TIA, Sean


    Friday, April 5, 2013 3:29 PM