locked
Issues with PDF Ifilter 9.0 on Windows Server 2008 R2 RRS feed

  • Question

  • I recently deployed a MOSS 2007 farm on a Windows Server 2008 R2 64 bit server and I am having issues with PDF Ifilter. I did all the configuration but i still get the following error in the crawl log

    The filtering process could not process this item. This might be because you do not have the latest file filter for this type of item. Install the corresponding filter and retry your crawl

    Below is the configuration steps I did

    1. Downloaded and Installed Adobe Reader 9.0 64bit PDF Ifilter

    2. Added the PDF file type in SSP

    3. Added PDF to the list as a new String Value 38 at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server
    Extensions\12.0\Search\Applications\GUID\Gather\Search\Extensions\ExtensionList

    4. Addded PDF icon to images folder and made an entry to DOCICON.XML
    <mapping Key="pdf" Value="pdficon_small.gif" OpenControl="" />

    5. Modified the following registry keys

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office server\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf

    Default {E8978DA6-047F-4E3D-9C78-CDBE46041603}

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf

    Default {E8978DA6-047F-4E3D-9C78-CDBE46041603}

    6. Added adobe pdf ifilter bin to the path variable under environment variables
    C:\Program Files\Adobe\Adobe PDF ifilter for 64 bit platforms\bin

    7. Restarted Office Search

    8. Started Full Crawl

    Despite all these changes, I am still getting same error. Did anybody install PDF Ifilter 64 bit on Windows Server 2008 R2? I did not see Windows Server 2008 R2 in the system requirements on the adobe site (http://www.adobe.com/support/downloads/detail.jsp?ftpID=4025)

    Any help with this is much appreciated.
    Tuesday, January 5, 2010 4:01 PM

Answers

All replies

  • The Foxit Software IFIlter is supposed to be considerably faster.

    I suggest you try it out - maybe its installation routine works better too (there's a download available to try it out)

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Wednesday, January 6, 2010 6:33 AM
  • Hi Avinash Kota,

     

    I think PDF ifilter 9.0 can also be used on Windows Server 2008 R2. When you configure this PDF ifilter, did you follow the instruction step by step? Please double check it carefully:

    http://www.adobe.com/special/acrobat/configuring_pdf_ifilter_for_ms_sharepoint_2007.pdf

     

    Hope this helps.

     

    Lu Zou

     

    • Marked as answer by Lily Wu Wednesday, January 13, 2010 10:08 AM
    Thursday, January 7, 2010 6:15 AM
  • Thank You guys, I have figured out the issue. When modifying the following registry key, the registry key type has to be "REG_MULTI_SZ" not "REG_SZ"


    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office server\12.0\Search\Setup\ContentIndexCommon\Filters\Extension\.pdf

    Default {E8978DA6-047F-4E3D-9C78-CDBE46041603}

    Changing the registry key type fixed issue and the search is working great.



    Avinash kota

    http://SharePointReporter.wordpress.com
    • Proposed as answer by sivaramnarayan Monday, November 26, 2012 6:33 AM
    Wednesday, January 20, 2010 6:10 PM
  • Hi All,

    I have published an article at http://www.mossgurus.com/adnan/default.aspx explaining How to Install and configure PDF iFilter (64 bit) for SharePoint Server 2010 or Search Server 2010 Express with screen shots of each important steps.

    I do hope that you will find this article useful. Please leave your comments.

    Thanks

    Adnan Ahmed

    Senior MS Solutions Consultant

    Owner: www.mossgurus.com

      

    Wednesday, May 19, 2010 11:21 PM
  • Thanks for the article!

    Step 11: I just notice that the working command are

    net stop osearch14
    net start osearch14

    (btw comments are not working on your site)

    Thursday, May 20, 2010 1:54 PM
  • Hi Tim,

    Thanks for your response. I have correct your mentioned mistake on my article. Comments are also enabled.

    Regards,

    Adnan Ahmed

    Saturday, May 22, 2010 9:14 PM