none
HTTP/HTTPS access RRS feed

  • Question

  • A wired desktop computer (Win 8.1) on my network is only able to access internet sites with prefix https.  Other sites such as www.msn.com give "connection was reset" error (firefox) or "website is too busy" (IE).  https://yahoo.com and several other sites with https prefix will load fine.  Other computers on network, wired or wifi, Win 8.1 or XP load sites fine.  Further, file sharing between computers on network work as expected.  Network troubleshooter sees nothing.

    Am I missing a setting somewhere?

    Wednesday, December 23, 2015 5:56 PM

Answers

All replies

  • Well interesting Firefox and IE it appears, so beyond resetting IE to defaults (in case Firefox uses some underlying settings), in Internet properties on both the Security tab, Reset all zones to default level, on Advanced tab Reset.

    Other than that reset the TCP\IP stack

    On the Start screen, type CMD. In the search results, right-click Command Prompt, and then click Run as administrator. At the command prompt, enter the following command, and then press Enter:

    netsh int ip reset

    Restart the computer. From How to reset TCP/IP by using the NetShell utility

    Wednesday, December 23, 2015 9:50 PM
  • Thank you, but that did not seem to help.
    Thursday, December 24, 2015 1:25 AM
  • Hi,

    Based on your description, we should pay attention to https issue.

    At the beginning, I suggest to try browse http website in the safe mode with networking to test the result.

    Besides, Have you installed any Avast?

    If so, it could cause this problem, please check the settings of your Avast, maybe some setting like “Web Shield” has been turned on.

    Then, please check your firewall settings. http uses port 80 while https uses port 443 by default, if your firewall block port 80, you wouldn’t browse website with http.

    Next, we could consider resetting Winsock.

    Open a CMD as administrator, type: Netsh winsock reset, hit Enter. Restart your computer after see a message said:

    "Successfully reset the Winsock Catalog".

    In addition, in some case, Proxy settings can cause this problem, please check your settings.

    There are some similar cases, maybe they can give you some prompt.

    http://answers.microsoft.com/en-us/ie/forum/ie8-windows_other/can-only-access-https-sites-and-not-http-sites/64669d6b-f5bb-4455-bcbc-8342d6f648cc?db=5&auth=1

    https://social.technet.microsoft.com/Forums/windows/en-US/4ec432f0-204e-46d2-af2e-0d8fca222f62/all-browsers-suddently-stop-displaying-http-webpages-only-https-websites-are-available?forum=w7itprogeneral

    Last but not least, you could use system restore to return a previous normal status.

    Hope my suggestion could be helpful. 


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, December 24, 2015 1:43 PM
    Moderator
  • Don't know Avast, but other proposed actions have not helped.  Interestingly, issue persists even when Windows firewall is turned off.
    Thursday, December 24, 2015 8:29 PM
  • Hi,

    Avast means anti-virus software, such as McAfee, Kaspersky etc.

    Have you tried all method? Such as system restore.

    Could you please confirm with us that what you don before this issue firstly occurred. It will be helpful to diagnose current condition.

    Enjoy your time.

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, December 28, 2015 1:20 AM
    Moderator
  • Issue resolved with system restore.
    Monday, December 28, 2015 10:24 PM
  • I am glad to know your issue has been fixed.

    This is a really practical case, I believe it could be helpful to others, thank you for sharing.

    Happy holidays.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, December 29, 2015 1:40 AM
    Moderator