none
Perfoming restore, unable to mount database RRS feed

  • Question

  • Hi,

    I'm trying to mount a database as recovery but it fails.
    We are running Exchange 2007 SP3.
    I've searched the forum but none of the topics helped resolving my problem

    Restored the EDB file and it's logfiles.

    New-StorageGroup -Server <server> -LogFolderPath "R:\Log" -SystemFolderPath "R:\Database" -Recovery
    New-MailboxDatabase -MailboxDatabaseToRecover "<Database Name>" -StorageGroup "<server>\Recovery Storage Group" -EdbFilePath "R:\DATABASE\<edb file>"

    Set-MailboxDatabase -Identity "<server>\Recovery Storage Group\<Database name>" -AllowFileRestore:$TRUE

    since it is in dirty shutdown i started a recovery:
    eseutil /r "E05" /l "R:\Log" /d "R:\Database"

    recovery fails with:
    JET_errAttachedDatabaseMismatch, An outstanding database attachment has been detected at the start or end of recovery, but database is missing or does not match attachment info

    So i run the recovery again, but now with the /i parameter.
    Now the database is in clean shutdown state.

    Mount-Database -Identity "<server>\Recovery Storage Group\<EDB FILE>"

    Mount failed:
    Mount-Database : Exchange is unable to mount the database that you specified. Specified database: <server>\Recovery Storage Group\<Database name>; Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-1023)

    How to proceed in succesfully mounting the database?

     

    Wednesday, April 17, 2013 7:49 AM

All replies

  • Hi 
       Run below command and check the edb file path is correctly available and exists.

     

    Get-MailboxDatabase “Database Name” | FL Identity, EdbFilePath
     


    Terence Yu

    TechNet Community Support

    Thursday, April 18, 2013 2:37 AM
    Moderator
  • Hi 
       Run below command and check the edb file path is correctly available and exists.

    Get-MailboxDatabase “Database Name” | FL Identity, EdbFilePath
     


    Terence Yu

    TechNet Community Support

    Thanks for the reply.

    Paths are fine.
    The drive R:\ is a mapped network drive at the backup server, could that cause an issue?

    Thursday, April 18, 2013 6:22 AM
  • Hi 
        if your server can access R:,backup server is ok.

    Terence Yu

    TechNet Community Support

    Thursday, April 18, 2013 6:28 AM
    Moderator
  • Hi 
        if your server can access R:,backup server is ok.

    Terence Yu

    TechNet Community Support


    The server has access to the mapped drives and folder
    Thursday, April 18, 2013 7:11 AM
  • Restored the files again, same issue.
    Is anyone familiar with this problem

    Friday, April 19, 2013 6:25 AM
  • What was the resolution ITmab?  I'm facing this after a compact on a virtual server.  Dirty shutdown and a Jet err missing attachment failure on a recovery.

    answer would help.

    Regards,

    C

    Sunday, September 8, 2013 2:39 AM