What are the reasons Hyper-V might not properly apply the Automatic Start Action in Settings? RRS feed

  • Question

  • Win 8.1 Pro, Hyper-V v6.3.9600.16384

    I have set a VM for "Always start this virtual machine automatically".  But when Windows and Hyper-V start up, this machine is not starting.  I have alternately tried going back to a different setting for startup and coming back to auto start thinking it might reset some internal 'switch', and I have tried 0 and 30 sec delays wondering if there are delayed services, but I don't know what those might be.  But I would think when Hyper-V starts, it should be fully ready to go.

    I have Hyper-V also running on another machine (Server 2012 R2) and it behaves properly.  Of course the only time I shut down the server is for software updates as required, but when I do that, Hyper-V automatically starts all its VMs per the settings.

    What things can I look at to determine why Hyper-V is not starting the VM automatically on this Win 8.1 machine, and what might I do to fix this problem?


    • Moved by BrianEhMVP Tuesday, August 4, 2015 2:53 PM
    Thursday, July 30, 2015 12:43 PM

All replies

  • Is it simply not starting or are you getting an error during the startup?  Have you reviewed the event logs to see if something is preventing it from starting?

    I know I have some of test VMs on a removable USB drive.  I will often see a 'stopped - critical' error on the VMs after a restart of the system because the drive is not yet recognized so Hyper-V can't find the machines.  Waiting until the whole system is up allows me to start the VMs.  Since these are test VMs, though, I have never had them set for auto-start, so I can't say if that is a problem.

    . : | : . : | : . tim

    • Proposed as answer by Alex Lv Tuesday, August 4, 2015 5:50 AM
    Thursday, July 30, 2015 3:02 PM
  • Hi Alan and Tim,

    actually what Tim wrote regarding the USB Drive could cause the issue.
    You can check this post in order to resolve the issue - also for you Tim ;-)

    If that is not the cause, please have a look if there is something in the Hyper-V Event Logs and let us know.

    Best Regards,

    Thursday, July 30, 2015 3:15 PM
  • Hi Tim and Jens,

    Thanks for both your responses.  The link regarding unavailable VM's at startup was interesting.  I don't think that's directly my problem, but I will try an extended startup delay in little bit. 

    My machine has 2 SSD's for basic operation.  I boot from the 1st SSD, and my VMs/VHDs are on the 2nd SSD.  There is also a 3rd spindle drive, but that's not in the Hyper-V equation.

    I also checked services and noticed there are 7 Hyper-V services that are all set to Manual(Trigger Start).  I assume that's OK.

    Good reminder to check the Event Viewer and I did check for all the Hyper-V sources.  I had one Critical warning; the .iso I had specified for the virtual DVD was no longer in the location that Hyper-V was looking for it.  I changed the DVD to 'none'.  However, that didn't seem to make a difference.  But the following is curious and the plot thickens...

    If I boot from power off, the VM doesn't start.  If I boot from restart, the VM does start.  However, I don't know what that implies.

    Any ideas what is different about a power up versus a restart that might affect Hyper-V?

    Thursday, July 30, 2015 4:33 PM
  • I don't know about Client Hyper-V, but Hyper-V Server will eventually turn on a virtual machine even if its storage isn't available right away. I haven't seen this behavior documented anywhere, but I've seen it occur reliably going all the way back to 2008 R2. It may take some time for VMMS to "catch on" that the storage is available and then respond accordingly, but I've never seen a VM just stay off.

    I wonder though, if your issue isn't related to memory starvation. The behavior you describe is more inline with what I would expect from Hyper-V Server and not Client Hyper-V and I would think that VMMS would eventually "catch on" there as well, but it's worth looking at.

    Eric Siron
    Altaro Hyper-V Blog
    I am an independent blog contributor, not an Altaro employee. I am solely responsible for the content of my posts.

    Thursday, July 30, 2015 8:05 PM
  • Hi Eric,

    Thanks for the thought.  I have 32 gig on this machine, so I would think there's plenty of room for Hyper-V to work.  On the other hand, because the boot drive is a SSD, maybe things are going by so fast that setups aren't complete before Hyper-V is waking up.  I never really thought that any of the memory resources wouldn't be immediately available, but I suppose that's possible.  I will continue to look into this odd startup behavior (restart vs cold boot) and also look at putting hyper-V on a delayed start.

    Thursday, July 30, 2015 10:16 PM
  • So the delayed start didn't solve the problem, but I did notice before I could actually get into the services applet after boot up Hyper-V was already on.  That's pretty quick.  I thought delayed start was supposed to wait for about 120 secs.

    Anyway, I did observe this:

    If I stop the VMMS service and restart, the VM starts up immediately.

    So I'm thinking delayed start is needed, but I don't seem to be able to get enough of a delay.  Or maybe it's something else.

    Any thoughts?

    Thursday, July 30, 2015 10:33 PM
  • Hi Alan Wheeler,

    When the [“Automatic Start Action”] is set to 0 or near lower value to all VM’s , the VM’s cannot start

    Because they need more time to connect to their iSCSI disks. But when we set the VM's to greater value they all start is the expect behavior, please check the event log to confirm whether have any event occur after you cold start computer.

    The related article:

    Looking at the Hyper-V Event Log

    I’m glad to be of help to you!

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact

    Tuesday, August 4, 2015 6:23 AM
  • Hi Alex,

    I had tried to check that log per Tim's recommendation and found nothing meaningful, but I will review it again using the link you provided.  I had also tried a longer delay, but that didn't seem to work, but I will try it again and get back to this thread.

    So far nothing has worked.  In the meantime I set up a simple batch to click & run from the desktop until I/we figure this out.

    Tuesday, August 4, 2015 3:11 PM
  • Hi,

    I have the same issue of a Win 10 Pro Hyper-V VM ...

    - Not performing an Automatic Start on a cold Start (i.e. Shut Down and Start cycle)

    - Successfully performing an Automatic Start on a Restart.

    I've already tried:

    - Automatic Start Delay settings of 60 and 120 seconds

    - Checking Hyper-V Error logs for differences between cold Start and Restart (no differences)

    - Setting the Hyper-V Virtual Machine Management service to Automatic or Automatic (Delayed Start)

    - Setting the Hyper-V Time Synchronization Service to Automatic (Trigger Start)

    - Starting the iSCSI service and attempting an Volume and Drive Auto Configuration

    - Checking other Hyper-V services for differences between cold Start and Restart (no differences)

    -- HV Host Service was Running

    -- Hyper-V Host Compute Service was Running

    -- Hyper-V Virtual Machine Management was Running

    Does anyone have any new insights for a potential resolution for fixing the Hyper-V VM Automatic Start to work after a cold Start  (even though it now only works with a Restart)?


    Tuesday, November 8, 2016 5:56 PM
  • I thought I would report back to you that I found Hyper-V to work very well in all circumstances when I moved my VM's to a dedicated host server (2012R2).  Even though VM's worked in the desktop OK, it wasn't always consistent in all features.  But on 2012R2 everything works just as advertised, and it is a pleasure to use there.  Not much help for your situation, but it may help you to know it seems from observational experience there are just some things on the desktop OS that aren't as robust as on the server OS.
    Thursday, November 10, 2016 7:51 PM