none
FIM Portal installation @harbar.net RRS feed

  • Question

  • HI,

    I am following (at least try to) on th ehow to from this Website http://www.harbar.net/articles/fimportal.aspx which is a great post. THANKS

    Me as a rooky trying to follow this step by step post and failing already at the power Shell part. I believe I Need to copy your Information into the Editor and Change some Information that applies to my Network and then save the file as fim farmcreation.ps1
    Correct?
    I have tried to get to Change this Information to reflect my Network Settings but I always getting Errors when I run the script.
    Please see my adapted script on the below where I would be very happy if someone could Review it and let me know about my errors?
    My Network Settings are as following:
    SQL Server=sql2-srv with a named instance FIMSP
    FIM Server=fim1-srv
    FIM Service=fim.service
    FIMSPFarm=fimsp.service
    FIMSPContent=fimsp.content

    Many thanks,
    Markus


    asnp Microsoft.SharePoint.PowerShell

    $databaseServer = "SQL2-SRV\FIMSP"
    $configDatabase = "FIMSP_Config"
    $adminContentDB = "FIMSP_Content_Admin"
    $passphrase = "mypassword?"
    $farmAccountName = "XY\fimsp.service"
    $caUrl = "https://fimspca.XY.COM"
     
    $farmAccount = Get-Credential $farmAccountName
    $passphrase = (ConvertTo-SecureString $passphrase -AsPlainText -force)
     
    Write-Host "Creating Configuration Database and Central Admin Content Database..."
    New-SPConfigurationDatabase -DatabaseServer $databaseServer -DatabaseName $configDatabase `
         -AdministrationContentDatabaseName $adminContentDB `
         -Passphrase $passphrase -FarmCredentials $farmAccount
     
    $spfarm = Get-SPFarm -ErrorAction SilentlyContinue -ErrorVariable
    err        
    if ($spfarm -eq $null -or $err) {
       throw "Unable to verify farm creation."
    }


    Write-Host "ACLing SharePoint Resources..."
    Initialize-SPResourceSecurity
    Write-Host "Installing Services ..."
    Install-SPService  
    Write-Host "Installing Features..."
    Install-SPFeature -AllExistingFeatures

    Write-Host "Creating Central Administration..."             
    New-SPCentralAdministration -Port 443 -WindowsAuthProvider NTLM
    Write-Host "Fixing CA IIS binding..."
    Set-SPCentralAdministration -Port 443 -Confirm:$false
    Write-Host "Fixing Internal URL..."
    Set-SPAlternateURL -Identity "https://$env:fim1-srv" -Url $caUrl

    Write-Host "Installing Help..."
    Install-SPHelpCollection -All       
    Write-Host "Installing Application Content..."
    Install-SPApplicationContent

    Write-Host "Farm Creation Done!"


    AdminIT

    Tuesday, June 11, 2013 3:51 PM

All replies

  • Hi,

    I think you are using a great link but as you said "As a rooky" You should follow following Microsoft link for FIM portal installation:

    "http://technet.microsoft.com/en-us/library/hh332711(v=ws.10).aspx"

    It gives you all information about FIM portal installation.Let me know if you face any further issue.

    Thanks~

    Giriraj Singh Bhamu

    Wednesday, June 12, 2013 4:09 PM
  • Hi,

    Hmm...I would like to use the newest Versions of the MS products (Server 2012 and SharePoint Foundation 2013) which is not covered in your proposed TechNet post. As well (as a Rooky) I am trying to practisize and increase my Status from a Rooky to a starter and sooner or later to be a Kind beginner and so on.

    Am I that far with what I did already?

    Thanks, Markus


    AdminIT

    Wednesday, June 12, 2013 4:35 PM
  • Hi,

    Okay :D

    I suppose, I shouldn't use "Rooky" word for you. First of all My bad.

    So, About latest systems There is not much difference between these newer versions and older versions. Yeah, there are few GUI difference and a few functionallity difference. But this link is more thn enough for FIM implementation.

    Thanks~

    Giriraj 

    Wednesday, June 12, 2013 8:25 PM
  • Hi Giriraj,

    Appreciate your Feedback but I am pretty sure I am still a Rooky at the moment...

    Maybe to mention it again: I would like to use actual products inkl. SP2013. So far I am reading through some links, there is always pointed that SP2013 needs special "Tasks" for installtion to run FIM Portal.

    In the other Hand, if I am not starting to get use to understand the power shell commands I will never get a step further.

    Therefore I would like you or someone else to explain me what I did wrong in my script. PLEASE

    Thanks, Markus


    AdminIT

    Wednesday, June 12, 2013 9:58 PM
  • Hello!!

    I used the same blogpost the other day and it worked great for me.

    What errors are you getting? Are you setting up FIM in a Lab/Demo or production env?

    Sorry for the first reply, I skipped the "FIM Join Farm.ps1"

    Please add some more info about your errors.

    //johan


    Thursday, June 13, 2013 8:25 AM
  • Hi Johan,

    I am getting a lot of Errors. Because I am using a German Version of Server 2012 (SharePoint 2013 is in english) I need to translate the errors via a online translator.

    Just Brief what happen when I start the posted script in SharePoint 2013 Management Shell:
    1. Login window Pop up with fim.service account credentials where I Need to enter Password
    2. again a Login window Pop up this time empty one where I use my Administrator credentials
    3. back to power shell where it ask for FarmCredentials Passphrase where I entered "mypassword"

    ERROR MESSAGE
    PS C:\Users\Administrator.XY\documents> .\fimfarmcreation.ps1
    Creating Configuration Database and Central Admin Content Database...

    Cmdlet New-SPConfigurationDatabase an der Befehlspipelineposition 1
    Geben Sie Werte für die folgenden Parameter an:
    FarmCredentials
    Passphrase: **********
    New-SPConfigurationDatabase : Requested by the login
    FIMSP_Config database can not be opened. The login failed.
    Login failed for user'XY\Administrator'.
    In C:\Users\Administrator.XY\documents\fimfarmcreation.ps1:14 Zeichen:1
    + New-SPConfigurationDatabase -DatabaseServer $databaseServer -DatabaseName
    $confi ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~
        + CategoryInfo          : InvalidData: (Microsoft.Share...urationDatabase:
       SPCmdletNewSPConfigurationDatabase) [New-SPConfigurationDatabase], SqlExce
      ption
        + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletNewSPCon
       figurationDatabase

    -AdministrationContentDatabaseName : the designation
    "Administration Content Database Name" is a not a name of a cmdlet,
    Function, script file, or operable program detected.
    Check the spelling of the name, or if the path is correct
    (if included), and repeat the process.In C:\Users\Administrator.XY\documents\fimfarmcreation.ps1:15 Zeichen:6
    +      -AdministrationContentDatabaseName $adminContentDB `
    +      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (-AdministrationContentDatabaseN
       ame:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    -Passphrase : The term "passphrase" was not, as the name of a cmdlet
    a function, script file, or operable program detected.
    Check the spelling of the name, or if the path is correct
    (if included), and repeat the process.
    In C:\Users\Administrator.XY\documents\fimfarmcreation.ps1:16 Zeichen:6
    +      -Passphrase $passphrase -FarmCredentials $farmAccount
    +      ~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (-Passphrase:String) [], Command
       NotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException

    Get-SPFarm : Missing argument for parameter "error variable". enter
    a parameter of type "System.String", and try again.
    In C:\Users\Administrator.XY\documents\fimfarmcreation.ps1:18 Zeichen:52
    + $spfarm = Get-SPFarm -ErrorAction SilentlyContinue -ErrorVariable
    +                                                    ~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (:) [Get-SPFarm], ParameterBind
       ingException
        + FullyQualifiedErrorId : MissingArgument,Microsoft.SharePoint.PowerShell.
       SpCmdletGetFarm

    err : The designation "err", was not as the name of a cmdlet, function
    recognized a script file or an executable program. check
    the spelling of the name, or if the path is correct (if included)
    and repeat the process.In C:\Users\Administrator.XY\documents\fimfarmcreation.ps1:19 Zeichen:1
    + err
    + ~~~
        + CategoryInfo          : ObjectNotFound: (err:String) [], CommandNotFound
       Exception
        + FullyQualifiedErrorId : CommandNotFoundException

    Unable to verify farm creation.
    In C:\Users\Administrator.XY\documents\fimfarmcreation.ps1:21 Zeichen:4
    +    throw "Unable to verify farm creation."
    +    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OperationStopped: (Unable to verify farm creatio
       n.:String) [], RuntimeException
        + FullyQualifiedErrorId : Unable to verify farm creation.

    Thanks, Markus


    AdminIT

    Friday, June 14, 2013 2:04 PM
  • HI,

    anybody an idea what is wrong in my script seeing at my error post?

    Thanks, Markus


    AdminIT

    Monday, June 24, 2013 3:13 PM
  • Don't use SharePoint Foundation 2013 unless you REALLY REALLY REALLY have to.

    There are reasons for this that I cover in my blog post about installing FIM on SharePoint Foundation 2013.

    I understand your reasons for wanting to use the "latest" technology, but SPF 2013 support in FIM 2010 R2 SP1 for is basically a hack. It works, but it forces your SharePoint Foundation 2013 instance to use deprecated functionality.

    At time of writing, the absolute best way to run FIM 2010 is on Windows 2008 R2 with SharePoint Foundation 2010.

    Trying to use SPF 2013 is a rookie mistake. 

    That said, if you insist on continuing with SPF2013, read my guide as well.

    Also, read this post by Paul Williams at Microsoft that explains Why you should not install FIM into a SharePoint Farm

    - Ross Currie


    FIMSpecialist.com | MCTS: FIM 2010 | Now Offering ECMA1->ECMA2 Upgrade Services

    Tuesday, June 25, 2013 5:43 AM
  • Hi Ross,

    Thank you for the detailed explanation of pro and contras...it may change my mind of using latest technology.

    To be honest, I have done my first try following your blog and failed "only" on the management page where I found a http 404 error.

    As I am working in lab test I also thinking in waiting for the SP2 release to support Server 2012.

    That said, I am still wondering what is wrong in my script (I am sure the harbar blog has a success)

    All the above show me many different ways to reach my goal for a first step in getting my experience with FIM.

    THANKS, Markus


    AdminIT

    Tuesday, June 25, 2013 8:37 AM
  • If you're working in a lab.... chances are you may not have your DNS settings properly configured for your test domain?

    I always try and skip this step, but the reality is life is made a lot easier if your DNS is working properly.

    Other tips:

    - Sounds like your SharePoint Central admin site didn't load? Check your alternate access mappings. Double check the server addresses you're using

    - Just try with NTLM for now (don't worry about kerberos until you've got it installed)

    You might be waiting a while for SPF 2010 SP2 . I'm not sure there's an ETA on that yet.

    Best of luck. Keep at it and don't be afraid to blow everything away and try again.

    My guide is really a "down and dirty" guide, where harbar's is more pure from a SharePoint perspective. Good to learn both.

    - Ross Currie


    FIMSpecialist.com | MCTS: FIM 2010 | Now Offering ECMA1->ECMA2 Upgrade Services

    Tuesday, June 25, 2013 8:57 AM
  • Hi Ross,

    It took me a while but finally I can say I made my life myself very difficult.

    The error were on two mistakes (rooky)done:
    - I did not copy the source code itself from the website
    - I had SharePoint 2013 with a language pack installed

    After copied the source, made changes to fit my Installation and removed SharePoint 2013 German language pack everything went smoothly.

    Just up to the Point to check the successfully Installation of the Portal. There I am running in the same error as I had when I followed your post:
    HTTP 404 Website could not found

    Any idea where/how to get this error solved?

    Thanks,
    Markus


    AdminIT


    Sorry...everything is fine now. Typo in the IdentityManagement page URL
    • Edited by AdminIT Sunday, June 30, 2013 5:48 PM typo
    Sunday, June 30, 2013 4:31 PM