locked
Network Adapters Code 31 RRS feed

  • Question

  • Hi,

    I have Vista 32-bit running on a Dell inspiron 1525.  ALL network adapters have turned error code 31. isatap devices, wireless, wired, WAN Miniport adapters, everybody.  I have read KB
    932520, but of course my problem is much more than an isatap adapter erroring out, everything is erroring out.  All searches seem to be contaminated with threads that are ultimately about
    KB932520.  Any assistance would be appreciated.
    Friday, October 24, 2008 4:51 AM

All replies

  • Hi,

     

    Before moving on, please confirm the following points first. Thanks.

     

    1.      When the issue occurs?

    2.      Do you install any software or hardware recently?

    3.      Can you resolve the problem by system restore?

     

    At this time, let’s try to take the following steps to troubleshoot the problem.

     

    1.      Click Start, type regedit and press Enter.

    2.      Navigate to

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}

     

    3.      Right click the{4D36E972-E325-11CE-BFC1-08002bE10318} entry, choose "Export", select Desktop in the Save in box and type backup in File Name. Click Save.

     

    Please Note: The backup file is on the Desktop and named backup.reg. We can simply restore the registry by double-clicking the backup.reg file.

     

    4.      Please remove any subkeys under {4D36E972-E325-11CE-BFC1-08002bE10318}.

    5.      On right panel, please remove all items except:

     

    (Default)           Network adapters

    Class                  Net

    ClassDesc                  @NetCfgx.dll,-1502

    EnumPropPages32           NetCfgx.dll,NetPropPageProvider

    IconPath           %systemroot%\system32\setupapi.dll,-5

    Installer32                 NetCfgx.dll,NetClassInstaller

     

    Then, restart the computer to reinstall all the network adapter drivers to test the issue again.

     

    Thanks.

     

    Monday, October 27, 2008 9:20 AM
    Moderator
  • New software install was suspected, but even after System Restore to before a recent software install, my problem persists.  No new hardware changes have been made either.

    After removing the subkeys, they simply return on reboot with same problem shown in device manager.

    Thanks for your response.  Any other ideas?
    Tuesday, October 28, 2008 4:29 AM
  • Hi,

     

    Thank you for your cooperation.

     

    Given the current situation, I suggest you take an in-place upgrade installation, in this way the issue can be resolve efficiently.

     

    In-place Upgrade Installation

    ===============================

    Technically, you won’t lose any data to take an In-place Upgrade Installation. In order to avoid any unexpected problem. I suggest you backup your data before taking In-place Upgrade Installation.

     

    1. Start the computer by using the current Operating System.

    2. Insert the Windows Vista DVD in the computer's DVD drive.

    3. Use one of the following procedures, as appropriate:

     

    If Windows automatically detects the DVD, the Install now screen appears.

     

    Click Install now.

     

    If Windows does not automatically detect the DVD, follow these steps:

    a. Click Start, click Run, type Drive:\setup.exe, and then click OK.

     

    Note Drive is the drive letter of the computer's DVD drive.

     

    b. Click Install now.

     

    4. When you reach the "Which type of installation do you want?" screen, click Upgrade to upgrade the current operating system to Windows Vista.

     

    Hope it helps.

     

    Wednesday, October 29, 2008 8:01 AM
    Moderator
  • Im having the same problem, and i've tried pretty much everything to get through the problem, its not any specific device, and its not the drivers either, the problem leads me to believe something has been changed in the registry or a missing system file (as is the case with the code 39 error across all network adapters)  but as of yet i cannot find out what...

    I just tried the in-place upgrade install, and it told me the install was unable to complete because it was unable to operate one or more devices (or something along those lines), and now it is rolling back the install...

    I am at a loose end as to what to do short of backing everything up on this computer and doing a clean install of windows (which i would rather avoid seeing as this isn't the only case of this problem we have had, and it takes alot of effort to install software and user data back to how it was beforehand)

    does anyone have any ideas what i can do to solve this issue, thanks

    [EDIT]-----------------------------------------------------------------------------

    tried the in-place upgrade install for a second time and the upgrade completed succesfully, the error issue is fixed, so im happy this time, but i still want to find a fix for the issue when its in windows XP, because another computer we had with the same symptoms, we tried a repair install, among other things, and nothing seemed to fix the issue..

    thanks for helping me sort this in vista, im really glad, hopes are a solve can be found for XP aswell

    Friday, May 14, 2010 3:25 AM
  • Code 31


    This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)
    Recommended resolution

    Update the driver

    You may be prompted to provide the path of the driver. Windows may have the driver built-in, or may still have the driver files installed from the last time that you set up the device. However, sometimes, it will open the New Hardware Wizard which may ask for the driver. If you are asked for the driver and you do not have it, you can try to download the latest driver from the hardware vendor’s Web site.

    In the device Properties dialog box, click the Driver tab, and then click Update Driver to start the Hardware Update Wizard. Follow the instructions to update the driver.

    Thursday, July 15, 2010 5:18 PM
  • When I had error code 31 across all the network adapters in Vista, it turned out to be caused by having two firewalls on my system. I had enabled Windows firewall and I still had ZoneAlarm. I had to completely uninstall ZoneAlarm (it wasn't enough to just disable it).
    Monday, January 7, 2013 1:29 AM