locked
Shared Services - can't connect to config database RRS feed

  • Question

  • I had to change the account for our Shared Service provider which seems to have caused problems. I changed it within the central admin for Shared Services. It seemed to work at first but today I am getting errors when I try and browse to the individual Shared Service site.

    The first error I got was - cannot connect to the configuration database. I checked our sql server and made sure the permissions were the same as the account it originally worked with. After reading a microsoft article I noticed I should restart the application pool after changing the username/password. I did this but still no luck.

    I thought it might help to stop and start the SSP website in IIS but still no luck.

    I am now getting the below message sometimes, and other times the config database one.

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

    Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="RemoteOnly"/>
      </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
      </system.web>
    </configuration>

    Server Error in '/' Application.

    Runtime Error

     

    Please can someone help me?


    Thanks in advance!!

     

     

    Sarah


    Monday, April 4, 2011 2:30 PM

Answers

  • I would say the most important steps would be to change passwords for the SSP (6a). You could also check the application pools ( if any) which use this account and change it within IIS.
    • Marked as answer by sarah22 Tuesday, April 5, 2011 11:12 AM
    Monday, April 4, 2011 5:41 PM

All replies

  • The error message ("below message") you are getting is a standard one.

    Follow the instructions in this error message and the next time you have the same problem you will get a different error message that indicates what the actual problem is.


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Monday, April 4, 2011 2:44 PM
  • Sarah,

     The following article mentions the steps to change the service account for SSP

    http://support.microsoft.com/kb/934838

    The emphais should be on steps 3,4,5,6 . I am assuming here that you only changed the password for the search account and not the farm account.

    Monday, April 4, 2011 2:48 PM
  • Thanks for getting back to me. The account I am changing is only used for the SSP, nothing else,  so do I still have to go through all of those steps? I thought it would just be a case of editing the username and password when I go in to edit the details of the SSP I made?

     

    Monday, April 4, 2011 2:58 PM
  • I would say the most important steps would be to change passwords for the SSP (6a). You could also check the application pools ( if any) which use this account and change it within IIS.
    • Marked as answer by sarah22 Tuesday, April 5, 2011 11:12 AM
    Monday, April 4, 2011 5:41 PM
  • The application error seems to have gone but I'm still getting the cannot connect to the configuration database error.

    I tried running that stsadm command from the article in both of the servers in my farm but still no luck. I have also checked the application pools and the one for the SSP is already set to use the new account I would like it to.

    Tuesday, April 5, 2011 6:49 AM
  • Can you just reenter the new password for the account in the application pool and restart the application pool as well as the web site?

    Tuesday, April 5, 2011 1:22 PM
  • I changed the service account for the application pool within the Service Accounts option in Central Admin and it fixed the problem :-)

    Thank you for your help with this.

    Thursday, April 7, 2011 1:33 PM