locked
Unable to receive email alerts from sharepoint server RRS feed

  • Question

  • Hi,

    I have created user in windows server and added that user profiles manually in SharePoint using Shared Service. In user profile I set Work Email for all users. I have also set incoming and outgoing email servers.

    After that, I have added that users in one site and end user. Every user is able to login into SharePoint site. Now I set email alerts on Discussion board.  But this gives me below error

    The following users do not have e-mail addresses specified:  Alerts have been created successfully but these users will not receive e-mail notifications until valid e-mail addresses have been provided

    Set my e-mail address...

    I have googled lot and find below suggestion

    1)    Syncronize MOSS and WSS profiles by using
    Stsadm -o sync -synctiming m:5
    Stsadm -o sync -synctiming m:1

    2)    I have also restarted machine after this and check running timing job. In that it shows synchronization success, also I checked immediate alert are success.
    3)    After that I removed all users added to site and again added the users. But still it shows same message whenever I set alert on any list, discussion..etc.
    4)    Also in profile I view from sharepoint it does not show email address in profile details, also it does not provide option to edit profile and set email id.

    even after applying all above suggetions, I still not able to receive email from SharePoint.

    I would appreciate if anyone has any solution or help me out to resolve the problem.

    Thanks.

    • Moved by Mike Walsh FIN Thursday, July 21, 2011 12:41 PM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Thursday, July 21, 2011 11:12 AM

All replies

  • The root of your problem is that emails are sent based on the email address stored in the UserInfo table and it hasn't been set.  The email address you are changing is in the UserProfile.  AS you have already learned from Google there are timer jobs that synchronize changes made in the User Profiles with the UserInfo table.  The stsadm commands you listed above set the timing of the main Sync job.

    However, there is one thing that most of those blog post don't mention.  The sync job only syncs ACTIVE users.  Inactive users are ignored.  For SharePoint an active user is anyone who has logged in and contributed to a site by adding or editing something.  If the user hasn't logged in to the site or hasn't changed anything they will be either not listed or listed as a inactive user in the UserInfo table and their profile will not be synced.

    So you have two options for fixing your problem.  First, you could make sure that all the users who are getting the error message have actually changed something on the site BEFORE the Sync job runs.  Or you could make sure that the email address is set in Active Directory before you create the user.  If the email address is specifically set in the properties of AD then it will be correctly picked up when the user is created and no sync will be necessary.


    Paul Stork SharePoint Server MVP
    Thursday, July 21, 2011 11:38 AM
  • Hi Paul,

     

    Thank you for your reply. I have already tried to login by all users and then sync the profiles. Again I have done all the processes,  but still I am enable to receive email alerts.

    One thing I have observed is I receive email when I add user to site, then it sends welcome message means email setup is ok. However I can't see the work email-id in profile from sharepoint site.

    Please provide your assistance in that direction.

    Thanks a lot again.. 

    Wednesday, August 3, 2011 7:25 AM
  • Logging in as the users isn't enough to make them active users.  If they are given their rights because they are members of an AD group that has permissions in SharePoint then they need to contribute something to the site before they are considered active users.  Only active users are synced.

    The fact that it sends an email when you add them to the site doesn't necessarily mean that the email setup is OK.  You need to go to the People and groups list and see if you can send an email to the user from there.  If you can't then the email address isn't set correctly on the user.   If the email isn't set correctly then setting it in their User Profile and waiting for the user table to sync will only work if the user is marked as active.


    Paul Stork SharePoint Server MVP
    Wednesday, August 3, 2011 11:38 AM
  • Hi Paul,

    Thanks for your quick reply..

    I have checked by visiting "People and Group" > Select user and send email. It is failed again.

    I would like to inform you that, I am NOT using Active Directory (AD), I am adding users to "Local users and Group" and then adding profile of that user in sharepoint site. While creating local user we do not have property "e-mail" for that user. So at time of first time creating profile I have added work-email and saved that profile.

    Do I must have AD?

    Please provide your thoughts....

    Wednesday, August 3, 2011 4:07 PM
  • HI,

    have you checked the user profiles in SSP?

    Are you able to locate their eMail address over there?

    If not then add their email address there and then sync their profile.

    Thanks,

    Rahul Rashu

    Wednesday, August 3, 2011 5:04 PM
  • As long as you only have one SharePoint server you can use local security in place of Active Directory.  However, as you have already seen doing that will not set the email address on the user when they are created.  Setting the email address in the profile after creation will only sync to the UserInfo table for Active users.  In SharePoint 2007 users need to have contributed to a site in the site collection before they are marked as active.  It is the email address in the UserInfo table that is used for sending emails.  If the users aren't active and didn't have an email when they were created it won't matter whether you set the email in the profile or not.
    Paul Stork SharePoint Server MVP
    • Proposed as answer by Zoeb S Friday, December 9, 2011 8:51 AM
    Wednesday, August 3, 2011 5:55 PM
  • Uhhh...I think I will setup the sequence of steps first and then execute one by one..Hope this work for me or not.

    I will update you about the result....

    Thanks for all your support.

    Thursday, August 4, 2011 11:59 AM
  • Thanks paul. This solved my problem as E-Mail was not setup in AD and because of that I was getting Server error while adding user in the sharepoint group.

    Thanks a million.

    Thursday, December 8, 2011 3:46 PM