none
Powershell to start a job

    Question

  • Hi all,

    I created a task list, create a job that send alert messages to users related to your due date tasks. The problem is, from last 3 weeks the users are receiving two mail alerts, 6:14 and 6:15.

    I disabled the job on sharepoint monitoring and create a scheedule task to run it by powershell script.

    Get-SPTimerJob ISSUE_Job_Timer -webapplication "http://portal.sa.bm.net" | start-sptimerjob

    But I continue receiving duplicate alerts.

    The WebApp portal.sa.bm.net has two databases, I suspect is because that my users are receiving duplicate messages.

    How to I add on this script to force start a job "Issue_Job_Time"on webappplication Http://portal.sa.bm.net but only on database Wss_Content_Master?

    JobDefinitionId JobDefinitionTitle WebApplicationId WebApplicationName ServiceId ServerId ServerName Status StartTime EndTime DatabaseName
    94eba910-68ce-4fbd-890f-8c4709e2730f Job Timer Issues 1d9f4548-9421-493f-8580-0650a1c1d76f SharePoint -80 f41bb244-44ba-4ec1-ace5-ab8d065a10fa 97e6da3a-2a61-4176-bf7c-a5e56f316b65 BRCWBSV16 Succeeded 7/11/2013 6:14 7/11/2013 6:15 WSS_Content_master_2
    94eba910-68ce-4fbd-890f-8c4709e2730f Job Timer Issues 1d9f4548-9421-493f-8580-0650a1c1d76f SharePoint -80 f41bb244-44ba-4ec1-ace5-ab8d065a10fa 97e6da3a-2a61-4176-bf7c-a5e56f316b65 BRCWBSV16 Succeeded 7/11/2013 6:14 7/11/2013 6:14 Wss_Content_Master

    Certified (35) | ITIL | MCP | MCDST | MCSA1 | MCSE1 | MCT | MCTS Sharepoint | MCITP SQL | MCSA Windows 2012 | MTA Security | MCSE Windows 8 | MCSE Windows 2012 | Vencedor do Winthe7.com.br 2009, Quarto lugar Copa de Talentos Microsoft 2010

    Thursday, July 11, 2013 1:44 PM

All replies

  • One alert you are sending by the timer job, by any chance have configured alert on the list, that might be executing and send alert too....just check your configuration


    Mark ANSWER if this reply resolves your query, If helpful then VOTE HELPFUL
    Everything about SQL Server | Experience inside SQL Server -Mohammad Nizamuddin

    Thursday, July 11, 2013 5:44 PM
  • I checked all configuration, the alerts are custom messages created by custom workflow, there is no any test environment using these lists or any other site collection. I almost sure that the problem is related to adicional databasename created on webapplication, because the problema started after this and I can see it on log attached.

    Certified (35) | ITIL | MCP | MCDST | MCSA1 | MCSE1 | MCT | MCTS Sharepoint | MCITP SQL | MCSA Windows 2012 | MTA Security | MCSE Windows 8 | MCSE Windows 2012 | Vencedor do Winthe7.com.br 2009, Quarto lugar Copa de Talentos Microsoft 2010

    Thursday, July 11, 2013 5:49 PM