locked
Problems Copying and Pasting from Word to a program that only accepts ASCII RRS feed

  • Question

  • Is there a way to format text in Word so that characters will be restricted to ASCII?  My team produces documents using Word that contain commands that get typed into other systems (such as a Linux command line shell) that don't accept Unicode characters - ASCII only.  It would be nice to cut and paste these, for accuracy, but we have found in the past that this does not always work correctly.  A prime example is if the Word document has a command containing quote marks.  Smart quotes apparently inserts a non-ascii character and when this gets cut and pasted it introduces gibberish.

    Ideally, what I would like to do is create a paragraph type or use a font for these commands embedded in the document that is restricted to ASCII.  Is something like that possible?

    Thursday, January 16, 2014 10:24 PM

Answers

  • For such documents, you should disable the problem auto-correct/format options, under File|Options|Proofing>Auto-correct options. That will prevent the problem characters being created, thus addressing the problem at its source. An alternative is to use a macro to do whatever post-processing is required to restrict the characters used to the ASCII set. Copying the content to Notepad, then saving, closing & re-opening the text file thus produced will achieve a similar result.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    • Marked as answer by George123345 Monday, January 27, 2014 6:52 AM
    Sunday, January 19, 2014 8:34 AM

All replies

  • plain Courier might do , or perhaps System font.

    What happens if the file extension is .txt ?


    TechNet

    Thursday, January 16, 2014 10:40 PM
  • For such documents, you should disable the problem auto-correct/format options, under File|Options|Proofing>Auto-correct options. That will prevent the problem characters being created, thus addressing the problem at its source. An alternative is to use a macro to do whatever post-processing is required to restrict the characters used to the ASCII set. Copying the content to Notepad, then saving, closing & re-opening the text file thus produced will achieve a similar result.

    Cheers
    Paul Edstein
    [MS MVP - Word]

    • Marked as answer by George123345 Monday, January 27, 2014 6:52 AM
    Sunday, January 19, 2014 8:34 AM