none
Can't Update policies in Central Store

    Question

  • Hi, I'm attempting to update the Central Store, with the new Windows 10 1709 files. I've downloaded and installed the software from here;https://support.microsoft.com/en-us/help/3087759/how-to-create-and-manage-the-central-store-for-group-policy-administra

    and now I'm attempting to copy over the files from the new PolicyDefinitions folder onto the E:\Windows\SYSVOL_DFSR\sysvol\{domain}\Policies\PolicyDefinitions folder on the DC, as outlined in the document above, but I keep receiving the below error;

    I even tried doing the copy using xcopy, but it gave a "Sharing Violation" error.

    I don't think it's a permission issue, as my account does have the required access, and I even tried taking over ownership of a file, and still it did not work.

    I've just recently taken over this role, so I can't say for sure if the Central Store was setup correctly.

    Any thoughts?

    Thanks,

    Bill



    • Edited by Bill Hearn Tuesday, January 02, 2018 5:19 PM
    Friday, December 29, 2017 8:23 PM

All replies

  • Hi Bill,
    Based on my research on similar error, you could have a try the following suggestions:
    1. Restart Computer and try
    2. Perform a Clean Boot
    3. Disable Launch folder windows in a separate process option
      1) Launch File Explorer, click View -> Options -> Change folder and search options.
      2) Find the Launch folder windows in a separate process option under Advanced settings, then disable it
      3) Close all the instances of File Explorer via Task Manager or reboot the machine 
    Best regards, 
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 01, 2018 6:32 AM
    Moderator
  • Thanks for the response Wendy.

    I came across those troubleshooting steps previously as well. The thing is that this issue is on a production domain controller and all 4 domain controllers are experiencing the same issue, so I'm doubtful that this will fix the problem. However, if I get a chance to reboot the DC I will try.

    Tuesday, January 02, 2018 5:00 PM
  • Not sure if it is related, but it is in the SYSVOL_DFSR folder on the DC, so perhaps there is something wrong with the DFS Replication.

    I also just checked the handles in Process Explorer, and the files are all opened by SYSTEM.

    This DC is also a member of a child domain, however I didn't see any mention about it having to be done on a parent DC.
    • Edited by Bill Hearn Tuesday, January 02, 2018 6:03 PM
    Tuesday, January 02, 2018 5:32 PM
  • Hi,
     
    Am 29.12.2017 um 21:23 schrieb Bill Hearn:
    > ...\SysVol\{domain}\Policies\PolicyDefinitions folder, as outlined
    > in the document above, but I keep receiving the below error;
     
    UAC and Share permissions ... copy them on one DC to the local path,
    which is shared as SYSVOL -> C:\Windows\SYSVOL\domain\Policies
    or \sysvol_dfsr if it was migrated.
     
    Mark
    --
    Mark Heitbrink - MVP Group Policy - Cloud and Datacenter Management
     
    Homepage:  http://www.gruppenrichtlinien.de - deutsch
     
    GET Privacy and DISABLE Telemetry on Windows 10 - gp-pack PaT
     
    Tuesday, January 02, 2018 6:04 PM
  • Hi Mark,

    That's exactly what I tried initially, except our AD SYSVOL_DFSR folder is on a separate drive.

    Not C:\ but E:\

    Bill

    Wednesday, January 03, 2018 11:22 PM