locked
Skype for Business asking Exchange credentials in Hybrid Exchange Scenario RRS feed

  • Question

  • Hi,

    We have in company Skype for Business 2015 on-premises integrated with Exchange Online and Exchange On-premises.

    With users in Exchange on-premises, the authentication runs well and no asking for Exchange credentials. However with users in Exchange online, Skype keeps asking Exchange Credentials.

    We are using Azure AD Connect pass-through authentication. If I put credentials manually Skype connect Exchange Online successfully.

    Is it a limitation or we have some mistake in configuration?

    Thanks! 

    Monday, June 19, 2017 11:39 PM

Answers

  • This is the answer of Microsoft about my problem:

    https://docs.microsoft.com/en-us/azure/active-directory/connect/active-directory-aadconnect-pass-through-authentication-current-limitations

    Skype for Business Client doesn't support Pass-Through Authentication. I don't know what I should thinking about this answer.

    • Marked as answer by BikeBrother Tuesday, July 25, 2017 1:22 PM
    Tuesday, July 25, 2017 1:21 PM

All replies


  • Hi BikeBrother,

    For SFB client side, please try the following steps:
    1.Use another computer test if there is the same issue
    2.Try to delete SFB cache files: %userprofile%\AppData\Local\Microsoft\Office\15.0\Lync\sip_UserName@Domain.com
    3.Install the latest update for SFB client
    4.Please press Ctrl and right click Lync icon in the taskbar, open configuration information. On the open page check if EWS status and MAPI status are OK

    For server side, please check the configuration between SFB on premise and Exchange online, please refer to the following document, it’s similar to SFB server 2015
    https://technet.microsoft.com/en-us/library/hh533880(v=ocs.15).aspx


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 20, 2017 3:07 AM
  • We have several computers with the same issue. I only see EWS and MAPI status ok if I put credentials manually. IN this case everything seems ok. 

    About article the ProxyFQDN is different from described in article, but as I told before we have a hybrid scenario and with Exchange on-premises SFB works well, only with Exchange Online ask for credentials. And article only refers to Exchange online implementation.

    Thank you,

    Bikebrother

     

    Tuesday, June 20, 2017 11:23 AM
  • Hi BikeBrother,

    Please try to use Microsoft connectivity analyzer test if there are any errors

    https://testconnectivity.microsoft.com/


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, June 23, 2017 9:45 AM
  • You may need to check the fiddler traces from client to understand for which url the prompt is for,how the redirection works from Onprem to online exchange ews.Does you have SSO enabled?

    Jayakumar K

    • Proposed as answer by Alice-Wang Monday, June 26, 2017 2:41 AM
    Friday, June 23, 2017 12:19 PM
  • Hi,

    are users in same domain?

    What is your SFB client version?

    Is SMTP,UPN and SIP the same?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Off2work

    Friday, June 23, 2017 12:55 PM
  • Hi Alice,

    I tested before and all tests are checked with success, only a warning about certificate.

    Regards,

    BikeBrother

    Monday, June 26, 2017 7:47 AM
  • Yes, we have SSO enabled using modern authentication in Exchange online.

    SMTP, UPN and SIP are the same.

    Thanks,

    BikeBrother



    Monday, June 26, 2017 7:50 AM
  • Did you use Microsoft remote connectivity analyzer test if there are any errors?

    If not, please try it.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 3, 2017 8:18 AM
  • Only warning with certificate SSL. Everything else no errors.

    Regards.

    Tuesday, July 4, 2017 11:13 AM
  • Try to run the EWS url and autodiscover url on browser and verify its not prompting for any credentials..and getting you the xml .


    Jayakumar K

    Tuesday, July 4, 2017 11:50 AM
  • Make sure that MFA feature is disabled for users. If MFA is enabled, it is most likely that SfB will continuously ask for Exchange Credentials in hybrid scenario. 
    Tuesday, July 4, 2017 3:53 PM
  • Try configuring oAuth between Skype and Exchange Online. It definitely does not need oAuth for exchange integration. But, it might help.

    https://gallery.technet.microsoft.com/office/Configure-OAuth-between-5705f1ac


    http://thamaraw.com

    Wednesday, July 5, 2017 12:52 AM
  • First of all thank you for all answers.

    I checked almost of our suggestions, but there is a simple question which I think that it is crucial and I still with doubts about that.

    AD Pass-Through authentication works with Skype For Business On-prem? According to this article, seems not: https://msunified.net/tag/pass-through-authentication/

    Until now I can't get an article telling that it is possible or not.

    Thanks.



    Friday, July 7, 2017 3:01 PM
  • This is the answer of Microsoft about my problem:

    https://docs.microsoft.com/en-us/azure/active-directory/connect/active-directory-aadconnect-pass-through-authentication-current-limitations

    Skype for Business Client doesn't support Pass-Through Authentication. I don't know what I should thinking about this answer.

    • Marked as answer by BikeBrother Tuesday, July 25, 2017 1:22 PM
    Tuesday, July 25, 2017 1:21 PM