none
attribute not displaying in user search RRS feed

  • Question

  • Hello, I'm new to FIM.   I have an attribute which will not display on a standard directory search. I know it is getting synched successfully from AD as if I can see it under the advanced/extended attributes when logged in to FIM as admin. Any suggestions? Thanks.
    Thursday, May 28, 2015 7:43 PM

Answers

  • That is handled by RCDC, but Please show me a screen shot, because I believe company is part of the default view.

    P.S: Don't forget to mark this answered.


    Nosh Mernacaj, Identity Management Specialist


    • Edited by Nosh Mernacaj Thursday, May 28, 2015 8:16 PM
    • Marked as answer by paddy-1 Thursday, May 28, 2015 8:31 PM
    Thursday, May 28, 2015 8:16 PM
  • I could have sworn that it was there, in any event.

    You need to EDIT The RCDC. if you are not familiar with this concept, please read https://technet.microsoft.com/en-us/library/ff393653(v=ws.10).aspx  

    Go to Administration - Resource Control Display Configuration
    Find Configuration for user View (Although I suggest including it in all three User RCDCs)
    Chose Export - Save on your filesystem

    Make a copy, in case you need to revert .

    Edit the xml in Visual Studio or another xml editor.

    You need to add a block for company attribute. Copy the costCenter TAG for instance and paste it (right under costCenter if you want it to show there, or else where you want it to show)

    change the costCenter for company everywhere in that tag.

    Go back to FIM and import the new xml

    IISRESET


    Nosh Mernacaj, Identity Management Specialist

    • Proposed as answer by Nosh Mernacaj Thursday, May 28, 2015 8:44 PM
    • Marked as answer by paddy-1 Thursday, May 28, 2015 8:48 PM
    Thursday, May 28, 2015 8:44 PM

All replies

  • I take it this is a custom attribute?!
    Check under search scopes for "All users" under attributes to display, include this attribute.

    Administration -- Search Scopes -- >All users.


    Nosh Mernacaj, Identity Management Specialist

    • Proposed as answer by Nosh Mernacaj Thursday, May 28, 2015 8:06 PM
    Thursday, May 28, 2015 7:50 PM
  • hi, no its not a custom attribute. Is the 'company' attribute. I understand this to be an extended attribute?

    Other extended attributes are displaying fine.

    Thursday, May 28, 2015 8:01 PM
  • "Extended" does not apply here.  Extended, means adding a custom attribute. 

    You still need to do what I asked. This is not an attribute included in the search view by default. Please follow my previous instruction.


    Nosh Mernacaj, Identity Management Specialist


    Thursday, May 28, 2015 8:02 PM
  • Here is what is there out of the box.  After you change it to include company, do an IISRESET and it will show.


    Nosh Mernacaj, Identity Management Specialist

    Thursday, May 28, 2015 8:05 PM
  • hi, yes. tried that. I added 'company' to

    Administration -- Search Scopes -- >All users -- results -- Attributes

    Thursday, May 28, 2015 8:06 PM
  • IIS RESET after that?

    Nosh Mernacaj, Identity Management Specialist

    Thursday, May 28, 2015 8:08 PM
  • Thanks - an iisreset displays it now in the search view.

    A further question if I may - when I click on the person it does not display in the detailed individual view. Could you point me in the right direction to get this working?

    Thursday, May 28, 2015 8:14 PM
  • That is handled by RCDC, but Please show me a screen shot, because I believe company is part of the default view.

    P.S: Don't forget to mark this answered.


    Nosh Mernacaj, Identity Management Specialist


    • Edited by Nosh Mernacaj Thursday, May 28, 2015 8:16 PM
    • Marked as answer by paddy-1 Thursday, May 28, 2015 8:31 PM
    Thursday, May 28, 2015 8:16 PM
  • Thursday, May 28, 2015 8:24 PM
  • I could have sworn that it was there, in any event.

    You need to EDIT The RCDC. if you are not familiar with this concept, please read https://technet.microsoft.com/en-us/library/ff393653(v=ws.10).aspx  

    Go to Administration - Resource Control Display Configuration
    Find Configuration for user View (Although I suggest including it in all three User RCDCs)
    Chose Export - Save on your filesystem

    Make a copy, in case you need to revert .

    Edit the xml in Visual Studio or another xml editor.

    You need to add a block for company attribute. Copy the costCenter TAG for instance and paste it (right under costCenter if you want it to show there, or else where you want it to show)

    change the costCenter for company everywhere in that tag.

    Go back to FIM and import the new xml

    IISRESET


    Nosh Mernacaj, Identity Management Specialist

    • Proposed as answer by Nosh Mernacaj Thursday, May 28, 2015 8:44 PM
    • Marked as answer by paddy-1 Thursday, May 28, 2015 8:48 PM
    Thursday, May 28, 2015 8:44 PM
  • thanks again.. will have to read up on this.
    Thursday, May 28, 2015 8:48 PM
  • Take your time and be careful, as the smallest mistake brakes the view and no one ca view any users.

    Make sure to have the backup of the XML file.

    Good Luck and welcome the to beautiful world of FIM.

    Nosh


    Nosh Mernacaj, Identity Management Specialist

    Thursday, May 28, 2015 8:51 PM