locked
User cannot Check In documents RRS feed

  • Question

  • I accidentally posted this in the 2010 forums so I am reposting here:

    We are running MOSS 2007 SP2 and one of our users is having an issue when checking a document into a document library.  Here are the steps the user is following:

    • Navigate to document library
    • User clicks on document and it opens in Excel 2007
    • User clicks File>Server>Check Out and document is checked out (User receives message that local drafts folder will be used)
    • User makes an edit to the document.  When they click File, the only available options are Save and Save As.  User clicks Save
    • After save, user clicks File>Server>Check In (this is grayed out until user clicks Save in previous step)
    • User enters any version notes and clicks OK
    • When user tries to exit Excel, following error is received:

    Other users cannot see your changes until you check in.  Do you want to check in now? (No matter how many times the user clicks "Yes", the same message pops up and the document is never checked in)

    If the user clicks "No" on the above warning, the document remains checked out but Excel closes.  If the user clicks on the Document dropdown list and clicks "Check In" from there, they see this error:

    The document was checked out to your local drafts folder but the local copy could not be checked in to the site.  Close any application that is editing the document and try to check in again, or discard the checkout.

    Other users, including myself, are able to successfully check the document out and check it back in so this appears to be a configuration issue on the user's machine.  Here are the steps we have tried so far:

    • Ran Office 2007 Diagnostics - It did identify and correct one issue but the Check In issue remains
    • Cleared cache in IE7 by clicking Tools>Internet Options>Delete in Browsing History section (after complete, we closed all browser windows and retested)
    • Tried opening the file directly in the SharePoint drafts local copy folder and Check In from there, but this also does not work

    Any ideas?

    Wednesday, November 17, 2010 1:20 PM

All replies

  • what Office version do you use and what version your customer use - are they different? If some functional works for most customers most probably issue in the client environment. May be some important update was not installed on client machine - so check Office versions first

    Blog - http://sadomovalex.blogspot.com
    CAML via C# - http://camlex.codeplex.com
    Graphs visualization in Sharepoint - http://spgraphviz.codeplex.com
    Wednesday, November 17, 2010 2:06 PM
  • The user is an internal user and we are all on Office 2007.  I remoted into their PC to double-check that they did not have a conflicting version of Office installed.  For good measure, I even ran the Office 2007 Diagnostics but that did not help.

    Wednesday, November 17, 2010 7:15 PM
  • Have you installed Office 2007 in your sharepoint server?
    Sara
    Wednesday, November 17, 2010 7:27 PM
  • I mean exact version of Office - 4 number digit version (e.g. 12.0.6425.1000 SP2 MSO) which can be found when you click in menu round button > Excel options > Resources > about Microsoft Office Excel 2007. Do you have all 4 version numbers equal?

    Blog - http://sadomovalex.blogspot.com
    CAML via C# - http://camlex.codeplex.com
    Graphs visualization in Sharepoint - http://spgraphviz.codeplex.com
    Wednesday, November 17, 2010 8:06 PM
  • Hello,

    There is no need to install Office on the SharePoint Server and you shouldn't do this.  This looks to be an issue with the client machine.  What is the opearting system of the machine?  Is the Webclient service started on the machine?

    Instead of running the diagnostics try and do a repair of Office to see if that helps. 

    -Aseem


    This posting is provided "AS IS" with no warranties, and confers no rights
    Friday, November 19, 2010 3:41 PM
  • We tried doing a complete uninstall of Office 2007 and a fresh reinstall.  After a reboot, the issue remains.  Any other ideas?
    Tuesday, November 23, 2010 2:00 PM
  • What is the operating system of the machine?  Is the Webclient service started?  Is it a user profile issue?  If another user logs into the problem machine does the same issue occur?  If the problem user logs into another machine does the problem follow the user? Are you familiar with Process Monitor?  http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx 

    Run a process monitor and see if you can see anything in the log that could be causing the issue. 

    -Aseem

     


    This posting is provided "AS IS" with no warranties, and confers no rights
    Tuesday, November 23, 2010 6:31 PM
  • User's OS - Windows XP Professional - SP3
    Webclient Started? - Yes, I restarted the service and the issue still remains
    User Issues - Other user's who use the same machine have the same issue so it's definitely some configuration issue.  If this user uses a different machine, he is able to check out/in without any issues.

    I tried another test with the user:

    • Clicked on Excel sheet in document library
    • Clicked "Check Out" in Excel (document does check out)
    • Click File>Save As and pasted the URL of the document library in as the file name.  Normally, this would display the contents of the library but this user receives an error that the location cannot be found.  I tried the same steps on my machine and the location is found

    It seems like the data can be pushed from SharePoint to Excel fine but it cannot be pushed back.  Any other ideas?

    Wednesday, November 24, 2010 4:12 PM
  • I should also mention that the user is prompted as to whether or not they want to use their local drafts folder when they check out.  The document is copied to the local drafts folder correctly, it just can't be checked back in.  Any help would be appreciated.
    Monday, November 29, 2010 1:39 PM
  • Does anyone find any solution for this problem? It seem to be happy out of no where, users just suddenlly can't edit document and open as read-only!
    Thursday, June 9, 2011 5:42 AM
  • Hi,

    PLease check with the the article http://support.microsoft.com/kb/833714 and follow Method 2: Install SharePoint support and also Method 3: Register the Owssupp.dll file and see if that works on the problem client machine.

    Thanks,

    Raj

    Thursday, June 9, 2011 9:43 AM
  • Hi,

    Have you tried my above plan? ...please let me know the outcome.

    Thanks,

    Raj

    Monday, June 13, 2011 10:42 AM
  • Does anyone know the solution to this issue?  I am having the exact same problem with a user.
    Thursday, October 3, 2013 9:44 PM