locked
Free busy not working on One of the Exchange server RRS feed

  • Question

  • Hi we were asked to work on an issue where we found for some users free busy isn't working at all. However it is not the case for all. Checking further we found it is only one of Exchange servers where the mailbox is hosted are having free busy lookup issue.

    We put the server in maintenance mode, moved all database and mailboxes to other servers and issue was fixed for them. We rebooted the problematic server in question but still the issue isn't fixed. I have moved back one of the database back to the server and free busy issue still exists. Any idea, what could be the problem and where we should look at?


    Regards BM

    Wednesday, June 5, 2019 5:24 PM

All replies

  • Have you already checked the properties for EWS with PowerShell and cross-referenced that with the other servers?


    Robert Sparnaaij [MVP-Outlook]
    Outlook guides and more: HowTo-Outlook.com
    Outlook Quick Tips: MSOutlook.info

    Wednesday, June 5, 2019 8:00 PM
  • It's not necessary to put a server in maintenance mode to move mailboxes from them.

    Look at the certificates on the server.  Is the self-signed certificate expired?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Thursday, June 6, 2019 2:30 AM
  • Hi GoodResource,

     

    Does this issue both happen on Outlook and OWA?

     

    Make sure that EWS has been set up correctly. Outlook uses EWS to get Free/Busy information. Once EWS has not been configured properly, the Free/Busy information may not display correctly. Check EWS with Test E-mail AutoConfiguration.( right-click the Outlook icon in the notification area, and then click Test E-mail AutoConfiguration).Are they all setup correctly?

     


     

    It also might relate to autocomplete, please try the following steps:

     

    1.Create a new meeting request.

    2.When typing attendee's name, it should see a dropdown/autocomplete of the user's name.

    3.Click the stylized X on the right side of the dropdown item to delete it.

    4.Once the dropdown entry is gone, use the 'Check Names' button to have it check against GAL and complete the entry.

    5.Check Scheduling Assistant and see if that resolves.

     

    It's also suggested that looking into the Event Viewer to verify whether there are some related errors or warnings included, like event id 5016.

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, June 6, 2019 7:30 AM
  • EWS is all set up correctly. self signed certificate is valid too. Please note it is happening only one server out of all the rest of the servers in DAG. All virtual directories are set up correctly i found, similar set up with other servers. Deleted the autocomplete cache and it's the same case. In scheduling assistance it is always choosing fresh from GAL. Also it is happening for OWA, Outlook cached and Outlook online mode all. 

    Regards BM

    Thursday, June 6, 2019 1:01 PM
  • Hi GoodResource,

     

    Since the issue occurs on an Exchange server, to avoid the config field corruption impact, you could try to replace the web.config file in the web services directory (C:\Program Files\Microsoft\Exchange Server\V15\FrontEnd\HttpProxy\EWS), with the one in other working servers, modify the server name within the file.

     

    If the issue persists, please run the following cmdlets both on the problematic server and the working server, then export the results to the notepad, please send it to our mailbox:ibsexc@microsoft.com , we will analyze the settings for troubleshooting.

     

    Get-ClientAccessServer | fl Name, *auto*

    Get-ClientAccessServer | Get-WebServicesVirtualDirectory | fl ServerName, *url*, *auth*

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, June 7, 2019 7:40 AM
  • Powershell export:

    Name                           : Exchserv01

    AutoDiscoverServiceCN          : Exchserv01

    AutoDiscoverServiceClassName   : ms-Exchange-AutoDiscover-Service

    AutoDiscoverServiceInternalUri : https://autodiscover.mydomain.com/Autodiscover/Autodiscover.xml

    AutoDiscoverServiceGuid        : SomeGUID

    AutoDiscoverSiteScope          : {Site1}

    InternalNLBBypassUrl          :

    InternalUrl                   : https://mail.mydomain.com/EWS/Exchange.asmx

    ExternalUrl                   : https://mail.mydomain.com/EWS/Exchange.asmx

    CertificateAuthentication     :

    InternalAuthenticationMethods : {Ntlm, WindowsIntegrated, WSSecurity, OAuth}

    ExternalAuthenticationMethods : {Ntlm, WindowsIntegrated, WSSecurity, OAuth}

    LiveIdNegotiateAuthentication :

    WSSecurityAuthentication      : True

    LiveIdBasicAuthentication     : False

    BasicAuthentication           : False

    DigestAuthentication          : False

    WindowsAuthentication         : True

    OAuthAuthentication           : True

    AdfsAuthentication            : False


    Regards BM

    Friday, June 7, 2019 7:02 PM
  • Hi GoodResource,

     

    I analyzed your Autodiscover and EWS configuration, the AutoDiscoverServiceInternalUri parameter specifies the internal URL of the Autodiscover service. The InternalURL parameter specifies the EWS URL that's used to connect to the virtual directory from inside the firewall. Please execute the Set-ClientAccessServer command to modify the e AutoDiscoverServiceInternalUri parameter as https://exchserv01.mydomain.com/Autodiscover/Autodiscover.xml , execute the Set-WebServicesVirtualDirectory to modify the InternalUrlparameter as https://exchserv01.mydomain.com/EWS/Exchange.asmx ,then try again.

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Proposed as answer by ThinkCenter Wednesday, June 12, 2019 9:20 AM
    Tuesday, June 11, 2019 9:37 AM
  • Hi GoodResource,

     

    I am writing here to confirm with you how the thing going now?

     

    If the above suggestion helps, please be free to mark it as an answer for helping more people.

     

    Regards,

    Kelvin Deng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, June 14, 2019 10:11 AM