Windows image restore (Error code 0x80070057; "the parameter is incorrect") RRS feed

  • Question

  • Hi! :)

    I have a Samsung PM800 256GB SSD. I made an image backup two nights ago with Windows 7 Ultimate 64-bit. Then yesterday I had some issues with partition alignment which somehow botched the Windows Repair/Recovery Environment found in "Repair Your Computer" when you hit F8 on boot. Windows, however, was fine after a startup repair and the partition was aligned perfectly. :)

    However, I couldn't get the Recovery Environment back so I did a fresh install of Windows Professional 64-bit onto my system. The recovery partition was there (and on a side note, it was aligned correctly, too). I am now trying to restore the image I made a few days ago. However, I realize I cannot conduct this restore (of the image) if I
    access the recovery environment through the hard drive (tells me it can't restore because the environment is on the hard drive which is to be restored) or a disc (I cannot eject a disc in the recovery environemnt due to lacking drivers for the touch-sensitive eject key). So I put the Recovery Environment on a flash drive which seems to work fine, though I cannot be certain that this is working perfectly.

    Nonetheless, I insert the disc with my backup (50GB Blu-ray DL) and the jump drive. Boot into the recovery environment via flash drive (my motherboard supports USB booting) and attempt to restore the image. It tells me it will have to format the drive, etc. However, as soon as I click the final "yes" prompt and it starts to restore, it immediately spits an error at me:

    Error: The parameter is incorrect
    Code: 0x80070057

    I have google'd this for hours, no luck: so few people have this problem and if so it is in MAKING the backup, not restoring it.

    The disc is fine: I've cleaned in numerous times. If you can't figure out the solution, can someone PLEASE tell me how to get this image onto my hard drive somehow? It is a *.vhd file about 18GB in size, but it includes a handful of other cryptically-titled files. :/



    Some possible useful bits of information:
    I made an image of my 7 Ultimate 64-bit drive, but only had a 7 Pro disc handy. I have my Ultimate 64-bit key, but don't have the disc currently. So I'm trying to restore an image of 7 Ultimate 64-bit onto my 7 Pro 64-bit installation: issue?

    There were no errors when making the image.

    Idea: wipe the drive clean (how?) and then use the image restore tool on my jump drive? I would do this RIGHT now, but I don't know how to format the hard drive without concurrently installing Windows. I have GParted (which I initially used to align the partition) on a disc: just use that? I want to be SURE that this is a good solution, though: if I formatted it, tried the restore and it failed, it would be a PITA to have to reinstall 7 again. :(
    Thursday, January 28, 2010 5:18 PM


  • Guys. I fixed it. It's doing the image restore now.

    I called MS and they told me that you can't do an image restore unless ALL the drives are exactly as they were. Meaning when I was using my jump drive to initiate the recovery (because I can't eject the recovery disk to put in the image disk), it was counting that as a drive. So no go on using a jump drive to initiate the Windows Recovery Environment. That was what was the "the parameter is incorrect; 0x80070057" error.

    I figured out a workaround that I should have seen INSTANTLY. All this time, it's been there. When you're selecting an image, Microsoft realized some people might have their images on external drives which require special drivers. You just go there and wala, you see a Browse icon. Go in there, right-click the optical drive, eject, put in the one with the image.

    It's restoring now.

    OH YEAH!

    And, btw, if you were wondering, 3 is the limit of times you can clean install from an upgrade disk on 7. I had to call and get that working,too.

    • Marked as answer by Dale Qiao Monday, February 1, 2010 1:52 AM
    Saturday, January 30, 2010 3:30 AM

All replies

  • Bump.

    New information:

    -Used diskpart to "clean" hard drive. Attempted restore again: 0x80070057.
    -Used Vista Recovery Environment to attempt a restore as this person had:
    He had the exact same issue I did, but he was able to fix it using the Vista Recovery Environment. Is he correct in stating that the Windows 7 Restore Image tool only will restore if it is the "same OS, same installation"? I would hope not!

    Thursday, January 28, 2010 10:45 PM
  • Bump, I was able to force an install using some wbadmin commands.

    However, now I'm at a blinking cursor, black screen, no boot. Startup Repair (finally!) recognizes my old install and doesn't detect any problems. I've tried bootsect, bcdedit, diskpart, etc. Nothing.

    I'm so close. Anyone have ANY IDEA of how to fix this? I can access all my old files through command prompt, but I just can't get the darned thing to boot! :(

    Thanks in advance.

    Friday, January 29, 2010 4:07 AM
  • Guys. I fixed it. It's doing the image restore now.

    I called MS and they told me that you can't do an image restore unless ALL the drives are exactly as they were. Meaning when I was using my jump drive to initiate the recovery (because I can't eject the recovery disk to put in the image disk), it was counting that as a drive. So no go on using a jump drive to initiate the Windows Recovery Environment. That was what was the "the parameter is incorrect; 0x80070057" error.

    I figured out a workaround that I should have seen INSTANTLY. All this time, it's been there. When you're selecting an image, Microsoft realized some people might have their images on external drives which require special drivers. You just go there and wala, you see a Browse icon. Go in there, right-click the optical drive, eject, put in the one with the image.

    It's restoring now.

    OH YEAH!

    And, btw, if you were wondering, 3 is the limit of times you can clean install from an upgrade disk on 7. I had to call and get that working,too.

    • Marked as answer by Dale Qiao Monday, February 1, 2010 1:52 AM
    Saturday, January 30, 2010 3:30 AM
  • Right on, Ibrahim. I had the same issue and error message except I loaded Windows 7 from USB stick. Your message and it was a great help. My fix: I went through all the steps in the image restore until the final confirmation buttom is to be pressed and removed the USB stick right at that point. Result: the system is restoring now.
    • Proposed as answer by Jason H. _ Thursday, March 17, 2011 10:46 PM
    Tuesday, February 16, 2010 5:44 AM
  • While this wasn't exactly what helped me, it was the final clue in my figure out wtf was the cause of my error "the parameter is incorrect; 0x80070057".

    My situation was this:

    - Created my Win7 64bit sys image to an external HDD connected via USB. 
    - Booted W7 Repair off a USB drive, created by making an iso of the cd and following these instructions
    - No issues up til the last step before recovery when the dreaded error would pop up immediately.
    - I recreated the backup image with a multitude of variation to no avail.
    - Finally, partly out of sheer frustration, I pulled the usb flash drive out after it had booted the recovery instance but before attempting to begin restoration.
    - Magically, this time when I hit "next" to start, the parameter was now correct and the image restored normally.

    That's it... just needed to remove the recovery boot flash drive prior to starting.  Argh.
    • Proposed as answer by matt_shoe Saturday, April 5, 2014 1:26 AM
    • Unproposed as answer by matt_shoe Saturday, April 5, 2014 1:33 AM
    • Proposed as answer by Nixu Friday, September 18, 2015 6:59 AM
    Saturday, February 20, 2010 1:54 AM
  • I had a very similar situation to M.Rock.  I was attempting to upgrade the hard drive of my Lenovo X200 - which does not have a CD/DVD drive.  My idea was to create a System Image on my local network (samba), swap the drive on the X200, then restore the image to the X200.  To this end, I created a recovery disc using the old machine, then copied the files on said disc to a bootable usb stick. The X200 booted fine from the stick, but the recovery process hanged with the error:

    Error: The parameter is incorrect
    Code: 0x80070057

    I admit, I was embarrassed to discover that my parameter was incorrect.  Nonetheless, I took to teh internets looking for a cause to this incredibly general error message.

    My fix turned out to be identical to M.Rock's: I pulled the usb stick out immediately before the confirming the restore and it seems to be working.

    Why is it so difficult to upgrade the hard drive?  This is the second system where Windows 7 Backup and Restore has not functioned in a sane manner (I have another outstanding issue on Microsoft Answers from the old system). This is really easy to do on *nix systems (the bullet-proof tank upon which I find myself typing this increasingly rant-y message) so I can't imagine it is a technical issue.  This feels like somebody's idea of copy protection, except that it (almost) foiled a paying customer from performing a really basic system upgrade.
    Sunday, March 7, 2010 7:27 AM
  • Great advise!   I have an x41t that keeps losing its 7 image or corrupting data on the SSD any time i test usb bootable devices...

    I actually carry the h/d with the backups when travelling incase it corrupts data or just doesnt boot(as it JUST did).

    This time I had it (backup) in an internal drive bay on an x4 base, as opposed to usb enclosure, and used a usb key as opposed to a dvd in the x4 base.

    So, I go to restore from the backup i just made 2 days ago before leaving work, and.....

    Error: The parameter is incorrect
    Code: 0x80070057

    I was perplexed!  You ABSOLUTLEY made my day with this, as i didnt want to have a dead laptop on the first day of a class.

    its sitting at the screensaver right now.  Thank you.


    (for the record, with the standard h/d in it, it works fine w xp - thinkin ssd)

    Monday, August 16, 2010 2:16 AM
  • Thanks for the fix... I don't understand why I should have had this problem in the first place!

    Just pull out the drive before confirming and you should be fine :)

    Wednesday, December 1, 2010 7:29 PM
  • Ibrahim,

    Could you give me a detailed step by step guide for how you resolved your problem (or if anyone else can)? I am running vista and trying to restore from an external hard drive and upon restoring I continually get the error 0x80070057. I have the old drive in currently and a new one with vista preinstalled on it from Dell. I noticed you mentioned something about using DVDs...if I backed up my old drive on DVDs instead of the external hard drive would that solve my problem?


    Monday, January 10, 2011 4:45 PM
  • HI,

    I've just had the same problem.  Basically Windows Vista/7 treats USB drives as internal disk drives and therfore when you try to recover your image the disks Windows sees in the image don't match the physical disks on your computer (why it lets you do an image to a disk and then complains about it i'll never know?). 

    As your image is on a external drive you can try putting it on DVD however I don't think it'll work, the best option is to create a share on another windows computer, create a folder in it called 'WindowsImageBackup' YES that's all one word, then copy the whole backup folder off the external drive to the share.  You should be able to boot to the recovery disk/pen drive and then click advanced and select connect to the network....the rest should be straight forward.

    Job Done!

    Friday, January 28, 2011 2:36 PM
  • This does not just apply to restoring.  I have the same error when I was trying to create my restore iso.  The answers above make me think, just maybe.  Remove my pendrives from the machine and tried again and bingo!


    thanks guys



    Thursday, April 28, 2011 12:59 PM
  • The backup software DOES NOT WORK!!!  Microsoft DOES NOT CARE!!!!!

    Obviously Vista and Windows 7 can't support backup.  They have failed and ripped me off twice snd I have spent weeks of time dealing with the consequences.  Search the Internet and you'll find soo many people on all types of computers with fresh clean installation that have this problem.

    Vista's backup failed and NEVER worked.  MS support tried to work with me and after 3 months of every level of tech support could not fix the problem, they told me the answer was to wait for Windows 7 for the fix.  My Vista system had many major meltdowns. Having no backup or repair disk I was not able to recover and every few months I needed to spend a day rebuilding the operating system.

    I resisted paying $100 for an upgrade to fix a problem that should have worked in Vista. Desperation must be Microsoft's marketing plan. I broke down and bought Windows 7 Pro, installed all the updates and ran the backup "Create a system Image".  It backed up to a Blu-Ray disk. at the end Windows asked if I wanted to create a "System Repair Disk"?   I selected to create one on a DVD in the Blu-Ray burner.  It FAILED giving me the error number I will remember as long as I live, 0x80070057.  I tried this again on the DVD burn and the same error occurred. 

    Has anyone used a backup software that has restored Windows 7 or Vista from a major corruption?  I tried Acronis and it backed up but would not restore Vista.  I've considered Retrospect, has anyone used it?

    Thanks Nick Brown nickb201 AT gmail DOT com

    Monday, May 9, 2011 3:07 AM
  • I just want to thank you so much!!!  I was having your issue with Windows Server 2008 R2.  My server all of a sudden crashed, due to software, so because I do an automatic full system backup at 1:00 AM every day, I thought I could restore it.  I went through the exact process you described because Windows Server 2008 R2 is basically Windows 7 "gone server."  I didn't remove my recovery flash-drive before re-imaging, so I got the error.  As you said, there isn't anything else on the web about this.  I understand that you could have called Microsoft, fixed your problem, and been done, but instead, you posted you findings with the world so that others can have their problem fixed.  Because of your consideration, my server is re-imaging right now as I type and my entire network should be "saved" in about and hour.  Thank you so much!!!
    Monday, January 23, 2012 4:14 AM
  • Your suggestion was what did it for me; I kept getting the message UNTIL I removed the USB just before giving the final confirmation.

    For those who might want to know how to create an Emergency Repair Disk on a thumb (USB) drive, watch this video:


    Saturday, May 26, 2012 7:24 PM
  • Actually The answer (in My case) was (http://technet.microsoft.com/en-us/library/cc757491%28v=ws.10%29.aspx) to change the drive letter. For some reason it was assigning the Drive I wanted to restore to the letter J and the drive to restore from: the letter C. I changed the drive letters with DISKPART and it restored like magic. Now my client is back up and running!
    Thursday, June 14, 2012 4:34 AM
  • One thing that also works is that you can unplug the USB drive before you get to the drive selection part.  Once you've booted, and after you begin the restore the USB drive isn't going to be used for anything else.  

    Works 100% of the time for me.

    first I back up my machine and elect to create a recovery disk

    then I rip the recovery disk into an ISO 

    I use "iso to usb" to create a bootable usb key from that ISO

    set up the computer so that bios 0 drive is my new C drive, and my image drive is bios drive 1, however I need to do that.

    sometimes you also have to run diskpart and 'clear' the target drive... even after removing partitions there are sometimes reasons why that needs to happen
    you do this by running diskpart, selecting the drive (make sure it's the right one) and entering the clear command.  Not something you want to do in error

    boot from the USB key

    select restore from system image

    when you have system image selected and target drive selected, remove the usb key, give it a moment to settle and hit the next button

    if you do not remove the usb key, you will get an error about 'invalid parameter'

    Tuesday, July 24, 2012 1:49 AM
  • Thanks Ibrahim.jadoon!

    Pulled the USB Stick out and the restore is now working.  Awesome!


    Thursday, October 11, 2012 2:19 PM
  • Thank you all so very much. My Dad gave me his two-year-old 60G OCZ Agility 2 when he upgraded to a 90G. Of course, a month later, it flat out died--unrecognized by BIOS.

    Having had miserable luck with SSDs in the past, I create a system image every week. I thought it would be easy to put in an old 80G SATA HDD and restore my three-day-old system image (using my Windows 7 USB stick).

    System image failed. Parameter is incorrect 0x80070057.

    Fortunately, Google is my friend, and I found this post. As soon as I pulled out the USB stick and hit Enter, it restored my image.

    Thank you!

    Thursday, December 6, 2012 2:41 AM
  • In my case I was recovering a laptop and booting off a USB Key (with the recovery DVD on it, via www.pendrivelinux.com) and the backup on an external USB hard disk.

    The Laptop Hard Disk (an SSD) had been securely wiped and was being completely restored.

    On boot, the USB Hard Disk was being seen as the C: drive, and thus trying to restore to restore the Image to the C: drive was failing (obvious in hindsight).

    The solution that worked for me as follows;

    1. With only the USB Key inserted, boot the laptop from the USB Key
    2. Let the restore program boot up and get to the point where it looks for a image to restore
    3. Then plug in the USB Hard disk
    4. Select latest backup system image.
    5. Start recovery

    Works fine for me after about 30 minutes of googling for answers!

    Saturday, November 2, 2013 4:40 PM
  • this works!

    before selecting the restore image pull out your memory stick. everything will still work.

    select the image and then you can restore without error!

    thnx for this article,


    Thursday, November 21, 2013 10:03 AM
  • hello. i have tried these on my laptop. i pulled out the usb stick and put the hard drive in so it was coming from the same drive letter. still no luck. it will go through the process but will give me the same error. i dont know what to do since during the restore process it reformatted my hard drive. so i dont have any way of getting the factory partition back on my computer other than restoring the image i have backed up. so now i dont have a working computer... if anyone can help me please. i need it. 

    backed image up onto external hard drive
    booted from usb drive with windows 8.1 recovery drive on it
    tried removing usb stick before doing restore, no luck

    • Edited by Caleb Pang Tuesday, December 3, 2013 9:34 PM
    Tuesday, December 3, 2013 9:33 PM
  • My computer was set up like this

    DVD drive (Q)

    Boot SSD (C)

    Backup Harddrive (D) (had the backup system image)

    When the boot drive died, I replaced it with a new SSD and ran a copy of the Windows System Repair from a bootable USB stick. Running the System Image Recovery always failed with either the above error or a more generic failure message that the drives were wrong or not avialable.

    Nothing worked. That trick with pulling out the USB at the final step did not work. I Tried changing drive letters with diskpart. Nope.

    What did work was running the Windows 7 System Repair from the DVD (boot from the Windows System Repair DVD).

    I am building new Windows 7 computers with no optical drives and I wonder if that is a mistake. Let me add my voice to those that are asking"why is Microsoft so careless?" We are recovering your base OS with your built-in tools. Why!?

    Friday, December 6, 2013 5:56 PM
  • Removing the boot USB stick is what worked for me too.

    Thank you. Thank you, thank you.

    Microsoft should be able to handle this better, or at least warn about it.


    Thursday, May 1, 2014 7:36 PM
  • Same for me! Was facing the same issue trying to run a System Image restore for a Windows Home Server 2011 (Windows Server 2008 R2) that crashed. I had created a bootable USB of the install media and used that to get into the restore options, but it kept failing.  Dealing with this for hours and was about to attempt to force a restore using my Windows 8.1 client and the WBadmin commands....then I found this.

    I reconnected the drives that were originally connected, removed the USB after going into the Restore from backup dialog,  and now restore is running. Really Microsoft? What if your original drive failed and you have to switch to a new drive possibly of another size. Is this tool useless then? Now I see why the restore wasn't working when trying to recover to a larger drive. Since the System Image tools are boot aware, I thought it would be easier using than cloning the drive using something like Ghost or RDeploy or even imagex and having to deal with BCD edit.

    The Re-image is still running, which is about 100% better than what it was doing before. Hopefully it will actually boot when done.

    Sunday, May 18, 2014 8:35 PM
  • Hi All

    I think I have the same issue as what's being discussed in this forum.

     I would like to try this but having read through all the discussion I can’t find a complete step by step guide of how to try this.

    The error:

    “There was an unexpected error: The parameter is incorrect 0x80070057) System restore will now close".

    I have tried reg fixe solutions didn’t work and it sounds like you solution works.

    Can anyone help me by doing a step by step guide?

    I have a copy of the restore program on my USB stick which I copied and pasted from a copy I had on a DVD. That’s as far I have got.

    If someone can help me I would be most greatful.

    Thank you in advance for your replies……Andy

    • Edited by Andy_Louey Friday, June 6, 2014 9:58 PM solved
    Thursday, June 5, 2014 10:12 PM
  • Hi All

    As I have said I have the same issue but I managed to solve my issue e.g. (Windows image restore (Error code 0x80070057; "the parameter is incorrect) on my own without using the solution suggested in this forum. I thought I would share this in the hope it may help someone else.

    This is what I did:-

    I went to control panel/system and security/system protection. Take a look in the dialogue box (protection settings) then see what is in the Available Drives heading. There should be in under this heading only the following: - OS (C) (System)

    Anything else under this heading needs to be deleted/removed I had something like “win"7 back and some numbers"

    To remove this do the following below click on the button/ configure/ then tick the box called turn off system protection then press apply then close (OK) the box.

    It will now show System Protection OFF but the other information that was in there e.g. in my case “win"7 back and some numbers" has gone. Now click configure button again check the box Restore System Settings and previous versions of files. Click apply then OK. Now try the system restore it should now be working.

    I am not a hundred percent sure were the error came from but if I were to guess I would say something triggered it during my last backup which failed to complete.

    As there are quite a few reasons for Error code 0x80070057; "the parameter is incorrect yours might not be the same as mine so good luck hope it works for you.

    I hope this helps. Andy

    Friday, June 6, 2014 9:57 PM
  • Amazing.  Pull out the USB stick you booted with so the system can look like it did when the image was created.  Unbelievable.  I have been frustrated for hours before this post.  Now my system image is restored... Microsoft, are you serious?  You can't just make it intelligent enough to let the user specify the restore target?

    And about this network location thing... after I figured out that the network card driver wasn't generic and the mfr driver had to be installed during the process, I was hung up for an hour trying to figure out why the connection to the network share wasn't showing any image files.  Since there is no browse capability for that dialog (even though you can browse for your driver files when you install them) you have to specify the path precisely to the WindowsImageBackup directory, no more, no less.  Zero tolerance.

    This process was definitely not user friendly... but we're back running again thanks to M.Rock and the others in this post.

    Wednesday, December 17, 2014 4:28 AM
  • wow thank you, saved my life!
    Monday, February 16, 2015 12:01 PM
  • Attempting to restore a System Image of Server 2008R2. Client did not have an install disk, so I used my copy on a bootable USB drive to get to the System Recovery dialog and restore the system image.

    I ran into the exact same error and used M. Rock's solution. Right before clicking 'Finish', I removed the USB disk and the system restored their original copy successfully.


    Thursday, July 2, 2015 6:36 PM
  • This saved my bacon on a Server 2008 restore.  Mucho Grats.  As an add-on:  I was booting to a USB containing the OS install CD.  Despite choosing the "Exclude" option on that drive, I still got the error.  The fix was simply pulling the boot drive after the server was booted but before beginning the restore.
    Tuesday, July 7, 2015 6:31 PM
  • Removing the drive will work, but you can also click on the button to Exclude disks, then select your USB boot drive. Seems like the system image restore option could have some logic written into it to exclude the obvious drive that's being used to run the software, would save a lot of people much headaches.
    Wednesday, September 2, 2015 3:26 PM
  • I had the image on external hard drive and I booted to the recovery console from Win7 USB-stick. I removed the USB-stick after the boot and was able to restore.

    Thank you! This was the first webpage where I started the troubleshooting of the error message and I was able to fix this issue in 10 minutes. I feel very lucky today :).

    Friday, September 18, 2015 7:02 AM
  • Pulling the USB thumb stick that contained system restore files did the trick for me.  Thanks for this information, I was getting frustrated & confused with this issue on a late night project and this got me going again!
    Wednesday, September 23, 2015 5:35 AM
  • Thank you! Didn't have an option for "Browse" or "Eject" but when I went to the screen to choose the Windows Image I wanted to install, I just removed the USB stick. It's a third of the way done as I type this! Thanks again.
    Friday, September 25, 2015 9:21 PM
  • Thanks for the pointer!  Mine was a bit different though.  I was trying to restore a Surface Pro 2 Win 8.1 Pro image from a smaller SSD (128GB) to a model with the larger 256GB SSD.  The image is on an external USB3 HDD & I was running the recovery environment from a Micro SD card in the in-built reader.  I wasn't getting the error at the restore start, but only at the end (which nuked the restore anyway).

    Just pulling the microSD card at some point during the restore fixed it.  So restoring to a larger drive does work.  Of course it restored the partitions as they were, leaving 50% of unallocated space at the end of the drive, but you can shuffle that with the in-built Disk Management (I hope, about to try) or various free partitioning software.

    Saturday, November 21, 2015 5:33 AM
  • In my case, I upgraded from Win 8.1 to Windows 10 Pro in September.  I created a recovery DVD and made a system image backup onto the second physical hard drive in my system via System Image in Control Panel.

    I began to experience  blue screening after waking from hibernation, never otherwise.  The memory dump analysis did not show which driver was the culprit.  I chose to run Verify to debug the drivers.  After that, my system never re-booted and went to Recovery Mode.  Fix start up problems failed.  System restore failed.  I boot into safe mode and turned off Verify from the command line options.My system still would not boot, going into recovery and diagnosis.

    Next i tried a system image restore.  The PC located the system image and the en result was the error of this thread.  I ran diskpart and found the System Reserved and Recovery partitions to be in NTFS while the OS partition was listed as RAW file type.  Drive letters were not correct as System Reserved was listed a drive C.

    Using diskpart, went as far as formatting the system OS partition to NTFS and changing the System Reserved and Recovery partitions to no drive letter and formatting the OS partition as NTFS with drive letter C.  Even the disk with my image on it was correctly identified.

    My boot drive is an IBM 535 SSD and my backuyp drive a plain old Seagate 500 GB platter.  Both drives passed chkdsk /f without problems.

    I even tried removing my drive with the image from the SATA port to a USB port.  Nothing worked  Same old error.

    Now I have no operating system, no image that can be restored a lot of time wasted.  My last resort will be to pull the SSD, run it through IBM tests and securely erase it and try the image restore again.  If if fails, I have to re-install OS and do all the upgrades and then, thankfully I have all files backed up into the cloud.

    But this is certainly a disappointing issue when running Verify program ruins your computer and OS and your backups and recovery do not work and nothing available on-line seems to help.

    Sunday, November 29, 2015 7:34 AM
  • This is an old thread, but I have some info that may be useful:

    I had a similar problem with trying to restore a Windows Backup image from an internal hard drive to an an internal RAID 5 array (basically a C drive), using a USB thumb drive to boot into Windows Recovery.

    No matter what I did - removing the USB thumb drive at various times did not make the "parameter is incorrect; 0x80070057" error go away. The suggestions of removing the USB Windows Recovery thumb drive just before the last step changed nothing.

    The problem is that USB thumb drives screw around with the drive lettering. Once I connected a USB CD-ROM drive, inserted a Windows 7 installation DVD, and and started the Windows Recovery environment from there, was I able to restore the image from the internal hard drive to the RAID.

    Thursday, January 21, 2016 1:19 AM
  • Nailed it!  Why, oh why, does Microsoft do such silly things?  The restore program lets you unselect particular drives to be formatted (so I unselected, or rather, selected for omission) my thumb drive, but then it gives the error seen above.  Removing it completely after all selections are made with the image selected, waiting for the "next" button to be clicked, and then it works.

    Why do they not anticipate people booting from a thumb drive?  They can be so frustrating.

    Tuesday, May 10, 2016 6:56 AM
  • What worked for me was 

    1. I created the image in an external drive

    2. I had to create a "Boot CD/DVD" and boot from it.

    3.  make sure you don't have any other usb hdd other than the image ones plugged in.

    and that's it.

    Thursday, September 15, 2016 8:18 PM
    Tuesday, October 25, 2016 2:50 AM
  • Hi!
    My solution:
      Starting Computer Setup disk or an Emergency Repair Disk.
      Shift + F10
      list disk
      sel disk 0 (0 = where the reset required)
    PC is restarted. Start the installation disk or an Emergency Repair Disk.
    Next steps Troubleshooting - Restore system image.
    Sunday, January 22, 2017 2:28 PM
  • I had a similar issue. In my case I was trying to restore an image of a Windows 10 installation to a new (larger) SSD disk from an older, failing, hard drive. I was booting from a Windows 10 repair CD built on the original system.

    The restore would proceed all the way to 100% (hours later) and only then fail with 0x80070057 Parameter Incorrect.

    After much trial and error, I was able to determine (using diskpart) that the image restore had apparently succeeded, but the drive was simply not flagged as bootable and did not have a drive letter assigned.

    I was able to get things working by closing the error message, and opening a command line. I then used bootrec to fix the Master Boot Record:

    bootrec /FixMbr

    bootrec /FixBoot

    bootrec /ScanOs

    bootrec /RebuildBcd

    and then using diskpart:

    sel disk 0

    sel vol 0

    assign letter=c:

    At this point I exited the command line and the "Proceed to Windows 10" option was offered by the repair process.

    Ejecting the CD and Rebooting successfully booted the re-imaged Windows 10.

    Sunday, February 19, 2017 11:49 PM
  • In my case it was necessary to run chkdsk c: /f after getting the 0x80070057 Parameter Incorrect error.

    Even though diskpart was showing the partition as RAW just go ahead and run chkdsk and then restart your computer.

    I hope this saves someone a lot of grief. It took me some digging to find it.


    • Proposed as answer by RubyT Tuesday, February 27, 2018 11:48 PM
    Wednesday, March 8, 2017 4:04 PM
  • I realize this is an old thread, but I was just doing a quick DR test on a system and ran across this very same issue.  I read it and thought "yeah, whatever." and then I tried it.  Worked like a champ.  Of course it would... had I used the DVD I never would have had this issue to begin with.  Thank you for this post.

    Friday, August 4, 2017 1:25 AM
  • Great!!!!

    Saturday, January 27, 2018 9:16 PM
  • Thanks Mark, it did save me a lot of grief.  Running chkdsk c: /f and restarting fixed the the problem. 

    I'm a little frustrated that Microsoft shipped me my copy of Win 10 Pro /on a USB drive/ and yet you cannot use said USB drive for the recovery environment to do an image restore without problems.  Really?  I would have bought a DVD had it been available!

    It's eight years and two operating systems later, how is this still a thing?

    Tuesday, February 27, 2018 11:55 PM
  • Hi, I was with the same problem., but with windows 2008 r2 server.

    I did the same procedure before to click next to restore backup, I removed the usb flash disk with a win2008 boot instalation.

    And, the image started to restore, without a fail message box.


    Wednesday, March 14, 2018 1:11 PM
  • thanks Nate, this worked for me!
    Wednesday, August 29, 2018 8:52 PM
  • Thanks for posting the answer!!  I was struggling with the same issue and pulling out the USB stick right before hitting finish got it to get started, you saved me hours of troubleshooting!!

    Sean Sutton

    Wednesday, February 6, 2019 8:13 PM
  • RAM Upgrade Issue

    I had the error 0x80070057 when upgrading to a new larger 2TB HDD. I also upgraded my ram from 6 GB to 16 GB. When I tried to restore my system to the new drive it kept giving the 'parameter 0x80070057' error.

    After trying many suggestions online and having no luck I decided to put the old 6GB ram configuration back in and it finally worked. I thought the ram would have no relevance to the system image due to its plug and play nature but obviously it does, so I guess changing anything system related will abort the image restore process.

    Friday, April 12, 2019 11:28 PM
  • Old post but if you're getting 0x80070057 error at the end of an image restore and diskpart shows RAW on the volume this might be relevant:


    This worked for me on a Win10 image restore.



    Wednesday, June 5, 2019 8:50 PM