none
ServerManager.exe Fails to load RRS feed

  • Question

  • Windows Server 2012. I'm attempting to open Server Manager and I get the following error message.

    This server is a virtual machine. Any idea?

    Friday, November 13, 2015 4:26 PM

Answers

  • Wish I had found this sooner.

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/a96a0415-494e-40a6-bf04-c65e00b8eeb5/server-manager-fails-to-load-with-the-error-a-device-attached-to-the-system-is-not-functioning

    • Marked as answer by MarkGiemza Wednesday, November 18, 2015 9:39 PM
    Wednesday, November 18, 2015 9:39 PM

All replies

  • Open cmd.exe with administrative privileges. Then type the following 2 commands

    Set Devmgr_Show_NonPresent_Devices=1

    Devmgmt.msc

    then look for devices with bangs or triangles.

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, November 13, 2015 4:43 PM
  • No devices with bangs or triangles.
    Friday, November 13, 2015 4:51 PM
  • What's the history? New install? If not I'd look at what was recently changed or devices removed that were detached. Also check the system event log for clues.

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.


    Friday, November 13, 2015 5:14 PM
  • The VM was built a little over a year ago. Only hardware added was a 200GB VHD about a month ago. Drive is readable.
    Friday, November 13, 2015 5:20 PM
  • You've given us almost nothing really to go on. I'd probably call it in to product support.

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, November 13, 2015 5:23 PM
  • You've given us almost nothing really to go on. I'd probably call it in to product support.

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    You're right, I'm trying to figure this out myself having nothing to go on. I'm not sure what else I could give you. I connected to this server today figuring I would add a feature and be done, 2 hours later I'm still investigating this error message with nothing in the event log, device manager, or vCenter saying that something doesn't look right.
    Friday, November 13, 2015 5:29 PM
  • https://technet.microsoft.com/en-us/library/cc978749.aspx?f=255&MSPPError=-2147217396

    It could be the USB controller driver or possibly the upperfilter /lowerfilter registry settings.

    https://support.microsoft.com/en-us/kb/929461

    Or also something related to VMTools

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, November 13, 2015 5:42 PM
  • https://technet.microsoft.com/en-us/library/cc978749.aspx?f=255&MSPPError=-2147217396

    It could be the USB controller driver or possibly the upperfilter /lowerfilter registry settings.

    https://support.microsoft.com/en-us/kb/929461

    Or also something related to VMTools

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.


    I can't remove the Floppy Drive from the VM. I tried reinstalling VMTools and the registry did not contain UpperFilters or LowerFilters.
    Friday, November 13, 2015 7:27 PM
  • I'd probably try here

    https://communities.vmware.com/welcome

    or start a support case with microsoft product support.

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, November 13, 2015 7:47 PM
  • Thank you, will do.
    Friday, November 13, 2015 7:51 PM
  • Wish I had found this sooner.

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/a96a0415-494e-40a6-bf04-c65e00b8eeb5/server-manager-fails-to-load-with-the-error-a-device-attached-to-the-system-is-not-functioning

    • Marked as answer by MarkGiemza Wednesday, November 18, 2015 9:39 PM
    Wednesday, November 18, 2015 9:39 PM