none
Excel (There isn't enough memory to complete this action) RRS feed

  • Question

  • Hi, 

    Everytime multiple Excel spreadsheets are open we keep getting the error message saying:

    There isn't enough memory to complete this action. 

    Try using less data or closing other applications.

    To increase memory availability, consider:

    - Using a 64-bit version of Microsoft Excel.

    - Adding memory to your device

    I have tried to increase the memory to 8GB and re-installed to 64-bit version but the application keeps doing the same thing. It freezes occasionally, blank screen appears. 

    What can i do to resolve this?

    Tuesday, December 30, 2014 3:35 PM

Answers

All replies

  • Try switching off the following this helps our users when we see this issue, esp when using many sheets at once. 

    For Office 2013 - Advanced > General > Tick the option - Ignore other applications that use Dynamic Data Exchange (DDE)


    • Proposed as answer by netgeke Monday, August 3, 2015 6:00 PM
    Tuesday, December 30, 2014 3:48 PM
  • Thanks for the suggestion, I tried that before. 

    I have tried so many different types of solutions that i cant even remember which ones i have done.

    Tuesday, December 30, 2014 5:14 PM
  • Hello Dan Maia,

    Sometimes an error message is accurate to the point.
    1. Is this occurring on multiple computers or just one? (You wrote 'We' ...")
    2. What is the total RAM and operating system on this computer / these computers?
    3. After a fresh boot, do you still get this message when using Excel spreadsheets ONLY?
    4. Did this just happen now with spreadsheets successfully used over a period of time?


    Best regards George

    Tuesday, December 30, 2014 6:23 PM
  • how about a blank file? In my view, most of the error due to the formula recalcultion. set it as munal is a good choose.

    btw, increase Virtual Memory size also could choose.

    http://www.techulator.com/resources/2430-Increase-your-Virtual-Memory-size.aspx

    KR

    Wednesday, December 31, 2014 5:07 AM
  • Hi George: 

    1. Is this occurring on multiple computers or just one? (You wrote 'We' ...") - Just one machine
    2. What is the total RAM and operating system on this computer / these computers? - 8GB Ram using Windows 7
    3. After a fresh boot, do you still get this message when using Excel spreadsheets ONLY? - Yes after a fresh boot only happens with Excel
    4. Did this just happen now with spreadsheets successfully used over a period of time? - Yes thats correct

    Hi Robbery:

    You may be right about the formula calculation but these are spreadsheets that have been modified over time so we cant start from fresh. I tried to increase the virtual memory but still no joy. 

    Wednesday, December 31, 2014 8:52 AM
  • Hi again,

    1. Open Windows Task Manager (Ctrl-Shift-Esc). Select tab Performance. Check Physical memory, first without Excel running, then with Excel and no error, then with Excel and error.
    2. Select Processes tab and sort on Memory. Is Excel at top? How much? An empty Excel takes about 36 MBytes RAM on my machine.

    3. Can you successfully run this spreadsheet on another machine? If so, I'd do an offline virus scan on the problematic machine. I have instructions if you need it.


    Best regards George

    Wednesday, December 31, 2014 9:11 AM
  • Do you mean TICK or UNTICK to try and switch off? The default is a blank TICK block.
    If I TICK the option I cannot open any XLSX file by double clicking on the file.I can only open the files by using the File>Open function from within Excel.

    Sunday, January 4, 2015 8:57 AM
  • I'm having this same problem and it just started happening.

    I tried <g class="gr_ gr_8 gr-alert gr_gramm Punctuation only-ins replaceWithoutSep" data-gr-id="8" id="8">rebooting</g> but the issue persists even when trying to create a new spreadsheet.

    I'm running Windows 8.1 64-bit and 64-bit Excel with 16GB in my machine.

    And now I just went to check the version/build of Excel and the problem has gone away.. WTF?

    Rich

    Sunday, January 11, 2015 2:53 AM
  • I only have 8GB.  But good to know more memory won't fix it.  Seems like mine started around end of jan 2015.  Trying repair.

    Never used to happen.  Opened tons of sheets at one time.

    Thursday, February 19, 2015 3:21 PM
  • Same problem with 32-bit version.  Anyone found a solution yet?
    Tuesday, April 7, 2015 4:27 PM
  • I have a desktop computer i7 with 8GB of RAM 64-Bit that has given this problem ever since I have used Excel 2013. I also have a notebook i5 at home with 6GB Ram 64-Bit that also exhibits the same problem. I am opening a NEW instance of Excel and it won't open a small timesheet spreadsheet!

    I also have LOTS of problems with Excel hanging ever since I upgraded (about 2 years ago!). 2013 is definitely a bad year for Excel - I can't believe that Microsoft is not aware of this problem!

    "Pissed off with Excel"

    Sunday, May 3, 2015 7:39 AM
  • Same here!! Any fixes for this Microsoft?
    Wednesday, May 27, 2015 8:56 AM
  • Same here!! Any fixes for this Microsoft?

    We have the same issue, with several users/PC's. Windows 8.0 office 2013 32-bit.

    Thursday, June 18, 2015 12:17 PM
  • I have the same problem here! any fix?
    Monday, June 29, 2015 4:13 PM
  • THANK YOU VERY MUCH, your solution immediately resolved the problem that I was facing over a year ago.
    Monday, June 29, 2015 8:32 PM
  • Same issue started once I went to excel 2013. Happens regardless of which workbooks are open or even number of sheets open. Seems more related to time system is up and running. Sometimes closing excel and reopening helps for a while but reboot will be required to get it to work right for longer than an hour or so.

    Intel I5 processor, 16gb RAM (so that is not the issue), windows 7, excel 2013 32bit. It seems just to be a software issue in need of a fix.

    Come on MS, figure out a patch.

    Friday, July 24, 2015 7:59 PM
  • Excel 32-bit is limited to 2GB of memory no matter how much you have in your machine.
    Tuesday, July 28, 2015 6:53 PM
  • Hi Lei23, what was the solution ?
    Thursday, August 20, 2015 11:35 AM
  • Any chance you can say which fix you used ?
    Friday, November 6, 2015 2:50 PM
  • R u got any solution for this , 
    Tuesday, June 21, 2016 4:43 AM
  • Lei23, what was the solution?

    Wednesday, July 13, 2016 7:27 PM
  • Same issue, on a Windows Server 2012 managed in another state. Amazing that my 10 year old XP PC with a Pentium 4Ht  & Office 2003,  runs circles around Microsoft's latest and ("supposedly") greatest. This issue need to be corrected. All I hear is "crickets".
    Tuesday, August 2, 2016 9:56 PM
  • Sorry to all who inquire to Lei23 troll...Lie23 doesn't have a solution; only a knack for pissing real answer seekers off... 
    Tuesday, August 30, 2016 3:29 PM
  • Hello,

    I have the same problem in Excel 2016.

    I run an HP Envy with 4 CPU's and 16 Gb of memory and Windows 10 64 bits.

    Opening Excel with no file uses 53 Mb of data in the task manager.

    Once I open the file, which takes some time, it surges to 18.2% of CPU, then drops to 0%, when the file is open and the open Excel file uses 170Mb of memory.

    What is going on?

    DDE setting was already changed as well as manual recalc

    Friday, September 23, 2016 2:45 PM
  • I have found that usually, this is not directly related too the error message, in this case memory.

    Usually this is because the worksheet is stored as an old version of excel. 

    If you have an excel sheet stored as excel 97, and use this sheet in office 2016 you may get error like this. Most of the time you may be able to open the sheet after clicking avay all errors, if you the store the file as a copy using a new version like .xlsm you should now be able to open the worksheet without errors in excel 2016...

    I have come across this alot when customers have alot of old excel files that they use as templates. The template is still good, so it is still being used, but when it is closing in on 20 years between versions of the file and the program, it is not strange that we get problems. Just wish we could get some better error messages :)

    Best wishes Fredrik Weme 


    • Proposed as answer by Fredrik Weme Wednesday, January 11, 2017 10:41 AM
    • Edited by Fredrik Weme Wednesday, January 11, 2017 10:42 AM typo
    Wednesday, January 11, 2017 10:40 AM
  • Same issue and I'm proposing the solution that worked for me.  It was not RAM, not VRAM, not hardware or software.  The solution wasn't that involved.  Frederick Weme pointed me in the right direction.  Open the file and save it as a different version of Excel.  The key thing the client said "I've been using this for years now it's broken".   They now have Office 2016, combined that with what Frederick Weme said and saved the file to 97-2003 version (not XLSM as suggested).  There will be some conversion errors but they did not cause any problems.  All I can say is the client was happy.  



    • Edited by JJPadden Thursday, June 8, 2017 9:40 PM minor edits for better clarity.
    • Proposed as answer by FabimarHarmony Friday, October 6, 2017 12:23 AM
    Thursday, June 8, 2017 9:38 PM
  • Lo que ha funcionado en mi entorno, es "CONVERTIR" los rangos a "Tablas", es decir: Insert\Table

    marcar el rango, si tienen encabezados, marcar de que el rango contiene en su primera fila los encabezados

    y listo!

    Thursday, October 5, 2017 8:24 PM
  • What worked for me was getting the "Open" dialogue box, clicking on the dropdown next to "Open" and selecting "Open in protected mode" i.e. disabling macros.
    Wednesday, November 15, 2017 3:11 PM
  • Tried most of the solutions, none worked for us(two known systems same file). Quick fix copied and pasted to new .xls it now works fine.
    Wednesday, November 15, 2017 4:00 PM
  • For us, it was to do with trust centre settings.

    File was a large excel file on a network share that was mapped to a drive.

    Going into trust centre and ticking allow trusted locations from network, then adding the path to the folder containing the excel files and ticking all subfolders resolved this.

    Why it was coming up with this memory issue when actually it was a trust centre issue, is beyond me!

    Hope this helps,


    Adam.

    Friday, February 16, 2018 2:43 PM
  • My issue was that my file was too large - 32,000 kb...i read that is due to the document accounting for blank spaces. When i copied the content of the tab into a new tab, and then deleted the old tab (thus deleting all the blank spaces) the problem was solved and my book got down to 92 kb

    You can check to see the farthest-used cell in your document with cntrl+END. If it takes you to a blank space far from your work, this is the issue. 

    Tuesday, March 27, 2018 12:04 PM
  • This fixed it:

    1. Installed WPS Office (also known as Kingsoft).

    2. Opened the XLS file in WPS Spreadsheets.

    3. Deleted all of the columns to the right of my data, as far out as I could go.

    4. Deleted all of the rows beneath my data, as far out as I could go.

    5. Saved the document.

    Now I can open it and do my modifications in Excel. I don't know what the deal is, but this dramatically reduced my file size too. It's like Excel was saving all those extra rows and columns. But I couldn't delete them in Excel for some reason. I had to use WPS Spreadsheets.

    Monday, May 14, 2018 4:17 PM
  • Posters please. When you indicate the solution worked, please specify which of the many posted solutions worked for you!

    StarsNStripes post on 20180514 helped me, but instead of using WPS office I used Excel as other users on this thread or on other sites have posted. Our users are running 32-bit Windoze 7 Pro with 32-bit Office 2016.

    I was getting the memory error when trying to insert a new row in a sheet that already had 9700+ rows. Some of the ther sheets also had rows of similar count too. Columns on this sheet went out to EY.

    Saving as XLS from within Excel did work for me (I could add rows to the 9700+ row XLS sheet), and then save-as XLSX I could still add rows without getting the "There isn't enough memory to complete this action" error.

    Protected mode didn't apply to me as there were no macros in the workbook. All data was local in the workbook (no pulling from other sources). Unchecking 2013 (2016 for me) - File > Options > Advanced > General > Tick the option - Ignore other applications that use Dynamic Data Exchange (DDE) made things much worse.  Excel would show an all white screen but moving the mouse over where there should have been cells would pop up information like "select an option from the drop down" or "a value from 1 to 5 is required".

    Note that saving as XLS will only work if you don't have row counts and column counts over the max allowed for XLS. (Sorry, I don't have that count handy.)

    I asked someone else here and he said that it's often not a memory issue but often it's a corrupt XLSX file and saving as XLS will remove the corruption (Excel doesn't know what to do with the corruption) and saving as XLS does pop up message that could imply that, but I thought that was because XLS may not be able to handle all the XLSX formatting or newer formulas, and may be true too.

    I also notice that my save as XLS does say I have columns out past IV (max columns) and beyond 65K rows, but I only see data up to EY and row 9700 (a bit more than that but not 65K) so it might be true but it isn't important data so a file "cleaner" might help to remove rows and columns beyond the useful data rows/columns.

    • Edited by PReinie01 Friday, June 29, 2018 12:01 AM Add even more info.
    Thursday, June 28, 2018 11:26 PM
  • I experienced this problem with a very complicated workbook with lots of array formulas and macros and such.  I had recently added some camera shots on one tab to get a quick look at key data on other tabs.  After not finding the solution here, I deleted those camera shots and the problem seems to have gone away.
    Sunday, July 15, 2018 2:23 AM
  • I was able to resolve the issue for my user by saving the file as an .xls.
    Wednesday, August 8, 2018 3:14 PM
  • Thanks, This work in my situation
    Monday, October 1, 2018 11:58 AM
  • Hey,

    I have experienced this problem in Excel 2016 as well. 

    I have tried reinstalling excel and other solutions suggested above.

    I believe the problem is with a individual files. I had backed up the file previously to an external hardrive. This 3 day old copy from the external hardrive is working without problems 

    I wonder if it is a bug in the microsoft software which suddenly triggers this error. Which is frustrating and awful on Microsoft's part. 

    Wednesday, November 7, 2018 9:34 AM
  • YES THANK YOU jmiacurci!!!

    I was able to insert rows on another worksheet within the same workbook, but not the main worksheet.  somehow I got data WAY down in one of the blank cells, so all the blank lines/cells between my actual data and that were taking up memory/space.  I copied the data I wanted to keep to a new tab, fixed all my REF errors, deleted the old tab, and voila, I can insert rows again!

    Tuesday, December 4, 2018 6:32 PM
  • Thank you enormously, jmiacurci. Your speculation that blank spaces were the root cause proved to be the case. I deleted all columns to the right of the last used column in my sheet and deleted them. I repeated the same selection for all rows following my last-used row and deleted them. Would you believe I can now do "saves", "automatic calculations" and row and column insertions? 'sure can.

    To you, sir, I'm indebted.

    Tuesday, July 30, 2019 2:48 PM