locked
Issue in SharePoint 2007 in profile synchronization RRS feed

  • Question

  • Hi All,

    I am facing an issue in SharePoint 2007. When user log in to SharePoint site he cannot able to use target audienced links, which is to AD group 'A'.

    This user is member of AD group 'A' and i can see his entry in User Profile also.

    I checked in blogs and some of them advise to check for profile synchronization service under

    Central Admin --> Operations  --> Timer jobs status. I see this service which runs every hour is aborted. And quick Profile Synchronization service is running perfectly OK.

    Then i also checked in UserInfo table in content database where a column IsActive is 0 and for other users its 1.

    This issue is temporarily fixed when we included this AD group 'A' under SharePoint group and target audienced this SharePoint group to same link.

    This is a happening for new users only who are joining the AD , old users are working fine.

    But anyone please advise how can rectify this issue.


    -- Kind Regards Sandeep

    Friday, May 18, 2012 3:30 PM

Answers

  •  

    Hi Sandeep,

    Did you import AD security groups into your SSP? You can use the following user filter to import them into your SSP.(Central Administration->SharedServices1->User Profiles and properties->Manage Connections->Edit Connection->Search Setting) 

    (|(objectCategory=Person)(objectClass=User)( objectClass=Group))

    After change it, please do it with “start full import” in your SSP.

    Thanks,

    Jack

    Tuesday, May 22, 2012 4:45 AM
    Moderator

All replies

  • Hi Sandeep,

    Sounds like your profile import is not working - this is why you having issues with the new AD users. Have you checked the import logs?

    Check the following blog posts for troubleshooting ideas.

    http://blogs.technet.com/b/nishants/archive/2010/08/23/troubleshooting-user-profile-sync-issues-in-office-sharepoint-server-2007.aspx

    http://blah.winsmarts.com/2006-11-SharePoint_2007__Importing_User_Profile_information.aspx

    Hope this helps!


    BlueSky2010
    Please help and appreciate others by using these features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Saturday, May 19, 2012 11:14 PM
  • Hi,

    Carry out a full profile import followed by audience compilation.

    Then try again carrying out target audience.

    I hope this will help you out.


    Thanks, Rahul Rashu

    Sunday, May 20, 2012 2:24 AM
  • Dear All ,

    Thanks for your rpely..

    I checked in sharepoint logs i see Shared Service timed out error it says shared service cannot able to connect one of content database.

    I checked this content db which is offline. Actually we have three content database and one we took offline as no one was using this site.

    Would this be the issue? ..that all content db should be online to allow Shared Services to work properly.

    Also please advise will only one shared service will be there for multiple sites content db.


    -- Kind Regards Sandeep

    Sunday, May 20, 2012 1:06 PM
  • Hi,

    The Shared services act on all content DBs. Hence mark it online and try again.



    Thanks, Rahul Rashu

    Monday, May 21, 2012 2:08 AM
  • Hi,

    Thanks for your reply..

    We marked db online and try incremental import and did IISRESET also..but no help.

    Please advise.


    -- Kind Regards Sandeep

    Monday, May 21, 2012 10:07 AM
  •  

    Hi Sandeep,

    Did you import AD security groups into your SSP? You can use the following user filter to import them into your SSP.(Central Administration->SharedServices1->User Profiles and properties->Manage Connections->Edit Connection->Search Setting) 

    (|(objectCategory=Person)(objectClass=User)( objectClass=Group))

    After change it, please do it with “start full import” in your SSP.

    Thanks,

    Jack

    Tuesday, May 22, 2012 4:45 AM
    Moderator