locked
Access denied on survey when branching is enabled RRS feed

  • Question

  • The forum apparently ate my other thread I had started so here is a new one.

    The problem I am having is that whenever we enable branching on a survey, anywhere in a particular site collection, the first page will display, but as soon as the user clicks "Next" an Access Denied error is displayed. This occurs even when using the farm admin account. It occurs even after setting full control on the survey for all users, and setting the most permissive advanced options.

    If we remove the branching logic from the survey, everything works fine. I have tried setting up multiple surveys in multiple different ways, and still no luck.

    At this point I am out of troubleshooting ideas. Can anyone provide some direction for further things to try?

    • Moved by Mike Walsh FIN Tuesday, July 20, 2010 4:34 PM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Tuesday, July 20, 2010 4:24 PM

Answers

  • I had this issue recently and solved the problem this way.

    - Gave the permission level "Edit Items" which it did not have. (Done via Permission settings at the Site Collection Level). It already had "Add Items and View Items".

    - Confirmed that the setting "Create responses and edit responses that were created by the user" had been selected.

    These two settings seemed to fix the issue.

    Friday, July 26, 2013 1:38 AM

All replies

  • Hi Scott1000, Did your survey list inherit permission from its parents or not? If not, please inherit permission from its parents and then check the effect. Check in survey Advanced settings -> Edit Access enabled with “None”. If so, change to Edit Access enable “Only their own”, after that check the effect. Or you can create a new survey list, then check the effect. For more information about adding branching logic to a survey, please refer to the following article: http://office.microsoft.com/en-us/windows-sharepoint-services-help/add-branching-logic-to-a-survey-HA010209065.aspx
    Regards, Rock Wang Microsoft Online Community Support
    Thursday, July 22, 2010 5:05 AM
  • Hi Rock,

    Thank you for your reply. I am aware of and have reviewed the article you referenced. I also double-checked all the things you mentioned. The effect is the same whether inheriting or not. It also does not change when I create a new survey.

    Here are some steps I followed to demonstrate the effect:

    1.      Site Actions > Create.

    2.      Chose Survey from the Tracking column.

    3.      Input a survey name and the following settings:

    a.       Display this survey on the Quick Launch? NO

    b.      Show user names in survey results? NO

    c.       Allow multiple response? YES

    4.      Clicked Next.

    5.      Created three questions, clicking Next each time. The first question is a choice between options A or B. The second and third questions are single line of text responses. Other than that, accepted all defaults.

    6.      Selected the first question and scrolled to bottom to add branching. For Option A I selected “No Branching.” For Option B I selected my third question.

    7.      Clicked OK.

    8.      Double-checked that the list inherited the permissions of the parent.

    9.      Attempted to respond to the survey. As expected, question 1 loads, but any response to question 1 simply produces the Access Denied error.

    10.  Went to Survey Settings > Permissions for this survey.

    11.  Chose Actions > Edit permissions. When prompted for “You are about to create unique permissions for this list. Changes made to the parent site permissions will no longer affect this list,” clicked OK.

    12.  Attempted to respond to the survey again. As expected, question 1 loads, but any response to question 1 simply produces the Access Denied error.

    13.  Clicked on “View all responses.” Proved that full control rights are working by deleting, editing, and managing permissions on the various responses.

    14.  Went to Settings > Survey Settings > Advanced Settings.

    15.  Changed Edit Access from “Only their own” to “All responses.” Clicked OK.

    16.  Attempted to respond to the survey again. As expected, question 1 loads, but any response to question 1 simply produces the Access Denied error.

    17.  Had a coworker in a different office try steps 1-16 with the same results.

    18.  Navigated to a different site, but within the same site collection. Repeated steps 1-17 with the same results.

    19.  Navigated to a different site, in a different site collection. Repeated steps 1-17 with different results. Now I am able to take the survey fully through and the branching works with no access denied errors, in all cases. So is my coworker.

    I believe that the access denied error is resulting from some underlying cause in the site collection’s content database or in the 12 hive or IIS metabase, rather than permissions directly on the page or list.

    FYI we are on WSS 3.0. I believe I forgot to mention that when I recreated the thread.

    Thursday, July 22, 2010 6:03 PM
  • PS I wanted to reiterate my thanks for your guys' help in brainstorming on this! It is most appreciated!
    Friday, July 23, 2010 4:59 PM
  • Any other ideas out there? Should we just try to recreate the site collection?
    Friday, July 30, 2010 5:06 PM
  • OK lol I guess I stumped everyone. I will let you know when I figure it out.
    • Proposed as answer by Spellman Tuesday, November 23, 2010 7:39 PM
    • Unproposed as answer by Mike Walsh FIN Tuesday, November 23, 2010 8:06 PM
    Wednesday, August 4, 2010 9:55 PM
  • You can fix this by breaking permissions on the survey and then give the users in question full control when granting them access. When branching is used I have had to grant full control to get past the permissions error while responding.  Hope this helps.

     

    Tuesday, November 23, 2010 7:40 PM
  • But if there is no other solution than giving the users full control to allow branching in a survey, then this seems to be a bug!?

    I can confirm and reproduce the behaviour in Sharepoint 2010.

    Monday, November 29, 2010 10:49 PM
  • Hello,

    you must allow to edit responses that were created by the user in the Advanced Settings of the survey.

    The reason is that if there is a branching logic, the user's response is actually saved each time he choose one of the branches (by clicking Next button).

    I hope it helps & have a nice day to everybody!

    Monday, March 5, 2012 9:53 AM
  • I had this issue recently and solved the problem this way.

    - Gave the permission level "Edit Items" which it did not have. (Done via Permission settings at the Site Collection Level). It already had "Add Items and View Items".

    - Confirmed that the setting "Create responses and edit responses that were created by the user" had been selected.

    These two settings seemed to fix the issue.

    Friday, July 26, 2013 1:38 AM
  • I just had the same issue in my O365 SharePoint Online environment. Thank you all for the help!

    Sheila

    Wednesday, May 31, 2017 1:08 PM