none
Set-DPMGlobalProperty -KnownVMMServers - DPM Powershell command fails RRS feed

  • Question

  • Hello,

    I must be over looking a step and hope that someone can point out something obvious I am missing.

    We are running SCDPM 2012 SP1 on a Win server 2012 and SCVMM 2012 SP1 on another Win 2012 server.

    I want to setup DPM to automatically protect our VM's when they're migrated around on our Server 2012 Hyper-V hosts.

    The SCDPM2012 Server has the Hyper-V role added and has the SCVMM console installed. The SCVMM console on the SCDPM server and SCVMM server are the same version 2012 SP1 Version 3.1.6018.0.

    The SCDPM agent is installed on the SCVMM server. On the SCVMM server I have granted administrator rights to the SCDPM server account.

    On the SCDPM server I open an Admin elevated powershell and import the dpm modules. When I then try to run Set-DPMGlobalProperty –DPMServerName MyDpmServerName -KnownVMMServers MySCVMMServerName I get the following Error.


    WARNING: Connecting to DPM server: MyDPMServer
    Set-DPMGlobalProperty : DPM was unable to configure and start the VmmHelperService on the DPM Server.
    Server name: MyDPMServer.
    Exception Message: Time out has expired and the operation has not been completed. (ID: 33399)
    1) Verify that VMM Console features are installed on the DPM Server.
    2) To reconfigure the VMM server in DPM, use the Set-DPMGlobalProperty cmdlet as follows:
    Set-DPMGlobalProperty -DpmServerName <DPMServerName> -KnownVMMServers <VMMServerName>.
    At line:2 char:1
    + Set-DPMGlobalProperty –DPMServerName schooldpm02.dundeecity.sch.uk -KnownVMMServ ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Set-DPMGlobalProperty], DlsException
        + FullyQualifiedErrorId : FailedToConfigureVmmHelperService,Microsoft.Internal.EnterpriseStorage.Dls.UI.
       Cmdlet.SetGlobalProperty

     

    Any help would be greatly appreciated.

    Cheers

    Alex

    Friday, March 15, 2013 11:58 AM

All replies

  • Alex,

    Based on the way you described above, I have two questions.

    * Can you try the same with the FQDN name for VMM server name?

    * Both DPM and VMM servers are on both same/mutually trusted domains

    * Last but not least... from DPM you are able to "ping" VMM server.

    Can you confirm them?

    Monday, March 18, 2013 8:18 AM
  • Also, can you confirm that you have added firewall port exception for 6070 as discussed in the link below...

    technet dot microsoft dot com slash en-us slash library slash jj656643.aspx

    Unable to post the links due to technical issues.

    Both DPM and VMM should be on the same DPM server.

    Monday, March 18, 2013 11:11 AM
  • Hi Neela,

    Thankyou for your reply.

    1. I have tried the FQDN of the servers in the powershell.

    2. Both servers are in the same Domain.

    3. Both servers can ping each other.

    4. Both servers have port 6070 open in the firewall in both inbound and outbound rules for all Profiles.

    5. The SCDPM server has the VMM console installed, this runs up and connects to the SCVMM server successfully.

    Cheers

    Alex

    Tuesday, March 19, 2013 9:53 AM
  • The problem could be related to registry permissions.  The DPM VMM Helper service should be running under the NetworkService account and it may not have read/write permissions on the key:  "Software\Microsoft\Microsoft Data Protection Manager\2.0\Configuration"

    Please verify the System/Network Service account has read/write permissions on this registry key and try rerunning the command.

    Thanks,

    Michael Vargo


    -------------------- Regards, Michael V [MSFT] - This posting is provided "AS IS" with no warranties, and confers no rights.

    • Proposed as answer by Markus_R. _ Friday, May 3, 2013 10:24 AM
    Monday, April 1, 2013 8:25 PM
    Moderator
  • Had the same problem; giving the network service RW-permissions as proposed above solved the problem.

    Seems that someone must have forgotten to set this during the installation of dpm...

    Thanks and best regards,

    Markus

    • Proposed as answer by Paavo Evans Wednesday, September 24, 2014 1:45 PM
    Friday, May 3, 2013 10:24 AM
  • I have the same error message, but giving permission for de configuration registry key doesn't help.

    Anybody has other idea what can be the problem?

    Tuesday, April 22, 2014 2:51 PM