locked
Disable instant messages in skype for business. RRS feed

  • Question

  • Dear All,

    We are using Skype for Business 2015 on premises . 

    Now we want to stop instant messages in Skype for business client. I tried to search but not found any thing.I want to stop Chats between SFB client. so kindly guide to me for Disable Instant Massages between Skype users.


    Rahi Padariya

    Monday, December 26, 2016 5:21 AM

All replies

  • Hi  

    you can use registry key DisableIM to stop IM on client side (you need to push it by Group policy )

    reg add HKLM\Software\Policies\Microsoft\Office\16.0\Lync /v DisableIM /t REG_DWORD /d 1 /f

    for reference for lync 2013 

    http://howdouc.blogspot.co.uk/2012/12/disabling-im-for-lync-2013-client.html

    • Proposed as answer by Alice-Wang Tuesday, December 27, 2016 3:08 AM
    Monday, December 26, 2016 5:54 PM
  • Hi rahi,

    Welcome to post in our forum.

    Agree with GUI.

    Based on my research, there is no option or command to disable IM feature in SFB server side.

    You could try to run “reg add HKLM\Software\Policies\Microsoft\Office\16.0\Lync /v DisableIM /t REG_DWORD /d 1 /f” command in CMD, then you could disable the IM feature.

    But this registry is only suitable for the computer which you run this command, if you use another client which hasn’t run this command, you can still use SFB IM feature.


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, December 27, 2016 3:13 AM
  • Hi Alice Wang,

    Thanks for reply

    I applied registry in one computer, But after apply registry present desktop option not appear directly.

    we have to call first to user then present desktop option appear.

    So how can I share desktop directly without calling to user ?  


    Rahi Padariya

    Tuesday, December 27, 2016 5:57 AM
  • Hi rahi,

    Thanks for your response.

    You could click here then you can share desktop:

    If you can’t share desktop by this option, please try to restart SFB client and test again.


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, December 29, 2016 8:37 AM
  • Thanks for your reply.

    In My case if I want to share my screen to any user. your screenshot window not appear. but Call option come first. so guide me how can I share my desktop.

    SFB     


    Rahi Padariya

    Monday, January 2, 2017 4:57 AM
  • Hi rahi,

    After you run “reg add HKLM\Software\Policies\Microsoft\Office\16.0\Lync /v DisableIM /t REG_DWORD /d 1 /f” command in CMD, if you want to share desktop with others, double click him and then you could see the option “present desktop.”


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Liinus Monday, January 2, 2017 1:53 PM
    Monday, January 2, 2017 6:33 AM
  • Thanks for your replay.

    As per your comment,  it is not showing me the icon of 'Present Desktop'.

    When I double click on the username as per your snap, the call has been started.

     


    Rahi Padariya

    Tuesday, January 3, 2017 6:20 AM
  • Hi rahi,

    I did a test on my computer, it works fine. What’s your SFB client version and what’s your windows system (windows 7/8 or windows 10)?
    Please make sure your windows system has the latest update, exit your SFB client, then delete this registry key, then re-add it then test again.


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 6, 2017 9:29 AM
  • VersionThanks for your replay

    we are using Windows 7


    Rahi Padariya

    Friday, January 6, 2017 1:32 PM
  • Hi rahi,

    Thanks for your response.

    I did a test on windows 7 system and SFB client (16.0.6925.1048), it works fine.

    Did you try to delete this registry key and re-add it? If not, please try it.


    Regards,

    Alice Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 11, 2017 7:44 AM