none
Issue after SYSPREP - Windows could not finish configuring the system RRS feed

  • Question

  • I am having an issue with my POSREADY 7 image.  I initially set this image up back in November 2014, sealed it and deployed it to 600 machines in the month of December.

    I am now looking to update the image so that it stays fresh.  I made the changes that I needed to make, re-sealed the image, and now when I deploy it in my lab, I get stuck with the "Windows could not finish configuring the system".  After searching through some forums I found a post that said to hit Shift+F10 to get to a command prompt, cd to Windows\Panther, copy off setup.etl and then export it to XML. Search for "failed to process reg" and I see:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    	<System>
    		<Provider Name="Microsoft-Windows-SetupCl" Guid="{75ebc33e-d017-4d0f-93ab-0b4f86579164}" />
    		<EventID>2</EventID>
    		<Version>0</Version>
    		<Level>2</Level>
    		<Task>0</Task>
    		<Opcode>0</Opcode>
    		<Keywords>0x8000000000000002</Keywords>
    		<TimeCreated SystemTime="2015-04-24T13:01:26.636507400Z" />
    		<Correlation ActivityID="{00000000-0000-0000-0000-000000000000}" />
    		<Execution ProcessID="440" ThreadID="444" ProcessorID="1" KernelTime="60" UserTime="0" />
    		<Channel>Microsoft-Windows-SetupCl/Analytic</Channel>
    		<Computer />
    	</System>
    	<EventData>
    		<Data Name="SourceLine">     330</Data>
    		<Data Name="SourceFunction">SclRegProcessKeyRecursiveByHandle</Data>
    		<Data Name="Message">(c0000022): Failed to process reg key or one of its descendants: [\REGISTRY\MACHINE\SOFTWARE]</Data>
    	</EventData>
    	<RenderingInfo Culture="en-US">
    		<Level>Error </Level>
    		<Opcode>Info </Opcode>
    		<Keywords>
    			<Keyword>keyDiagnostic</Keyword>
    		</Keywords>
    		<Message>SclRegProcessKeyRecursiveByHandle@330 : (c0000022): Failed to process reg key or one of its descendants: [\REGISTRY\MACHINE\SOFTWARE] </Message>
    		<Channel>Microsoft-Windows-SetupCl/Analytic</Channel>
    		<Provider>Microsoft-Windows-SetupCl </Provider>
    	</RenderingInfo>
    </Event>

    The original post I read had to do with a specific registry key, I believe SOFTWARE\ESET.  This one, however, is a little broader being SOFTWARE.

    I also found somewhere that there was a hotfix to take care of this issue - KB981542 - but when I downloaded it and tried to install it, it told me it didn't apply to my system.

    So I am a bit stuck, looking for some assistance.

    Thanks in advance,

    sb

    Monday, April 27, 2015 1:50 PM

All replies

  • Just for clarification: did you recreate the POSReady image from scratch? Or did you run sysprep on the image that already went through sysprep?


    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Monday, April 27, 2015 3:15 PM
    Moderator
  • Thanks for the reply. In my process I build the image to what I need. Then I rip an image using clonezilla. This image is not sysprepped at this point. I then take this drive and sysprep it, and re-rip a second image. This way when I need to make changes they are added to the original image. How would I tell if my process failed and I am trying to do this on a drive that has already been sysprepped?
    Monday, April 27, 2015 3:30 PM
  • There is a known issue about sysprep-ing an image too many times. MS recommends 3 syspreps max. If you created a custom unattended file, I suggest that you review the file to be sure nothing is causing the error.

    When I do POSReady 7 images, I use System Image Manager (SIM) from the ADK to create a custom OS installer that automates as much of the OS and custom setup as possible: http://www.microsoft.com/en-ie/download/details.aspx?id=39982 / I have a book that covers SIM: https://annabooks.com/Book_SGSIM.html . I also use SIM to create the Sysprep unattended file. This way if I have to go back to do any changes, I can go back to a tool and make the change, re-install the image, and run sysprep.


    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Monday, April 27, 2015 7:59 PM
    Moderator
  • Yes - I use this tool as well - mostly just for the unattended file creation.

    On my system in my lab, I just ran a slmgr /dlv and it tells me that I have a remaining windows rearm count of 4.  So it doesn't look like I have hit that magic 3 syspreps, unless I am misunderstanding what that means.

    The only changes that I made in the unattended file was - I updated the local admin password.  I also did this on the machine itself.  Could that cause this issue??  Doesn't seem to make sense.

    Thanks again for the input, I think I am going to get a copy of your book.  It looks like it would be useful for our environment.


     
    Tuesday, April 28, 2015 1:06 PM
  • If there was miss-spelling any place in the unattended file, then this could cause a problem.

    I would keep the passwords the same since the account was setup in the master image.


    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Wednesday, April 29, 2015 4:06 PM
    Moderator
  • Thanks for the tips.  I tried reverting the password, and had the same problem.  

    I ended starting over from my previous base image - even though it had already been sealed with sysprep.  I deployed it in my lab, and ran a slmgr.vbs /dlv and still had a re-arm count of 4.  Just to test, I made a few minor changes, resealed it with my new xml file and deployed it in my lab.  it came up fine.  

    Something must really be junked up in the registry on my other image.  I am actually hoping, as I step back through this process, I find the software that caused the issue.

    -sb

    Thursday, April 30, 2015 12:24 AM
  • I'm getting the exact same error. Did you ever get to the bottom of it?
    Wednesday, March 29, 2017 7:58 AM
  • Based on the last post, it looks like he started with a fresh image and it worked.

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Wednesday, March 29, 2017 3:30 PM
    Moderator
  • Yes - I ended up starting from my previous base image - luckily I had some decent notes on the changes that were made.  I wish there was a better solution.

    HTH

    Steve

    Wednesday, March 29, 2017 4:14 PM
  • Thanks guys. I never had this problem until Windows 10 build 1607 (Anniversary).

    I ended up removing McAfee from the base image and adding it as an automated install step after the image went on. Such a pain.

    Wednesday, March 29, 2017 4:22 PM