none
Problems Generating a Offline Media RRS feed

  • Question

  • Hello!

    I have problems with generating a offline media. 

    I get this error 

    System.Management.Automation.CmdletInvocationException: Unable to open the specified WIM file. ---> System.Exception: Unable to open the specified WIM file. ---> System.ComponentModel.Win32Exception: The process cannot access the file because it is being used by another process

    Using dism manually for checking the mountpoint and get this directory as an mount point. C:\Users\username\AppData\Local\Temp\MDTUpdate.2252\Mount

    I find several files in this directory. 

    C:.
    ├───users
    │   └───default
    └───windows
        └───system32
            ├───config
            └───smi
                └───store
                    └───machine

    I am using 

    ADK version 10.1.14393.0
    MDT version 6.3.8443.1000

    I have disabled the antivirus on the server with no luck. I have extended the scratch space with the same result. 

    Any Ideas?

    Tuesday, February 28, 2017 8:42 AM

Answers

  • I can now generate offline media. 

    The fault was changeing the selection profile from Everything to Drivers and it started to work. 

    Thursday, March 2, 2017 6:26 PM

All replies

  • MDT uses the WIM image from the ADK install path, is the original WIM still in the folder ?

    Delete you wim file, uninstall/reinstall ADK reboot :) and try again

    Tuesday, February 28, 2017 12:56 PM
  • Reinstalled the ADK with no luck. Stops after reclaiming unused space and it crashes since "The process cannot access the file because it is being used by another process"

    Wednesday, March 1, 2017 1:22 PM
  • Try using the Dism /get-mountedwiminfo (or /get-mountedimageinfo depending on the dism version) to see if any WIMs are mounted.  If any are, try unmounting the image without saving it (/unmomunt-image or /unmounts-wim with the /discard switch). 

    Disk switches:  https://msdn.microsoft.com/en-us/library/jj980032(v=winembedded.81).aspx

    Wednesday, March 1, 2017 9:24 PM
  • Deployment Image Servicing and Management tool
    Version: 6.3.9600.17031

    Mounted images:

    Mount Dir : C:\Users\USERNAME\AppData\Local\Temp\MDTUpdate.3740\Mount
    Image File : C:\Users\USERNAME\AppData\Local\Temp\MDTUpdate.3740\LiteTouchPE_x64.wim
    Image Index : 1
    Mounted Read/Write : Yes
    Status : Invalid

    The operation completed successfully.

    I cannot unmount the images since SYSTEM is locking NTUSER.DAT and supported files in the filesystem.  Only a reboot solves this. 

    I have disabled the antivirus on the computer, with no luck, tried to move %TEMP% to another volume with no luck. 

    I have no idea why. 


    Thursday, March 2, 2017 8:52 AM
  • I can now generate offline media. 

    The fault was changeing the selection profile from Everything to Drivers and it started to work. 

    Thursday, March 2, 2017 6:26 PM