locked
Clock takes up three lines, would prefer two or one line RRS feed

  • Question

  • I'm trying to get the taskbar clock to show the following, ideally on one line:

    Wed 2/24/10 10:00PM

    In the Region and Language settings, I've selected Additional Settings and gone to the Date tab.  My Short Date is set to ddd M/D/y

    However, the clock in the taskbar shows:

    10:00 PM
    Wednesday
    Wed 2/24/10

    Two questions:

    How do I get rid of the "Wednesday" line?  I can't figure out how it got there in the first place.

    Can I get the clock to read on one line:  Wed 2/24/10 10:00PM  ?  I'm familiar with the T-Clock app, but didn't like it.

    Thanks.
    Thursday, February 25, 2010 4:06 AM

Answers

  • Hi,

     

    According to your screenshot, it seems that you are using "Use small icons". Perhaps it is why the clock is displayed in three lines or on line.

    Please right-click the taskbar, click Properties,  then click Taskbar tab, uncheck “Use small icons” checkbox, click OK and then close the window.


    Hope it will help you.

    • Marked as answer by Nicholas Li Friday, March 5, 2010 8:01 AM
    Monday, March 1, 2010 8:41 AM
  • Where do you set the options for the on-screen clock display, Piscoe?  In the Region and Language options?

    -Noel

    Here are the steps one by one Noel

    Control Panel
    Clock, Language & Region
    Region & Language
    Additional Settings
    Date
    Short Format - my setting is dddd dd MMM

    Please let me know if you need more info.


    Regards Picsoe
    • Marked as answer by MidwestSteve Friday, March 5, 2010 12:49 PM
    Friday, February 26, 2010 6:58 PM
  • Noel, it depends on personal using habit. In fact, I use large icons. If using small icons, it will be fine to enable "Never combine" to distinguish the very icon of the running application. 

    • Marked as answer by Nicholas Li Friday, March 5, 2010 8:02 AM
    Wednesday, March 3, 2010 1:45 AM

All replies

  • Hi there,

    Since you mentioned of “ddd M/dd/yy”, there is no use to repeat how to set in “Region and Language”.

    The three-lined display can be caused by your setting of taskbar or some software you have installed to optimize you system, or just expand upwards the taskbar.
    You can right-click the taskbar and uncheck “Lock the taskbar”, then resize the taskbar.

    Meanwhile, T-Clock does add registry keys and other values during first running. I found:
    HKU\S-1-5-21-1155160046-3374615403-4015448303-1000\Software\Kazubon\TClock\Format: "ddd, mm/dd/yy hh:nn:ss"
    T-Clock generates the key to customize its own display style, for there is no ready-made entries of Registry keys of the display format.

    You have to make the best of the two-lined display without third-party software.

    Good luck!

    Thursday, February 25, 2010 10:42 AM
  • You can get it down to one line, but it only shows the time in that case.  It will show you the day and date if you hover over it.



    My settings:



    Note that I've dragged the edge of the Taskbar to be as thin as possible.  That may be how you can get rid of the day of the week.  The Taskbar must be unlocked to do this.

    Also note that the Taskbar (and icon/button size within) can change if you've been through a period where Aero has been disabled and the system has returned to Windows 7 Basic (i.e., because you ran a program that disabled Desktop Composition).  This is clearly a minor Aero bug.  The only workaround to get back the sizing you had before is to log off and back on again.

    -Noel

    • Proposed as answer by Noel Carboni Thursday, February 25, 2010 6:27 PM
    Thursday, February 25, 2010 6:26 PM
  • I'm trying to get the taskbar clock to show the following, ideally on one line:

    Wed 2/24/10 10:00PM

    In the Region and Language settings, I've selected Additional Settings and gone to the Date tab.  My Short Date is set to ddd M/D/y

    However, the clock in the taskbar shows:

    10:00 PM
    Wednesday
    Wed 2/24/10

    Two questions:

    How do I get rid of the "Wednesday" line?  I can't figure out how it got there in the first place.

    Can I get the clock to read on one line:  Wed 2/24/10 10:00PM  ?  I'm familiar with the T-Clock app, but didn't like it.

    Thanks.

    Hi,
    I think that your taskbar is 3 lines high right now.

    Do the following to reduce it to 2 lines :
    - Right click in the taskbar and unlock it.
    - Grab the top border with your left mouse button and move it downward until it measures 2 lines instead of 3.
    - Done

    I hope this helps.


    Regards Picsoe
    • Proposed as answer by Picsoe Thursday, February 25, 2010 10:37 PM
    Thursday, February 25, 2010 10:06 PM
  • I appreciate the advice, but I'm still struggling with this.  I don't have any software to optimize my system or do anything special with the taskbar.  When I unlock the taskbar and resize it, the clock goes from a one line display
    >

     to a three line display.



    If I try to make the taskbar smaller, it goes back to a one line display.

    Any other thoughts?  I completely understand the suggestions to make the taskbar smaller to make it a two line display, but I can't do that for some reason.
    Friday, February 26, 2010 4:55 AM
  • Didn't you say you wanted a one line display (in the subject of this thread)?

    -Noel

    Friday, February 26, 2010 5:30 AM
  • That would be the ideal, and I wasn't very clear in this thread.  What I'd love to see is a one line display with:

    Wed 2/24/10 10:00PM

    but I'll settle for a two line display with:

    10:00 PM
    Wed 2/24/10
    Friday, February 26, 2010 5:35 AM
  • You're probably not going to get that.

    For what it's worth, when I size my Taskbar to 2 lines it shows:

      9:31 AM
     2/26/2010

    No day of the week at all.

    Your issue might have something to do with the sizes you've chosen in the desktop personalization - Display section.  I have "Smaller - 100% (default)" set for the display scaling.

    -Noel

    Friday, February 26, 2010 2:33 PM
  • I'm also at Smaller - 100% for my display, and 1280x1024 (recommended) for the resolution.  I'd be happy with just a two line display, omitting the spelled out day of the week on the second line of the clock.
    Friday, February 26, 2010 2:53 PM
  • Well, the only other thing I can suggest is maybe altering the fonts for various things to see if changing them causes a different Taskbar sizing to occur...  Choose Personalize for the Desktop, then Window Color, then Advanced appearance settings...

    -Noel
    Friday, February 26, 2010 3:30 PM
  • I'm also at Smaller - 100% for my display, and 1280x1024 (recommended) for the resolution.  I'd be happy with just a two line display, omitting the spelled out day of the week on the second line of the clock.

    Hi Steve

    My clock area shows the following 2 lines :

    06:23 PM
    friday 26 feb

    I ommitted the year because I have no problem remembering that we are in the year 2010 :-))

    Regards Picsoe
    Friday, February 26, 2010 5:25 PM
  • Where do you set the options for the on-screen clock display, Piscoe?  In the Region and Language options?

    -Noel
    Friday, February 26, 2010 6:07 PM
  • Where do you set the options for the on-screen clock display, Piscoe?  In the Region and Language options?

    -Noel

    Here are the steps one by one Noel

    Control Panel
    Clock, Language & Region
    Region & Language
    Additional Settings
    Date
    Short Format - my setting is dddd dd MMM

    Please let me know if you need more info.


    Regards Picsoe
    • Marked as answer by MidwestSteve Friday, March 5, 2010 12:49 PM
    Friday, February 26, 2010 6:58 PM
  • Hi,

     

    According to your screenshot, it seems that you are using "Use small icons". Perhaps it is why the clock is displayed in three lines or on line.

    Please right-click the taskbar, click Properties,  then click Taskbar tab, uncheck “Use small icons” checkbox, click OK and then close the window.


    Hope it will help you.

    • Marked as answer by Nicholas Li Friday, March 5, 2010 8:01 AM
    Monday, March 1, 2010 8:41 AM
  • Martin, IMO that would make the cure worse than the disease!

    -Noel
    Monday, March 1, 2010 3:56 PM
  • Noel, it depends on personal using habit. In fact, I use large icons. If using small icons, it will be fine to enable "Never combine" to distinguish the very icon of the running application. 

    • Marked as answer by Nicholas Li Friday, March 5, 2010 8:02 AM
    Wednesday, March 3, 2010 1:45 AM
  • Thank you - that is indeed the solution!  Now I just with I could use small icons and have the two line clock :)
    Friday, March 5, 2010 12:49 PM
  • Solved!

    Hello, I found this problem extremely annoying and there was no answer on all the message boards so when I solved it I wanted to let people know how to fix it.

    Just go to your screen resolution, lower it, hit apply. You'll notice your taskbar fixes itself, then go change your resolution back up again.

    If for some reason that doesn't work you can download a date & time software for your taskbar. These are sure fire solutions beyond Control Panel-Regional Date & Time settings.

    Tuesday, September 17, 2013 11:47 PM
  • Solved it!

    Hello, I found this problem extremely annoying and there was no answer on all the message boards so when I solved it I wanted to let people checking the boards know how to solve it.

    Just go to your screen resolution, lower it, hit apply. You'll notice your taskbar fixes itself, then go change your resolution back up again.

    If for some reason that doesn't work you can download a date & time software for your taskbar. This is a sure solution beyond Control Panel-Regional Date & Time settings.

    Regards,

    Skye

    Tuesday, September 17, 2013 11:56 PM