none
BGInfo - way to set background type to 'solid color' instead of 'picture' on Windows 10 RRS feed

  • Question

  • Im trying to resolve an issue with an application that needs the background set to specific RGB color (255 0 255) and type to Solid Color instead of picture.

    I can get GPO to set the correct RGB desktop color and type, but that requires the user to log in (if new user to the PC) and then log out, then back in for the settings to update and work.

    Ive toyed with getting BGinfo to work, but it sets the background back to Picture.

    Any way to set the background type in BGInfo?

    Sunday, December 8, 2019 3:20 PM

Answers

  • Because it is always a picture.. BGINFO can write only to a picture..

    So, it creates an empty bitmap of the background color you choose, write on it, save the picture and set the background to that picture..

    There is no other way to write something on the desktop..

    HTH
    -mario

    • Marked as answer by dbwillis Tuesday, December 10, 2019 2:14 AM
    Monday, December 9, 2019 10:41 AM

All replies

  • Does it work for you if you choose Background-Use this settings-Wallpaper posistion = none and define your custom color..

    Look like it works for me..

    HTH
    -mario

    • Proposed as answer by scott_m Friday, October 2, 2020 2:21 PM
    Sunday, December 8, 2019 4:04 PM
  • Doesn't seem to work for me, this is my GPO screen (don't mind the color, I couldn't stand testing with the pink!)

    Monday, December 9, 2019 10:20 AM
  • then if I run BGinfo and use the settings you mentioned, the Windows background type changes back to picture

    Monday, December 9, 2019 10:25 AM
  • Because it is always a picture.. BGINFO can write only to a picture..

    So, it creates an empty bitmap of the background color you choose, write on it, save the picture and set the background to that picture..

    There is no other way to write something on the desktop..

    HTH
    -mario

    • Marked as answer by dbwillis Tuesday, December 10, 2019 2:14 AM
    Monday, December 9, 2019 10:41 AM