none
Upgraded to windows 10, now I cannot open encrypted files RRS feed

  • Question

  • Hi there. Thanks for reading. First, I tried to work with a Microsoft MVP on the forums. Link here: http://bit.ly/2iWHOHJ

    It is not anything under the security tab (NTFS) as I have done everything with permissions and everything says "full control" for my user name and admin. I've tried it both ways.

    I think it is under the general properties -> advanced tab -> encrypt contents to secure data. When I click "Details" it shows the old user/computer name - windows 8.
    I can click add, then it says "to share file access with other users, select their certificates from the list and click OK."
    I do this, for my new user name/system and two names show up in "Users who can access the file"
    When I click OK, an error pops up and says "To add users to this file, you must have access to the file and Write or Modify permission for it."
    But I do.
    If I try and uncheck "Encrypt contents to secure data" I get "An error occured applying attributes to the file. The specified file could not be encrypted. (Ignore, try again, cancel)

    Any thoughts? Could I rename my computer to the old name?

    Thanks again for your help.

    Tuesday, November 28, 2017 3:57 AM

All replies

  • Hi,

    Please open Event Viewer, right click Event Viewer (local)\View\Show analytic and debug logs. Then check if any related error messages occur in Applications and service logs\Microsoft\Windows\EFS\Debug. If you have difficult with debug, please export it and upload to One Drive, then paste link here. Please delete any thing about your personal information in the file.

    Please type "manage computer certificates" in Windows search box and check if the certificate existing in Personal\certificates.

    I noticed you said user name and Windows 8 existing in Advanced option in properties of the file, please upload a capture for clear understanding. 

    If you have backup certificate when you encrypted the file, we could import the certificate to decrypt when the existing certificate is missing or corrupt.

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 29, 2017 6:58 AM
    Moderator
  • Thanks. Sorry for the late reply, I was away for work.

    I created a custom view for apps\MS\Win\EFS\Debug but nothing came up, errors, criticals, etc. 

    "There are no items to show" in the personal folder

    Here is a link to the screenshots https://1drv.ms/i/s!At3qIsvVRYJCzBjeMeDQq7sxgEtF

    I did not make a backup of the certificate, can I create it again?


    Building since 96, now I feel old.

    Friday, December 8, 2017 3:14 AM