locked
Keyboard focus issue - When launching applications, the keyboard focus is not where it is expected (often I can't tell where it is...) RRS feed

  • Question

  • Apologies for the somewhat obscure title to this post. Hopefully I can clarify it here.

    I'm having a problem with Win7. I've used various Beta's and the RC, and the problem has been consistent in them all.

    I realize this is probably taboo on the Microsoft forum, but the problem is most easily described by using Firefox and Thunderbird as my examples. I use both (as well as IE and Outlook) on my machine. While I don't use IE frequently, I have had this problem happen in Outlook email windows.

    When I open a new instance of Firefox, the keyboard focus may, or may not, be in the address bar. I can't give a specific set of conditions that will guarantee one behavior or the other. However, almost always once I open Firefox and use CTRL-T to create a new tab, the keyboard focus is in some unknown place and I have to manually mouse click or tab to get the focus into the address bar. This is definitely NOT normal behavior for Firefox, as I've been using it for years (muscle memory is causing me lots of grief with this one!).

    Another similar problem happens with Thunderbird. If I click to Reply to a message, I expect the keyboard focus to be in the body area of the message. Generally, the flashing cursor is there, however, if I start typing, nothing appears. I have to click into the message body (even though the cursor was there) before I can start typing.

    Another problem that is similar with Firefox. When I first start Firefox and load a page, I expect to be able to Pageup or PageDown within that page, or use any other keyboard cursor controls to navigate the page. No matter what I do though, until I click to activate another application, or at least click to deactivate Firefox, I cannot get keyboard mouse events to work in the browser. Clicking on the desktop to deactivate Firefox and then clicking in the body of the message does enable the keyboard navigation.

    I have done several Win7 clean installed on this machine, and even replaced the motherboard in the machine for different reasons, yet this problem has been present every single time that I've set the machine up. I've been through various display driver revisions (I'm using an NVIDIA Quadro card, but I've tried 2 different version of that card as well with no difference). The only possible hardware related idea that I've had was that it might be related to my Logitech mouse and Keyboard, but that is pretty far fetched to me. I've tried letting Win7 install drivers for it, and I've manually installed the Logitech drivers / utility with no difference.

    Another application that I can use a simple example is Quicken. For each, when I've launched Quicken, the keyboard cursor would end up in the Enter Password dialog box such that I could immediately start typing with no other clicks required. Now, however, after launching Quicken, I always find the focus is somewhere other than the password dialog box, and I have to either ALT-TAB away and back, or manually click in the dialog, to enable me to type.

    I've searched and searched the web trying to find other complaints that are similar to this, but so far I haven't had any luck. If anyone has either experienced this or has any suggestions as to possible workaround to get back to my accustomed behavior, PLEASE let me know! Having been a PC user for so long, I've come to expect certain behavior from these applications, and that behavior is definitely different than what I'm seeing since my Win7 install... (and note that I actually really like Win7, I just need to resolve this problem!)

    Thanx in advance for any help!


    Thursday, September 17, 2009 2:12 PM

All replies

  • As a followup, I just experienced this when clocking reply on a message in Outlook 2007 as well. So it's not purely limited to Mozilla and Intuit products. :) The cursor was nowhere in which I could type (either TO: or body areas), so I had to click in the body of the message to start editing.

    Really frustrating! :(
    Friday, September 18, 2009 4:13 PM