locked
How to change my PAged memory Tool RRS feed

  • Question

  • Hi,

     

    I am having problems with playing games (starcraft 2 to be exact) when i play it it keeps giving me errors saying my paged pool memory is empty.

    I tried calling but you guys keep telling me talk to your computers manufacturer, well i can;t couse they don;t exist anymore. so apart from this forum i am not getting any help...

    My configuration

    Xxodd XNi900f Laptop

    Intel i7 940

    12gig ram

    64-bits windows 7 ultimate

    3x300gig 7200rpm harddrive windows and game both installed on a different drive

    Gforce GTX 280m 1024mb videocard

    Starcraft 2 suggests i play it on high/ultra settings but i can;t becouse the paged pool memory is to low..

     

    I tried downloading the windows debugging tool and process explorer to see if i can load the symbols needed to change te paged pool memory but this was sadly a dead end i kept getting the message this: The dll you specified is not a valid version of the debugging tools help file.

    and i tried to download diferent debugging toold from microsoft without any change..

    can someone please help me out here?

     

     

     

     


    • Edited by Guidozilver Wednesday, November 23, 2011 10:19 AM
    Wednesday, November 23, 2011 10:19 AM

All replies

  • There are two possible causes. One is the driver of the video adapter, the other is your hardware.

    In order to confirm, you may install a new Windows 7 system on another partition (do not cover the current system) and boot into the new system. If the issue still occurs, we can be assure that the issue is not caused by other reasons.

    In this case, if the latest driver cannot help you, you will not be able to resolve the issue unless troubleshooting hardware issues.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, November 25, 2011 6:07 AM
  • i did already install a fresh copy of windows 7 and also on another harddrive. no program or game has any problems just starcraft 2

    i called blizard and they can;t help me.. they say my videocard might be broken. but i don't understand why, other games and programs have no problem just starcraft....

    Is there any way to increase the paged memory pool?

    and for video drivers i use the newest from the nvidia website...

    Saturday, November 26, 2011 12:08 AM
  • Try to increase "PagedPoolSize" value in registry in

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management


    Do it at you own risk and create a restore point before changing.


    Sunday, November 27, 2011 6:55 PM
    Answerer
  • This is a common problem with Start Craft 2

    The fix for this is as Igor has said, modify the PagedPoolSize

    I recommend starting with the next highest size, eg if you paged pool is currently 140MB, increase to 192MB.

     

    If you really want to get all the dirty deatils there is a great article here:

    http://www.teamliquid.net/forum/viewmessage.php?topic_id=113433


    MCITP: Enterprise Administrator Windows Server 2008 MCTS: Windows 7, Active Directory, Network Infrastructure, Applications Infrastructure, Exchange 2007 ITIL V3 Certified
    Monday, November 28, 2011 12:06 AM
  • @david i try'd to follow that from teamliquid but it doesn;t work couse i don;t use xp i think. i tried several debugging tools but none work in the process explorer either nothing happens of it says: the DLL you specified is not a valid version of the Debugging Tools help file.

     

    @igor i tried going into the registery before but what should i change it too? it now stand on 0x00000000 (0)

    Tuesday, November 29, 2011 11:42 AM
  • 0 means auto size.

    the value is the number of bytes you want.

    so we can try 192Mb =

    201326592 (Decimal)

    or 0xC000000

     

    http://technet.microsoft.com/en-us/library/cc976157.aspx

     

     


    MCITP: Enterprise Administrator Windows Server 2008 MCTS: Windows 7, Active Directory, Network Infrastructure, Applications Infrastructure, Exchange 2007 ITIL V3 Certified
    Tuesday, November 29, 2011 10:35 PM