locked
Client failing to install Applications in OSD RRS feed

  • Question

  • This is the first OSD in SCCM 2012 R2 that I am testing and I cannot get any application (not package) deployed finding several different errors (see below).  Also I am confused as to whether the client is properly registering on the server (and if this is the cause of my problems)

    The SMSTS log is showing the following errors during SMS client install:

    • Unable to read SMS client cert from environment. Not restoring SMS client cert.
    • Active request handle is empty, registering with new active request handle. This is expected if the TS was started from a media/PXE.
    • Failed to create instance for IMTCTokenHandler interface, hr=0x80070005
    • Failed to find property 'AutoApplyDeployment' in 'CCM_ApplicationManagementClientConfig' class defintion. Error 0x80041002. Default value will be used for this property
    • Error getting system isolation info. Code 8027000C
    • Remediation failed with error code 8027000C

    Then during the application deployment phase I am seeing:

    • NotifyProgress received: 16 (Application failed to evaluate )
    • Policy Evaluation failed, hr=0x80004005
    • Install application action failed: 'Microsoft Visio Viewer 2013'. Error Code 0x80004005
    • Install application action cannot continue. ContinueOnErrorFlag is set to false.

    The SMS client is installed at the end of the failed task sequence but seems to have a few things not available. 

    Can I get any guidance on how to isolate what might be the cause of this?

    Thanks, Stephen

    Wednesday, January 14, 2015 5:40 AM

Answers

  • Hi,

    >>The SMS client is installed at the end of the failed task sequence but seems to have a few things not available. 

    Please check ccmsetup.log, client.msi.log, ClientLocation.log and LocationServices.log.

    The LocationService-20150115...log shows the client cannot find the MP.

    From the Smsts.log, the 'Microsoft Visio Viewer 2013' failed to install. Is there any application logs? (AppIntentEval.log, AppDiscovery.log and AppEnforce.log)

    Best Regards,

    Joyce

    • Proposed as answer by Joyce L Tuesday, January 20, 2015 10:00 AM
    • Marked as answer by Joyce L Thursday, January 22, 2015 1:30 AM
    Thursday, January 15, 2015 6:20 AM

All replies

  • Wednesday, January 14, 2015 6:57 AM
  • Is this the same behavior you're experiencing?: http://www.vansurksum.com/configmgr-2012-caveat-with-application-revisions-when-used-in-a-task-sequence/


    This issue should have been fixed with R2 so the version of ConfigMgr being used would be good to know. 

    Also upload smsts.log (or even better all ConfigMgr logs) to OneDrive, because just providing single lines are meaninless (they are taken out of context). Thanks


    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, January 14, 2015 7:24 AM
  • From my experience, you should defenetly use R2 CU2, since CU2 fixes lot of OSD issues.

    Also, are your bounderies set okay?

    Wednesday, January 14, 2015 7:38 AM
  • Note that simple copying out a bunch of errors from a log file is completely meaningless. Log files are about context and flow, not just single isolated lines (error or no error). Please post entire, relative, and unedited snippets of the log file showing the initial point of failure. Also, describe the task sequence task where the failure occurred. The more accurate and complete information you can give, the better  we can help you.

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Wednesday, January 14, 2015 2:59 PM
  • does the application install fine when you install it yourself manually.  not VIA SCCM

    if so  check out  c:\windows\logs\software , See if there is a log for the application that you were trying to install.

    Thursday, January 15, 2015 4:05 AM
  • I have uploaded all the logs for this PC into OneDrive as follows:

    OneNoteLink Logs Files

    Thursday, January 15, 2015 4:52 AM
  • Hi,

    >>The SMS client is installed at the end of the failed task sequence but seems to have a few things not available. 

    Please check ccmsetup.log, client.msi.log, ClientLocation.log and LocationServices.log.

    The LocationService-20150115...log shows the client cannot find the MP.

    From the Smsts.log, the 'Microsoft Visio Viewer 2013' failed to install. Is there any application logs? (AppIntentEval.log, AppDiscovery.log and AppEnforce.log)

    Best Regards,

    Joyce

    • Proposed as answer by Joyce L Tuesday, January 20, 2015 10:00 AM
    • Marked as answer by Joyce L Thursday, January 22, 2015 1:30 AM
    Thursday, January 15, 2015 6:20 AM
  • Thank you Joyce for pointing me in the right direction.  I found that becuase my client was being imaged on a Workgroup I had to alter the install properties to ensure it was seeing the MP as follows:

    SMSMP=abc.au

    SMSSLP=abc.au

    DNSSUFFIX=xxx.au

    This worked successfully and now I have a fully functioning Task Sequence.

    Wednesday, January 28, 2015 4:11 AM
  • Using SMSSLP is useless in 2012 because there is no SLP and using DNSSUFFIX is also useless because you've specified SMSMP and therefore don't need to lookup the MP in DNS. All you need is SMSMP. This is pretty standard and should be set in in the Setup Windows and ConfigMgr task in *every* TS to avoid any issues.

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Wednesday, January 28, 2015 2:01 PM