none
DFS folders are hidden when viewing locally on server, or via admin share.

    Question

  • I have two Windows Server 2008 servers setup with DFS replication.  This was installed in July 2009 and has been working perfectly since that time.  A few weeks ago I noticed that the replicated folders are no longer visible from the server itself or through the admin share.  The DFSRoots folder appears empty.  The folders within DFS roots are "deeply hidden", I assume the attributes "system" and "hidden" are set.  I have three folders; Admin, Public, Users.  All three folders have the same behavior, and this behavior is consistent on both servers.

    The DFS continues to work fine as the files and folders are visible through the share and namespace.  I have noticed, however, that our backup (Backup Exec) only shows "DFSRoots" but nothing under it.  I'm assuming that the files are there, because our backup size has not changed.  I'm assuming these hidden attributes prevent me from seeing the folders/files even on our backup.  Just in case I'm wrong I have set up a SyncBack Pro job that backs up the entire DFSRoots folder to disk daily.  I have no clue if this problem is serious or not, and I don't have the luxury of deleting and recreating the DFS as this is in a production environment.  Any help is greatly appreciated!!
    Friday, March 5, 2010 2:34 PM

All replies

  • Hello,

    What account are you loging on to? Check your system and make sure ABE is not enabled. Go to server manager, file management, right clik the root share and see if ABE box is checked
    Isaac Oben MCITP:EA, MCSE
    Friday, March 5, 2010 2:43 PM
  • I'm logging onto a domain administrator account.  I checked and "Enable access based enumeration" is not checked on the root share or any of the subfolders that are also shared.

    Thanks for your help!
    Friday, March 5, 2010 3:09 PM
  • I should clarify, ABE was not enabled.  So the issue isn't related to ABE.
    Friday, March 5, 2010 3:49 PM
  • Hi,

    If I understand correctly, the DFSRoots folder is empty when you access it locally on the namespace server (DFS root server). However, the folders (links) are visible if you access the namespace by using DFS share path, such as \\domain.com\dfsroot.

    Please help check the following:

    1. Do all namespace server encounter the issue?
    2. Do the DFS objects exist in AD domain partition? You can verify it by using adsiedit.msc, then navigate to Default naming context\CN=System\CN=Dfs-Configuration  
    3. Does AD replication work properly in the domain?

    Thanks.
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, March 11, 2010 6:29 AM
    Moderator
  • Hi!

    I have encountered the same problem.
    I have 2 file servers w2k3 R2 on which i have DFS shares and the replication between them. The namespace servers are my two DCs (W2k8 R2).
    I have added another file server, this one on W2k8 R2. After i have added this server to DFS and started the replication, some (not all) folders
    became "very hidden". The folder are still accessible through the namespace name, but not directly. The problem is that some
    aplications are writing directly to d:\foldername\filename, which is not possible any more.
    I have tried with attrib -h, but I got: Not resetting system file - d:\foldername.

    In the mean time we have also raised the domain functional level to Windows 2008 R2 (thought it would help), the namespace is Domain-level Windows
    Server 2000 (i do not know why).

    Any help is appreciated.

    Regards,
    Marko.
    • Proposed as answer by em3601 Tuesday, March 30, 2010 7:57 AM
    Tuesday, March 16, 2010 1:46 PM
  • I have exactly the same issue. 

    A new replicated DFS share, the source folder on the hub server is no longer visible in the file system. I can get to it via the share, and the namespace though. Any suggestions?

    • Proposed as answer by iimmy Thursday, July 22, 2010 6:08 AM
    Wednesday, June 23, 2010 2:10 PM
  • I had the same issue with one of my File server. I tried the ATTRIB command to unhide it:

     

    attrib -r -h -s "G:\folder_name"

     

    Regards

    Imran

    • Proposed as answer by Cwestwell Monday, July 25, 2011 8:48 PM
    Thursday, July 22, 2010 6:09 AM
  • iimmy - you cracked it.

    Thanks

    Friday, October 15, 2010 4:34 PM
  • thanks for the easy fix, this did it for me.....I was very confused

     

    Monday, July 25, 2011 8:48 PM
  • I had this exact same issue, but after un-hiding it with the attrib command it happens again but only on a few folders. What is causing it to be hidden. Its happening every morning. 
    Thursday, January 10, 2013 10:59 PM
  • Attrib works for me also.

    Thx!

    Tuesday, February 5, 2013 8:28 AM
  • Attrib did work,

    but some hours later the dfs-shares are hidden again.

    Howto fix this permanent?

    Thx

    Wednesday, February 6, 2013 6:58 AM
  • It's happening with me too. Folders are getting hidden locally after editing the DFS replication schedule. Once changed, folders get messed up (My luck that users was not affected by this)

    Edited Specs:

    Windows Server 2012 std. Fully Updated

    MS Partner - MCP


    Wednesday, February 20, 2013 12:06 PM
  • Anybody having a solution for this recuring issue?

    Thx

    Wednesday, February 20, 2013 7:05 PM
  • We had this problem in our company as well. We found out it was some malware on a users workstation that was causing the issue of the folders being hidden and attrib was the only way to get it back. One we found the malwared computer the issue never came back.
    Tuesday, March 5, 2013 11:03 PM
  • thank u buddy.its really amazing
    Tuesday, July 16, 2013 11:17 AM
  • Thanks Imran this did it for me
    • Edited by E_Leo Thursday, August 17, 2017 7:14 AM
    Thursday, August 17, 2017 7:13 AM
  • I had the same issue with one of my File server. I tried the ATTRIB command to unhide it:

     

    attrib -r -h -s "G:\folder_name"

     

    Regards

    Imran


    LEGEND !!!
    Friday, May 18, 2018 9:49 AM