none
Unable to set out of office on Outlook 2013 - Autodiscovery issue. RRS feed

  • Question

  • Hi

    when i click on Automatic Replies (out of office) i get this error "your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later.

    When i do Test E-mail Autoconfiguration i get this reponse

    Autoconfiguration was unable to determine your settings!

    I belive OOF isn't working because of autodiscover issue. 

    https://OWA_URL/Autodiscover/Autodiscover.xml

    xml version="1.0" encoding="utf-8" ?>
    - <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
    - <Response>
    - <Error Time="11:09:28.7811659" Id="2346168337">
    <ErrorCode>600</ErrorCode>
    <Message>Invalid Request</Message>
    <DebugData />
    </Error>
    </Response>

    </Autodiscover>

    Most of the clients are running Outlook 2003, so this is the first time i'm having to deal with such a problem.

    We are running a SBS windows 2008 server with Exchange 2007. This was migrated from SBS 2003.

    Please note, the issue is on our LAN, and we have a DNS record for the exchange server.

    e.g. https://mail.domain.com/owa works internally and externally. 

    I can set the OOO via OWA for this user.

    Please help

    Friday, August 29, 2014 7:40 AM

Answers

  • Yes, there are a lot of organizations whose external domain name is different to the DNS domain name of the AD forest/domain. But when that's the case they have (or should have) a DNS zone on an internal DNS server that matches the name used for external e-mail. The internal and external DNS can resolve the name to different addresses.

    In the case of the original poster, there's no DNS zone named uglog.com in the screen shot of his DNS (which I assume is the internal DNS).


    --- Rich Matheisen MCSE&I, Exchange MVP

    • Marked as answer by uklogistics Tuesday, September 16, 2014 4:12 PM
    Monday, September 1, 2014 2:23 AM
  • Add below  A records in uglog.com forward lookup zone which points to Exchange server IP
    So when you ping autodiscover.uglog.com  and commonname.uglog.com it should return your exchange server IP

    • Autodiscover  
    • commonname 


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by uklogistics Tuesday, September 16, 2014 4:12 PM
    Wednesday, September 3, 2014 4:17 PM
  • Please check this. Steps to troubleshoot and reference to autodiscover configuartion
    http://social.technet.microsoft.com/Forums/en-US/54bc6b17-9b60-46a4-9dad-584836d15a02/troubleshooting-and-introduction-for-exchange-20072010-autodiscover-details-about-test-email?forum=exchangesvrgeneral

    Hope it helpsBTW you should create mail.uglog.com or what ever name you use for accessing OWA not "commonname.uglog.com"


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by uklogistics Tuesday, September 16, 2014 4:12 PM
    Thursday, September 4, 2014 11:05 AM
  • The IIS log files on the CAS might tell you something. Depending on how your proxy server handles NAT the IP address of your connection might be from the proxy server instead of your client.

    In any case, a tool like Fiddler (http://www.telerik.com/fiddler) can be extremely helpful in working on problems like this because it can decode the SSL traffic on the client and you can see what's being sent and what's being received.

    Another thing to check (although it's unlikely to be your case) is whether or not your browser (when you try connecting to the autodiscover URL) thinks it's in the "Internet" zone. the "Local intranet", or at a "Trusted" site.

    The domain names you use on machines on your LAN should be excluded from being proxyed. Anything with "." in the name will be set, unless excluded, to the proxy server.

    Is the time correct on the client machine? Is it more than 5 minutes different to the Exchange machines and domain controllers? That'd be something that would cause Kerberos to fail.

    A certificate can be a problem if its expired or if it doesn't have the correct names. But I wouldn't worry about the uglog.com domain just yet. Until you get the Autodiscover working with the SCP you have bigger problems.

    If you've never used a WPAD file then don't worry about it. It's very useful if you have a complex network and you want to manage how browsers connect to servers. For example, if you have multiple proxy servers the each manage a different set of names, an/or if some names should bypass proxy servers entirely and just connect directly. If run a strictly Microsoft network with only Microsoft product that you can manage with GPOs (and you can enforce those GPOs on every machine -- even the BYOD ones) you probably don't need a WPAD.


    --- Rich Matheisen MCSE&I, Exchange MVP

    • Marked as answer by uklogistics Tuesday, September 16, 2014 4:11 PM
    Thursday, September 4, 2014 7:51 PM

All replies

  • Hi

    Outlook 2010 did not work with autodiscover in exchange 2003 so i doubt outlook 2013 will. you will manually have to setup an account and use OWA to set OOF.


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, August 29, 2014 10:45 AM
  • We have an exchange 2007 server, surely autodiscover should work for Outlook 2013!
    Friday, August 29, 2014 12:00 PM
  • apologies, i saw exchange 2003.

    Yes it will work with exchange 2007.

    In DNS do you have a CNAME record setup as you mentioned?

    Is it only this user or all users experiencing the OOF problem?


    Hope this helps. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, August 29, 2014 12:03 PM
  • Where under the DNS tree should I be looking for the CNAME in question?

    Here is a screenshot.

    Note the domain name used for the email is different to the domain name set against the server (see below) would this be causing the confusion on the Outlook client?

    e.g.


    • Edited by uklogistics Friday, August 29, 2014 1:51 PM
    Friday, August 29, 2014 1:49 PM
  • "600" is the expected error code if you browse to the autodiscover.xml file.

    With OL 2013 open, find the Outlook icon in the notification are on the machine's task bar. Ctrl+Right-click the icon and select the "Test E-Mail Configuration...". Uncheck the two "guessmart" boxes and then click the "Test" button. Did it succeed? What are the OOF URLs?

    Have you tried http://exrca.com to see if the diagnostics it offers helps you to figure out what's wrong?


    --- Rich Matheisen MCSE&I, Exchange MVP

    Friday, August 29, 2014 7:02 PM
  • Yes, it will be a problem. The OL client will look for uglog.com/autodiscover/autodiscover.xml and autodiscover.ulog.com/autodiscover/autodiscover.xml. IOW, it uses the domain portion of the user's e-mail address to find the AutoDiscover stuff.

    --- Rich Matheisen MCSE&I, Exchange MVP

    Friday, August 29, 2014 7:08 PM
  • Yes, it will be a problem. The OL client will look for uglog.com/autodiscover/autodiscover.xml and autodiscover.ulog.com/autodiscover/autodiscover.xml. IOW, it uses the domain portion of the user's e-mail address to find the AutoDiscover stuff.

    --- Rich Matheisen MCSE&I, Exchange MVP

    Hi

    How do i resolve this?

    Do I need to create some kind of internal DNS records ? Please advise steps Thanks


    Friday, August 29, 2014 8:10 PM
  • Please configure SplitDNS to resolve external name internally and configure your exchange autodscover, EWS URLs. Please check this and this 
    http://social.technet.microsoft.com/Forums/en-US/54bc6b17-9b60-46a4-9dad-584836d15a02/troubleshooting-and-introduction-for-exchange-20072010-autodiscover-details-about-test-email?forum=exchangesvrgeneral

    Your OOF shoud be working after this


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Saturday, August 30, 2014 12:29 PM
  • Aren't there organizations that use email addresses like:

    sherlock.holmes@bakerstreet.org

    And have an Active Directory domain:

    detectives.uk

    In that case, I see that, externally, where the Outlook client uses DNS to find the autodiscover services, this could be a problem.

    But in the case of the original poster, wouldn't the client look for a SCP record in Active Directory, whose "servicebindingattribute" value could be:

    https://server1.detectives.uk/autodiscover/autodiscover.xml

    or better...

    https://mail.detectives.uk/autodiscover/autodiscover.xml

    Couldn't the Outlook client find autodiscover services with the SCP record even if the email address suffix is different from the Active Directory domain name?

    Wouldn't the LDAP query to the Global Catalog use the Active Directory domain name - rather than the email address suffix?


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Saturday, August 30, 2014 8:41 PM
  • Hi,

    The Error Code 600 when you access the https://OWA_URL/Autodiscover/Autodiscover.xml for your Autodiscover service indicates that your autodiscover service should be proper and accessed successfully by using this URL.

    Please run Test E-mail AutoConfiguration in Outlook 2007 or higher version to check whether your Autodiscover service can be accessed successfully or not and if the OOF URL can be retrieved by using Autodiscover service. If possible, you can also post the Results tab and Log tab here for detailed analysis.

    Additionally, we can directly access OOF URL from IE to check whether a page with XML information or a service page can be returned. Here is an article about the OOF troubleshooting:

    http://www.msoutlook.info/question/879

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.

    Regards,


    Winnie Liang
    TechNet Community Support


    Monday, September 1, 2014 1:47 AM
    Moderator
  • Yes, there are a lot of organizations whose external domain name is different to the DNS domain name of the AD forest/domain. But when that's the case they have (or should have) a DNS zone on an internal DNS server that matches the name used for external e-mail. The internal and external DNS can resolve the name to different addresses.

    In the case of the original poster, there's no DNS zone named uglog.com in the screen shot of his DNS (which I assume is the internal DNS).


    --- Rich Matheisen MCSE&I, Exchange MVP

    • Marked as answer by uklogistics Tuesday, September 16, 2014 4:12 PM
    Monday, September 1, 2014 2:23 AM
  • Hi

    I right clicked on Forwawrd Lookup zones > NEw zone> primary zone > untick store in AD > added domain uglog.com

    I then added a CNAME for autodiscover.uglog.com.

    I then tried the autodscover test on outlook 2013 and and get the following errors

    showing the new zone added

    showing the error message

    Wednesday, September 3, 2014 3:19 PM
  • Add below  A records in uglog.com forward lookup zone which points to Exchange server IP
    So when you ping autodiscover.uglog.com  and commonname.uglog.com it should return your exchange server IP

    • Autodiscover  
    • commonname 


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by uklogistics Tuesday, September 16, 2014 4:12 PM
    Wednesday, September 3, 2014 4:17 PM
  • Hi

    I have done as you suggested and appear to be receiving the same errors. Here is the screen shot showing error and new A records under zone uglog.com and removed the CNAME entry ( see previous screen shot).

    Thursday, September 4, 2014 10:17 AM
  • also, there are the DNS settings for the zone
    Thursday, September 4, 2014 10:22 AM
  • Please check this. Steps to troubleshoot and reference to autodiscover configuartion
    http://social.technet.microsoft.com/Forums/en-US/54bc6b17-9b60-46a4-9dad-584836d15a02/troubleshooting-and-introduction-for-exchange-20072010-autodiscover-details-about-test-email?forum=exchangesvrgeneral

    Hope it helpsBTW you should create mail.uglog.com or what ever name you use for accessing OWA not "commonname.uglog.com"


    Thanks, MAS
    Please mark as helpful if you find my comment helpful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by uklogistics Tuesday, September 16, 2014 4:12 PM
    Thursday, September 4, 2014 11:05 AM
  • You ran that "Test E-Mail AutoConfiguration..." test from your LAN and not from the Internet, is that correct?

    If that's true then the SCP (Service Connection Point) information in your AD should have worked and not failed with an error 12152 (ERROR_HTTP_INVALID_SERVER_RESPONSE).

    Also, the 0x80072F78 error points to some sort of problem with either connectivity or authentication.

    In your original post you said you tried this URL and received a 600 status:

    https://OWA_URL/Autodiscover/Autodiscover.xml

    Would that really have been URL?

    https://mail.unsworthcl.com/Autodiscover/Autodiscover.xml

    Do you use a proxy server? If so, have you configured either the local proxy settings on the workstations (or, better, the WPAD file delivered from the proxy server) so that connections to that machine do NOT go to the proxy server???

    Oh . . . and if you're using a WPAD file, have you configured DNS so it actually answers queries for WPAD?

    http://technet.microsoft.com/en-us/library/cc995158.aspx


    --- Rich Matheisen MCSE&I, Exchange MVP

    Thursday, September 4, 2014 3:43 PM
  • 1. Only doing the "Test E-Mail AutoConfiguration..." from our LAN

    2. Yes, this is the real URL i used in the browser see screen shot , https://mail.unsworthcl.com/Autodiscover/Autodiscover.xml

    3. We have a proxy server that is running on a device that sits behind our internet connection. I normally add Excepions to IE proxy settings using GPO. Should I add autodiscover.uglog.com and mail.uglog.com to the exception list to bypass the proxy?

    4. Never used a WPAD file, and don't know what it is

    5. In addition, could the certificate on the server be an issue? the certificate we have is for unsworthcl.com and do not have one for uglog.com

    Thursday, September 4, 2014 4:05 PM
  • The IIS log files on the CAS might tell you something. Depending on how your proxy server handles NAT the IP address of your connection might be from the proxy server instead of your client.

    In any case, a tool like Fiddler (http://www.telerik.com/fiddler) can be extremely helpful in working on problems like this because it can decode the SSL traffic on the client and you can see what's being sent and what's being received.

    Another thing to check (although it's unlikely to be your case) is whether or not your browser (when you try connecting to the autodiscover URL) thinks it's in the "Internet" zone. the "Local intranet", or at a "Trusted" site.

    The domain names you use on machines on your LAN should be excluded from being proxyed. Anything with "." in the name will be set, unless excluded, to the proxy server.

    Is the time correct on the client machine? Is it more than 5 minutes different to the Exchange machines and domain controllers? That'd be something that would cause Kerberos to fail.

    A certificate can be a problem if its expired or if it doesn't have the correct names. But I wouldn't worry about the uglog.com domain just yet. Until you get the Autodiscover working with the SCP you have bigger problems.

    If you've never used a WPAD file then don't worry about it. It's very useful if you have a complex network and you want to manage how browsers connect to servers. For example, if you have multiple proxy servers the each manage a different set of names, an/or if some names should bypass proxy servers entirely and just connect directly. If run a strictly Microsoft network with only Microsoft product that you can manage with GPOs (and you can enforce those GPOs on every machine -- even the BYOD ones) you probably don't need a WPAD.


    --- Rich Matheisen MCSE&I, Exchange MVP

    • Marked as answer by uklogistics Tuesday, September 16, 2014 4:11 PM
    Thursday, September 4, 2014 7:51 PM
  • Hi Rich, many thanks for your update.

    FYG the  "Test E-Mail AutoConfiguration..." works when I connect over the internet, just tried it from home. The A Record I created a few days back appears to work... So do not believe this is a certificate issue as you just get a certificate miss match prompt , and click yes.

    I will do some further testing tomorrow on the LAN with the proxy side of things and see where we get to.

    If the default gateway on the client machines are set to the router (192.168.0.1) and not the domain controller would Outlook attempt to route via the internet, or because of the DNS server set to 192.168.0.10 would iit resolve *.uglog.com back to the domain controller, thus not routing the request over the internet?

    Thursday, September 4, 2014 8:54 PM
  • If the Outlook client machine and the Exchange CAS are on the same network (say, 192.168.0.0/24) there's no router involved at all. A router is only necessary when machines are on different networks.

    Depending on the release of MS Windows running on the client machines, you can use either proxycfg or netsh to check (and change) the proxy settings.

    http://msdn.microsoft.com/en-us/library/windows/desktop/aa384069(v=vs.85).aspx

    It might be instructive to simple change one of the failing client machines to use NO PROXY at all. They probably won't be able to get to Internet sites, but that's not what you're troubleshooting right now. :-)


    --- Rich Matheisen MCSE&I, Exchange MVP

    Friday, September 5, 2014 4:10 PM
  • Hi Rich

    From IE i have disabled the Proxy , restarted IE and Outlook and still unable to connect successfully.

    From the same PC on our LAN running Outlook 2007 SP3 I tried "Test E-Mail AutoConfiguration..." and it is throwing a error Auth package: Unspecified

    The SERVER is set to NULL, i checked by using this command;

    get-Outlookprovider -identity EXPR |fl

    What could be the issue ?

    I cannot understand why I’m not getting this error Externally?

    here are the screeen shots

    Monday, September 8, 2014 12:01 PM
  • Just a quick update here - OOF is now working for Outlook clients 2007 + 2013...hooray :) thanks for everyone's help

    added another entry to the proxy exclusion list *.unsworthcl.com , retested and worked!

    however, when I run the "Test E-Mail AutoConfiguration..." on these clients i'm still getting Auth Package: Unspecified ,  do i just ignore this?

    also is there way via GPO for Outlook clients greater than 2007 to suppress the certificate match error ?

    I have tried to manually add the reg key on client PCs mentioned http://support.microsoft.com/kb/2783881, however these clients do not have RedirectServers under AutoDiscover

    1. HKEY_CURRENT_USER\Software\Microsoft\Office\<var>xx</var>.0\Outlook\AutoDiscover\RedirectServers


    Monday, September 8, 2014 1:42 PM
  • What authentication do you see with get-outlookanywhere?

    --- Rich Matheisen MCSE&I, Exchange MVP

    Monday, September 8, 2014 6:52 PM
  • Hi

    See screen shot

    Monday, September 8, 2014 9:52 PM
  • Is there way via GPO for Outlook clients greater than 2007 to suppress the certificate match error when starting up Outlook?
    Tuesday, September 16, 2014 4:11 PM