none
ZTI ERROR - Non-zero return code from loadstate, RC = 71 RRS feed

  • Question

  • I had success deployment window image.

    But 2 Error was found as below:

    ZTI ERROR - Non-zero return code from loadstate, RC = 71

    ZTI ERROR - Non-zero return code from ZTIUserState, RC = 71

    Please help....

    Thursday, June 6, 2013 6:39 AM

All replies

  • I check the Error Return code as:

    71

    USMT_INIT_OPERATING_ENVIRONMENT_FAILED

    A Windows Win32 API error occurred

    Data transfer has begun, and there was an error during the creation of migration store or during the apply phase. Review the ScanState log or LoadState log for details.

    Fatal Errors

    An error occurred when attempting to initialize the diagnostic mechanisms such as the log

    Data transfer has begun, and there was an error during the creation of migration store or during the apply phase. Review the ScanState log or LoadState log for details.

    Failed to record diagnostic information

    Data transfer has begun, and there was an error during the creation of migration store or during the apply phase. Review the ScanState log or LoadState log for details.

    How to find the Scantate.log or loadstate.log file?

    If not as default how can i create it?

    Thursday, June 6, 2013 7:22 AM
  • MY CS file for this.
    ScanStateArgs=/v:5 /o /c /localonly /nocompress /listfiles:\\SG1-storage\%osdcomputername%_docs.txt /uel:10 /vsc 
    LoadStateArgs=/v:5 /c /nocompress /lac
    UDShare=\\SG1-STORAGE
    UDDir=%OSDComputerName%
    USMTMigFiles1=MigApp.xml
    USMTMigFiles2=EmrDocs.xml
    UserDataLocation=NETWORK
    Thursday, June 6, 2013 7:24 AM
  • Normally in windows\temp\smstslog.  Since you don't declare it in your args, maybe try adding the logging parts to the ScanStateArgs or LoadStateArgs with /L:<path>\scanstate.log

    You can see all the switches here: http://technet.microsoft.com/en-us/library/dd560781(v=WS.10).aspx


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Thursday, June 6, 2013 1:43 PM
    Answerer
  • Hi,

    i have args as =  /listfiles:\\SG1-storage\%osdcomputername%_docs.txt
    All the file being copy will be in this test file.
    My Scanstate and capture data was working well.

    I face the problem was loadstate...

    Can i add as
    LoadStateArgs=/v:5 /c /nocompress /lac /L:SG1-storage\loadstate.log ? ?

    Friday, June 7, 2013 1:12 AM
  • I believe that would put the file relative to where the command is run, so it may not end up where you want it to be.  However, give it a try and see what happens and if you can find LoadState.log so we can debug the actual issue.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Friday, June 7, 2013 4:55 AM
    Answerer
  • I was try on the command
    LoadStateArgs=/v:5 /c /nocompress /lac /L:SG1-storage\loadstate.log

    Not create loadstate.log file and having same error.

    ~~~~~~~~~~~

    Any idea to help me verify it?
    or you can guide me any default setting on loadStateArgs?

    Friday, June 7, 2013 7:11 AM
  • Try like /l:C:\temp\loadstate.log and then look at that machine for the log.  That would at least let you try and solve the real problem (which isn't exactly related to saving loadstate.log to the network).

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Saturday, June 8, 2013 1:48 AM
    Answerer
  • 2013-06-10 11:53:10, Info                  [0x000000] USMT Started at 2013/06/10:11:53:10.768
    2013-06-10 11:53:10, Info                  [0x000000] Command line: C:\MININT\USMT\X86\loadstate.exe \\SG1-Storage\UserBackup\Sg1-LHPSS22S /v:5 /c /nocompress /lac /l:C:\temp\loadstate.log /i:C:\MININT\USMT\X86\MigApp.xml /i:C:\MININT\USMT\X86\EmrDocs.xml /config:C:\MININT\USMT\X86\ZTIUserState_Config.xml /l:C:\MININT\SMSOSD\OSDLOGS\USMTrestore.log /progress:C:\MININT\SMSOSD\OSDLOGS\USMTrestore.prg
    2013-06-10 11:53:10, Status                [0x000000] Activity: 'MIGACTIVITY_COMMAND_LINE_PROCESSING'
    2013-06-10 11:53:10, Info                  [0x000000] Failed.[gle=0x00000006]
    2013-06-10 11:53:10, Info                  [0x000000]   An error occurred processing the command line.
      C:\MININT\USMT\X86\loadstate.exe \\SG1-Storage\UserBackup\Sg1-LHPSS22S /v:5 /c /nocompress /lac /l:C:\temp\loadstate.log /i:C:\MININT\USMT\X86\MigApp.xml /i:C:\MININT\USMT\X86\EmrDocs.xml /config:C:\MININT\USMT\X86\ZTIUserState_Config.xml ##ERROR## --> /l:C:\MININT\SMSOSD\OSDLOGS\USMTrestore.log /progress:C:\MININT\SMSOSD\OSDLOGS\USMTrestore.prg
      An option is specified more than once and is ambiguous[gle=0x00000006]
    2013-06-10 11:53:10, Info                  [0x000000] USMT Completed at 2013/06/10:11:53:10.768[gle=0x00000006]
    2013-06-10 11:53:10, Info                  [0x000000] Entering MigShutdown method
    2013-06-10 11:53:10, Info                  [0x000000] Leaving MigShutdown method


    Monday, June 10, 2013 5:19 AM
  • Sorry for late reply. this the loadstate.log from the command
    /l:C:\temp\loadstate.log
    Monday, June 10, 2013 5:20 AM
  • Looks like it failed since the log path was already being specified: /l:C:\MININT\SMSOSD\OSDLOGS\USMTrestore.log

    Remove the /l:C:\temp\loadstate.log from the CustomSettings.ini, rerun the Task Sequence, and look in C:\MININT\SMSOSD\OSDLOGS\USMTRestore.log to see what the real error is.


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Monday, June 10, 2013 12:44 PM
    Answerer
  • How can i retrive  C:\MININT\SMSOSD\OSDLOGS\USMTRestore.log ?

    As normally its will gone once error pop out...

    Tuesday, June 11, 2013 1:32 AM
  • You could put a Pause in the Task Sequence right after the LoadState step so that you can grab the file before anything else happens.

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, June 11, 2013 4:23 AM
    Answerer
  • the restore.log was long...
    I copy for you the end of the log as:
    DefaultSupported: 1, Supported: 1, Valid64to32Arch: 0
    2013-06-11 15:19:50, Info                  [0x080362] Dumping all migration units: END
    2013-06-11 15:19:50, Info                  [0x000000] Completed deserialization of migration engine state
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigOpenUNCStore method
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetRealPlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetRealPlatform method
    2013-06-11 15:19:50, Status                [0x000000] Activity: 'MIGACTIVITY_PROCESSING_CONFIGXML'
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetRealPlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetRealPlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Config.Xml Policy: I/O error 32 in File pattern '* [*]' will be skipped
    2013-06-11 15:19:50, Info                  [0x000000] Config.Xml Policy: I/O error <any> in File pattern 'C:\Users\* [*]' will be fatal
    2013-06-11 15:19:50, Info                  [0x000000] Config.Xml Policy: I/O error 5 in Registry pattern '* [*]' will be skipped
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Selecting migration units
    [gle=0x00000006]
    2013-06-11 15:19:50, Status                [0x000000] Activity: 'MIGACTIVITY_MIGUNIT_SELECTION'
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetStorePlatform method
    2013-06-11 15:19:50, Status                [0x000000] Activity: 'MIGACTIVITY_USER_MAPPING'
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetRealPlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetRealPlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetRealPlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetRealPlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetStorePlatform method
    2013-06-11 15:19:50, Info                  [0x000000] User EEE\user maps to S-1-5-21-1417001333-1682526488-839522115-872270
    2013-06-11 15:19:50, Info                  [0x000000] User EMRSN\SLUser.Service maps to S-1-5-21-1417001333-1682526488-839522115-219372
    2013-06-11 15:19:50, Info                  [0x000000] User SG1-LHPSS22S\Admin maps to SG1-LHPSS22S\Sys-Pro-Admin
    2013-06-11 15:19:50, Info                  [0x000000] Adding domain account EEE\user (S-1-5-21-1417001333-1682526488-839522115-872270)
    2013-06-11 15:19:50, Info                  [0x0803b2] Adding user S-1-5-21-1417001333-1682526488-839522115-872270,
    2013-06-11 15:19:50, Info                  [0x0803b3] User S-1-5-21-1417001333-1682526488-839522115-872270, added successfully
    2013-06-11 15:19:50, Info                  [0x000000] Adding domain account EMRSN\SLUser.Service (S-1-5-21-1417001333-1682526488-839522115-219372)
    2013-06-11 15:19:50, Info                  [0x0803b2] Adding user S-1-5-21-1417001333-1682526488-839522115-219372, EMRSN\SLUser.Service
    2013-06-11 15:19:50, Info                  [0x0803b3] User S-1-5-21-1417001333-1682526488-839522115-219372, EMRSN\SLUser.Service added successfully
    2013-06-11 15:19:50, Status                [0x000000] Activity: 'MIGACTIVITY_PROFILE_CREATE'
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigGetRealPlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigGetRealPlatform method
    2013-06-11 15:19:50, Info                  [0x000000] Creating profile for target user SG1-LHPSS22S\-Admin (source user SG1-LHPSS22S\Admin)
    2013-06-11 15:19:50, Info                  [0x080000] Creating profile for user S-1-5-21-970688620-1718658648-251399469-500, SG1-LHPSS22S\Admin. Using existent SID
    2013-06-11 15:19:50, Error                 [0x080000] There was an error while calling CreateProfile. Error: 0x800700B7
    2013-06-11 15:19:50, Info                  [0x0803e5] Not unmapping HKCU; it is not mapped
    2013-06-11 15:19:50, Error                 [0x000000] Error 0 creating profile for user SG1-LHPSS22S\Admin (source user SG1-LHPSS22S\Admin)
    2013-06-11 15:19:50, Info                  [0x000000] Failed.[gle=0x00000006]
    2013-06-11 15:19:50, Info                  [0x000000]   A Windows Win32 API error occurred
       Windows error 0 description: The operation completed successfully.[gle=0x00000006]
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigCloseCurrentStore method
    2013-06-11 15:19:50, Info                  [0x0801dc] Closing catalog file
    2013-06-11 15:19:50, Info                  [0x0801dd] Deleting catalog file at C:\Users\Administrator\AppData\Local\Temp\tmp71B5.tmp\Temp\tmpBA79.tmp
    2013-06-11 15:19:50, Error                 [0x0802f5] CMediaManager::Close: m_pSelectedTransport->Close(1) failed with Exception Win32Exception: Device was open with readonly access.: Access is denied. [0x00000005] void __thiscall Mig::CMediaManager::CloseTransport(int)
    void __thiscall Mig::CUNCTransport::Close(int).[gle=0x00000006]
    2013-06-11 15:19:50, Error                 [0x000000] MigCloseCurrentStore caught exception: Win32Exception: Device was open with readonly access.: Access is denied. [0x00000005] void __thiscall Mig::CMediaManager::CloseTransport(int)
    void __thiscall Mig::CUNCTransport::Close(int)[gle=0x00000006]
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigCloseCurrentStore method
    2013-06-11 15:19:50, Info                  [0x000000] USMT Completed at 2013/06/11:15:19:50.631[gle=0x00000006]
    2013-06-11 15:19:50, Info                  [0x000000] Entering MigShutdown method
    2013-06-11 15:19:50, Info                  [0x080000] Manifest thread was canceled. Exiting.
    2013-06-11 15:19:50, Info                  [0x080000] COutOfProcPluginFactory::RecoverOrTerminateHost: Successfully recovered host process.
    2013-06-11 15:19:50, Error                 [0x080872] COutOfProcPluginFactory::RecoverOrTerminateHost: Surrogate host unexpectedly exited. Likely one of plugins crashed. Look for last plugin, find manifest that declares plugin, looks for "author" attribute, extract owner and file a bug to him. hr=[0x80070534].[gle=0x00000534]
    2013-06-11 15:19:50, Warning               [0x0809cc] COutOfProcPluginFactory::RecoverOrTerminateHost: All attempt to recover IMigPluginSurrogate failed. Proceeding with process termination.
    2013-06-11 15:19:50, Info                  [0x0803e6] Removing mapping for HKLM
    2013-06-11 15:19:50, Info                  [0x0803e7] Successfully unmapped HKLM
    2013-06-11 15:19:50, Info                  [0x0803e6] Removing mapping for HKU
    2013-06-11 15:19:50, Info                  [0x0803e7] Successfully unmapped HKU
    2013-06-11 15:19:50, Info                  [0x080487] Destroying OS analysis service
    2013-06-11 15:19:50, Info                  [0x080488] Destroyed OS analysis service
    2013-06-11 15:19:50, Info                  [0x000000] Leaving MigShutdown method


    Tuesday, June 11, 2013 7:55 AM
  • I can saw my storage server was being map in PC...

    But, the data was failed to loaded...

    Tuesday, June 11, 2013 7:59 AM
  • Your error looks a lot like this: http://blogs.technet.com/b/configurationmgr/archive/2012/01/12/fix-configmgr-2007-osd-deployments-fail-with-error-0x800700b7-in-loadstate-log.aspx

    Did you at one point join the machine you captured the WIM from to the domain and login with the account you are now trying to capture?  You may need to clean up your WIM in order for USMT to work (and make sure you don't join it to a domain before capture or at least flush out all the profiles).


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, June 11, 2013 10:54 PM
    Answerer
  • There seems to be quite a few errors in this log.  Is the scanstate working correctly?

    Also,  what OS are you moving from / to?

    Tuesday, June 11, 2013 11:56 PM