locked
SharePoint Designer 2010 cannot edit master pages RRS feed

  • Question

  • Getting this popup error when trying to edit a master page in SD2010(latast build from //ProductWeb, 14.0.4514.1007)

    "Master page editing has been disabled for this site. Contact the site collection administrator to request permission."

    We have admin access to the site, as well as the design role. Once I got the design role I got the options in the master page gallery to add master pages, and to edit them in SD2010. Great. Problem is once SD2010 opens up I get this error. Also get this error directly in SD2010 when clicking the "How do I customize the site master page?" link in the site dashboard after I open it.

    Do we need to get the server admin to edit the onet.xml and remove that DisableWebDesignFeatures="wdfopensite" attribute? Or could there be some other lockdown somewhere we can untangle using our Admin role in the SharePoint site.
    • Moved by Clayton Cobb Wednesday, March 30, 2011 8:07 AM SPD Question (From:SharePoint 2010 - General Questions and Answers)
    Friday, November 6, 2009 10:27 PM

Answers

  • Go to Site Actions and click on SharePoint Designer Settings under Site Collection Administration and enable the desired settings.

    1) Enable Customizing Master Pages and Layout Pages

    There are also more settings you can enable if you want to:

    1) Enable Detaching Pages from the Site Definition
    2) Enable Managing of the Web Site URL Structure

    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    • Proposed as answer by Clayton Cobb Saturday, November 7, 2009 2:01 AM
    • Edited by Chakkaradeep Chandran Saturday, November 7, 2009 11:11 AM Added the available options
    • Marked as answer by Mike Walsh FIN Tuesday, November 10, 2009 5:33 PM
    Saturday, November 7, 2009 1:28 AM

All replies

  • Go to Site Actions and click on SharePoint Designer Settings under Site Collection Administration and enable the desired settings.

    1) Enable Customizing Master Pages and Layout Pages

    There are also more settings you can enable if you want to:

    1) Enable Detaching Pages from the Site Definition
    2) Enable Managing of the Web Site URL Structure

    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    • Proposed as answer by Clayton Cobb Saturday, November 7, 2009 2:01 AM
    • Edited by Chakkaradeep Chandran Saturday, November 7, 2009 11:11 AM Added the available options
    • Marked as answer by Mike Walsh FIN Tuesday, November 10, 2009 5:33 PM
    Saturday, November 7, 2009 1:28 AM
  • > enable the desired settings

    is a bit vague. I would have marked it up to answer level (from Clayton's propose as answer) if exactly which settings were required had been specified.


    (Moderator)

    P.S. Thanks for cutting your sig down from 7 lines to 3.




    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    • Marked as answer by Mike Walsh FIN Tuesday, November 10, 2009 5:32 PM
    • Unmarked as answer by Mike Walsh FIN Tuesday, November 10, 2009 5:32 PM
    Saturday, November 7, 2009 10:38 AM
  • is a bit vague. I would have marked it up to answer level (from Clayton's propose as answer) if exactly which settings were required had been specified.
    Done. Edited my post :)
    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Saturday, November 7, 2009 11:12 AM
  • Looks like instructions you gave are via the SharePoint sites admin interface? We only have owner/designer roles for the site itself I believe. This is for Microsoft's //SharePoint site do I doubt we have access to the sites actual admin interface.

    Edit: It's a subsite of //SharePoint...and I don't think God himself has access to the admin on that :)
    • Edited by Harlequin Monday, November 9, 2009 7:35 PM Added subsite info...
    Monday, November 9, 2009 7:15 PM
  • >>Looks like instructions you gave are via the SharePoint sites admin interface?

    Yes, this settings needs to be configured in order to edit Master Pages and a user not having sufficient permissions will not be able to change this setting.

    Regards,
    Chakkaradeep || SharePoint Developer - MCTS SharePoint Dev, WSS Dev
    http://www.intergen.co.nz || Twitter: http://twitter.com/chakkaradeep || http://www.chakkaradeep.com
    Monday, November 9, 2009 10:27 PM
  • Thanks, I'll relay this to the sites admin, hoping it works... =)

    I'll mark as answer if it does.
    Monday, November 9, 2009 10:49 PM
  • Got it working now, thanks.

    Not sure what to mark as answer though, since it is work on Microsoft's //SharePoint and it's not 100% up and running I think. Database might be in read-only mode right now, since the errors we get seem to point to that.
    Monday, November 16, 2009 4:59 PM
  • There is nothing to do with database readonly. The issue is only with the migrated site from WSS 3.0 to Sharepoint Foundation Server 2010. I have enabled all the designer settings as mentioned by Chakkaradeep.

    Also I am not able to see the custom pages we have created in WSS. I am using sharepoint designer 2010 to edit the site.

    Any solution will be appretiated.

    Wednesday, September 22, 2010 5:01 AM
  • I am having the same problem. All these options are tunred on in the Sharepoint Designer Settings section, but I get that error dialog in Sharepoint Designer.
    Monday, November 15, 2010 10:16 PM
  • What levels of permission does one need to edit a master page in sp2010? For example can users who have full control permission levels edit and create custom master pages or does this require 'site collection admin ' level permissions?


    Thank you!
    Mark -

    Friday, February 18, 2011 2:04 PM
  • HI,

    I want to customise the site master page, I get the error message "Master Page Editing Has been disabled for this site", so I tried following the instructions on this post, but I'm having trouble following these instructions:

    "Go to Site Actions and click on SharePoint Designer Settings under Site Collection Administration and enable the desired settings."

    We have a sharepoint 2010 site, my permission on this site is "full control", but in the "Site Actions" menu, there is no "Sharepoint Designer Settings" option.

    Available options in the Site Actions menu are:

    • New Page
    • New Document Library
    • New Site
    • More Options...
    • View All Site Content
    • Edit in Sharepoint Designer
    • Site Permissions
    • Site Settings

    I have checked both the "more options", "Site Permissions" and "Site Settings" options, and none of them have a "Sharepoint Designer Settings" option. Could you please help me to find this option?

    Monday, February 28, 2011 10:14 PM
  • Hi,

    I had a similar problem in finding the "SharePoint Designer Settings" option.

    Problem was that I was not logged in as a Site Collection Administrator.

    This is how I solved it.

    To view / change site collection administrator do the following

    Go to Central Administration -> Application Management

    Under "Site Collections", click on "Change Site Collection Administrators" 

    After that, refresh your site to reflect the changes.

    Hope this helps.

    Wednesday, March 30, 2011 4:58 AM
  • Your permissions aren't high enough.  You can't change site collection settings if you're not a Site Collection Administrator.  Someone higher has disabled this option.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Wednesday, March 30, 2011 8:06 AM
  • I was able to make myself the secondary site collection administrator and was able to get to the settings via SharePoint Designer and put a check on all 4 options in there. Now when I go to the SharePoint Designer and open the site I no longer have the option to Edit master pages? What would make that dissapear?
    Thanks, Hal
    Thursday, October 6, 2011 5:26 PM
  • This found for me. THanks.... :)

    Raniel Contreras www.ranielcontreras.com

    Thursday, November 20, 2014 2:51 PM