Configuration Manager Client Upgrade Package (MISSING!?) RRS feed

  • Question

  • While working with a client on deploying a ConfigMgr 2012 Infrastructure I have run into a curious issue that I am currently unable to resolve.  The Configuration Manager Client Upgrade Package is completely missing.  When I say completely I mean the following:

    • Package does not appear in content status
    • Package is missing from WMI in the SMS_DistributionPoint class on the Stand-Alone Primary
    • The ability to enable "Automatically Upgrade Clients" is completely grayed out
    • PowerShell script to force a package up date of xxx00003 fail with missing property errors

    There are no records of the package being modified or deleted from the Site Logs or Site Status Records.

    Additional Information:

    MDT 2012 Update 1 integration has been enable and an additional Client Package has been created.  Multiple DPs have been installed and configured with only the latest one throwing an error about the package unable to process.  This leads me to believe that a change has occurred recently but evidence of this change is complete obscured and I cannot locate it.

    Any information that can be obtained would be greatly useful!

    Tuesday, September 11, 2012 4:46 PM

All replies

  • To add an additional piece of information...

    The xxx00003 package is showing in the SQL Database by querying v_package.

    • Edited by Rick Delserone Tuesday, September 11, 2012 5:18 PM Misspelling
    Tuesday, September 11, 2012 5:17 PM
  • A site reset *might* bring it back.

    Torsten Meringer |

    Wednesday, September 12, 2012 6:57 AM
  • I have the identical issue, it seems.

    I dont suppose you have made any headway?

    Thursday, September 20, 2012 6:30 AM
  • I've got the exact same issue.
    • Edited by toadlife Monday, September 24, 2012 8:02 PM
    Monday, September 24, 2012 8:02 PM
  • What issue?

    The client upgrade is a special hidden package. The only way to see that it is there in the console is to go to the Content Status node in the  monitoring workspace. It will *not* display under the Packages node in the Software Library workspace.

    Jason |

    Monday, September 24, 2012 8:10 PM
  • If it is a hidden package, how can I go about and validate or redistribute the package so the Failed to validate content hash is removed from the DP Config Status monitoring workspace?
    Monday, November 12, 2012 10:54 PM
  • EGonzalezJr, did you ever get an answer to your question?
    Monday, January 28, 2013 7:18 PM
  • What issue?

    The client upgrade is a special hidden package. The only way to see that it is there in the console is to go to the Content Status node in the  monitoring workspace. It will *not* display under the Packages node in the Software Library workspace.

    Jason |

    Guessing the "Issue" here then is that its a hidden package.  This threw me at first as well.  Not sure the logic in hiding it when its clearly visible in the client logs when they recieve the policy.  Seems more logical to expose it in the console and just lock it down so it cant be modified so you don't have to go on a wild goose chase to figure out where its coming from.
    Monday, January 28, 2013 9:09 PM
  • I've the same problem, after upgrading with SP1, the package "Configuration Manager Client Upgrade Package" has not been well distributed on secondary sites. 

    So now, a lot of messages which are logged to redistribute it on all of our DistributionPoints (650) of secondary sites and I don't no how to resolve it :

    "The content files for package "P0100003" have not yet arrived from the source site P01. Distribution Manager will try again later to distribute the content"

    As this "hidden" package is not displayed on "Package node", I've tried with powershell command without success : 

    Start-CMContentDistribution -DeploymentPackageId "P0100003" -CollectionName "All Systems" -DistributionPointName ""

    Please have you an other solution ? (copy content files directly from primary to secondary sites ?). 

    Wednesday, January 30, 2013 5:16 PM
  • I've used a PS script to remedy this in the past. Sorry, I don't have it handy but it's in these forums and I don't think it's the same as what you posted above. I could be wrong though

    John Marcum |

    Thursday, January 31, 2013 1:03 AM
  • Finally, to resolve the problem of redistribution of hidden package, I've just apply the followed powershell script given in an other discussion :

    $SiteCode = "XXX"
    $PackageID = "XXX00003"
         $distpoints = Get-WmiObject -Namespace "root\SMS\Site_$($SiteCode)" -Query "Select * From SMS_DistributionPoint WHERE PackageID='$PackageID'"
            foreach ($dp in $distpoints)
                    $dp.RefreshNow = $true

    • Edited by Serge Lalanne Thursday, January 31, 2013 7:50 PM
    • Proposed as answer by PetriAsi Thursday, October 17, 2013 7:04 AM
    Thursday, January 31, 2013 7:49 PM
  • Serge Lalnne-

    Thank you so much for reposting that script.

    Monday, March 4, 2013 5:59 PM
  • What uses this package? Since it is hidden, I had to build a new package from definition in order to upgrade clients from SP1 to R2 using the program/package method of client distribution. Is the built in "hidden" package used at all for upgrading?

    Monday, October 27, 2014 8:08 PM
  • Is the built in "hidden" package used at all for upgrading?

    Yes - when using the automatic client upgrade (that can be found in the hierarchy settings)

    Torsten Meringer |

    Monday, October 27, 2014 8:12 PM
  • I too had this issue show up.  The Package was in the Content Library but not in WMI.  Could not use the console to redistribute it or update the distribution points.

    Also, I could not get the scripts to work right... tried several variations.. but instead, I was able to resolve this by using the "Content Library Explorer" from the SCCM 2012 R2 Toolkit which showed the package as "Invalid" on this DP.  Selected the package number, used the drop down menu from the "Package Menu" and selected redistribute.  All is well again.

    Hope that helps if anyone comes across this issue.

    Wednesday, November 19, 2014 3:07 PM
  • I found that you can actually initiate a Redistribution by right-click menu in Content Status for the package.


    Tuesday, July 3, 2018 12:08 PM
  • Redistribute is not the same as an update though so if there are content changes, like those that happen during an upgrade, redistribute won't have the desired effect. Also, from memory, this is only for the actual client package and not the client upgrade package.

    Jason | | @jasonsandys

    Tuesday, July 10, 2018 11:00 PM