none
Milestone Report columns unhide themselves RRS feed

  • Question

  • Hi I have a simple OData Task table Excel Query that includes 3 columns I don't want the user to see.  Since I can't hide the columns in the actual query definition they have to appear in the spreadsheet when downloaded.  I then hide these columns or make their width 0 but no matter what I do they reappear every time I refresh the query.    Can anyone provide any advice please on how to resolve this?

    thanks

    Dan

    Monday, April 24, 2017 7:27 AM

All replies

  • Hi Dan,

    Try this:

    Select the table -> Go to the Table tools-Design tab -> Open "Properties" in "External Table Data" group -> Here (i) Uncheck "Adjust Column width" (ii) Check "Preserve cell formatting"


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller

    Wednesday, May 3, 2017 1:10 PM
    Moderator
  • Hi Dan,

    Guillaume's answer is correct, but additionally, instead of loading the Odata feed directly into the Excel table (worksheet), you could load it into the Excel Data Model.  From there you can manipulate it all you like using Power Query, and then decide which columns to display in the table.  Additionally, if you don't need certain columns, then don't download them; the data load of course will be faster.


    Ben Howard [MVP] | web | blog | book

    Friday, May 5, 2017 11:09 AM