none
Installation and configuration of Workflow Manager 1.0 - Best practices RRS feed

  • Question

  • Hi guys,

    I have created a new Demo environment to make tests with workflows in Project Server 2013. I have 4 different machines: 1) Domain controller, 2) SQL Server, 3) SharePoint Server & Project Server, 4) Workflow Server.

    I have installed SharePoint Server 2013, Project Server 2013 and Workflow Client on machine 3. And I have installed Workflow Manager, Workflow Client and Service Bus on machine 4.

    The doubt I have is: what´s next? Can I now open up Workflow Client on machine 4 and make all the configurations and then go to machine 3 and run the SharePoint Power Shell command to enable the workflow or am I missing something?

    Thoughts would be appreciated!



    www.raphael-santos.net

    Friday, May 15, 2015 12:42 PM

All replies

  • Hi Raphael,

    Have you run the configuration wizards for Workflow Manager/Service Bus on machine 4?

    https://msdn.microsoft.com/en-us/library/jj193478.aspx

    After that you can try connecting your SharePoint farm to the workflow manager by running the:

    Register-SPWorkflowService

    You may need to wait for a bit in order for the farm to appear as connected to the workflow manager server (in some cases next day!)

    Hope this helps

    Paul

    Monday, May 18, 2015 9:06 AM
  • Hi Paul,

    Thanks for your answer and sorry for the delay in my response.

    Well, I have been trying to configure the Workflow Manager but I am struggling when I try to run the Configuration Wizard on machine 4.

    I set up the Database name, the account that will be used in the workflow and so on, but when I run the Configuration Wizard, I have a error as soon as it starts the process, as follows:

    The log on Event Viewer is:

    =============================================================

    Log Name:      Microsoft-ServiceBus/Admin
    Source:        Microsoft-ServiceBus
    Date:          5/20/2015 1:44:21 PM
    Event ID:      61502
    Task Category: (4032)
    Level:         Error
    Keywords:      
    User:          DOMAIN\username
    Computer:      brz-workflow.company.com.br
    Description:
    System.Data.SqlClient.SqlException (0x80131904): An object or column name is missing or empty. For SELECT INTO statements, verify each column has a name. For other statements, look for empty alias names. Aliases defined as "" or [] are not allowed. Change the alias to a valid name.
       at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
       at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
       at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)
       at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
       at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite, SqlDataReader ds)
       at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource`1 completion, Int32 timeout, Task& task, Boolean asyncWrite)
       at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite)
       at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
       at System.Data.Linq.SqlClient.SqlProvider.Execute(Expression query, QueryInfo queryInfo, IObjectReaderFactory factory, Object[] parentArgs, Object[] userArgs, ICompiledSubQuery[] subQueries, Object lastResult)
       at System.Data.Linq.SqlClient.SqlProvider.ExecuteAll(Expression query, QueryInfo[] queryInfos, IObjectReaderFactory factory, Object[] userArguments, ICompiledSubQuery[] subQueries)
       at System.Data.Linq.SqlClient.SqlProvider.System.Data.Linq.Provider.IProvider.Execute(Expression query)
       at Microsoft.ServiceBus.Commands.Common.ServerManagementStoreDataContext.CreateServerAdministratorLogin(String loginName)
       at Microsoft.ServiceBus.Commands.Common.SecurityHelper.CreateServerAdministratorRole(String accountName, String connectionString)
       at Microsoft.ServiceBus.Commands.NewSBFarmBase.InstallManagementDB(String connectionString, String adminGroup, String runAsName)
       at Microsoft.ServiceBus.Commands.NewSBFarmBase.ProcessRecordImplementation()
    ClientConnectionId:c0838cec-891f-4757-8882-6b451735b2f1
    Event Xml:

    =============================================================

    I am trying to find out the root cause of this issue, but with no success so far.

    Thank you for your help


    www.raphael-santos.net

    Wednesday, May 20, 2015 9:06 PM
  • I should also point out that I am using Windows Server 2012 R2 on all the four servers.

    www.raphael-santos.net

    Thursday, May 21, 2015 12:22 AM
  • Hi Raphael,

    Which version of SQL Server are you using? Also, any aliases configured with SQL Server network utility on the server where you are installing Service Bus/Workflow Manager?

    Paul

    Thursday, May 21, 2015 4:19 PM
  • Hi Paul, and thanks for your answer.

    I am using SQL Server 2012 with Service Pack 1. I didn´t do any other configuration in terms of aliases.

    Today I just created a single server to use as a new test. It is a Windows Server 2012 (not R2), in which I installed Domain Controller, SQL Server, SharePoint and Project Server. All the products installed are in Portuguese-BR. In this machine, I was able to install and configure Workflow Manager without a single problem.

    I am trying to figure out what is wrong/missing, but I suspect that there may be some issue on the Windows Server 2012 R2 in terms of language, because I installed all servers and tools in Portuguese and can´t finish the configuration.

    I am thinking in create a new environment (Windows Server 2012 R2) with everything in English, and try again.

     


    www.raphael-santos.net


    Friday, May 22, 2015 2:37 PM
  • Just to update the discussion:

    Today I created a new server with the following configuration:

    -Windows Server 2012 R2 (EN-US)

    -Service Bus and Workflow Manager 

    -SharePoint Server and Project Server 2013

    I am still unable to configure WF Manager. When I run the Configuration Wizard, I get the same message that "an object or column name is missing". So the hypothesis I though (issue related to the language of SO) was not the root cause of the problem.



    www.raphael-santos.net

    Monday, May 25, 2015 9:55 PM
  • Hi Raphael,

    Just to confirm, are all your machines part of the same domain? Also, are you using the Workflow manager and client 1.0 refresh or other version?

    Paul

    Tuesday, May 26, 2015 5:32 PM
  • Hi Paul. Thanks for answering.

    Yes, the servers are all part of the same domain, and the WF is the 1.0 version.


    www.raphael-santos.net


    Tuesday, May 26, 2015 6:38 PM
  • Hi Raphael,

    There are two versions for Workflow Manager: 1.0 and 1.0 Refresh. Have you tried installing the 1.0 Refresh version?

    Paul

    Wednesday, May 27, 2015 10:14 AM
  • Hi Paul. Thanks for your answer.

    The version 1.0 (not 1.0 refresh) was installed. As it was not possible to fix the issue, as a workaround it was decided that we will reinstall everything but the Database using Windows 2012 (not R2).

    If everything goes ok, I will let you know.

    Thanks for share your time trying to help.

    Raphael



    www.raphael-santos.net

    Thursday, May 28, 2015 5:42 PM
  • Just to give an update on this matter:

    We have rebuild the environment. The Database Server is configured with Windows Server 2012 R2 and SQL Server 2012 SP1, while the Application and Workflow Server was installed in a Windows Server 2012 (not R2).

    This time we were able to configure the Workflow Manager and everything is just working fine.

    Thanks for Paul for taking time trying to help.


    www.raphael-santos.net

    Wednesday, June 3, 2015 7:10 PM